This section lists the start up issues and its solution.
Problem
AdminServer start up fails with following message:
"java.net.SocketException: No buffer space available".
Configuration for the number of AIX file descriptors set for the operating system is substantially high (ulimit
file descriptor) resulting in a buffer overflow that causes remote registration failure with the following message:
The ulimit value is application dependent and applies exclusively to application program data and the application stack. The default number of open files setting (2000) is typically sufficient for most applications. If the value is too low, errors might occur when opening files or establishing connections. Because this value limits the number of file descriptors that a server process might open, a value that is too low prevents optimum performance. For the AIX operating system, the default setting is 2000.
Solution
Increasing the ulimit
file descriptor limits might improve performance. Increasing some of the other limits might be needed depending on your application.
Log in as root.
Perform the following steps to change the open file limit to 10,000 files:
Open the command window.
Locate and edit /etc/security/limits file to add the following lines to the user account on which the AdminServer process runs:
nofiles = 10000 nofiles_hard = 10000
Save the file and restart AIX.
In a command window, decrease the TCP_TIMEWAIT interval with the following command to set the state to 15 seconds (which allows TCP to release closed connections faster and increases the number of available resources for open connections).
/usr/sbin/no –o tcp_timewait =1
Tune the following parameters to 256k, as shown:
no -a |grep space tcp_recvspace = 262144 tcp_sendspace = 262144 udp_recvspace = 262144 udp_sendspace = 262144
Tune the following parameters as indicated here:
no -o rfc1323=1 no -o sb_max=4194304
Cause:
This is normal and expected behavior for the Managed Server where the OAM Server runs because the IAMSuiteAgent agent is started before the OAM Server.
The IAMSuiteAgent is deployed on every WebLogic container. When the WebLogic container starts, the agent tries to connect to the OAM Server. If it fails to connect, this message is logged and the agent tries to establish the connection in subsequent requests. When the agent is successful, this message is no longer displayed.
Solution
If the connection to the OAM Server is not successful, the IAMSuiteAgent falls back and the WebLogic container handles protection (including login), if it is configured.