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Oracle® Fusion Middleware Oracle Identity and Access Managementデプロイメント・ガイド
11gリリース2 (11.1.2.2.0)
E53414-02
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8 Oracle Identity and Access Managementデプロイメントのトラブルシューティング

この章では、Oracle Identity and Access Managementデプロイメント・ツールを使用している場合に発生する可能性のある一般的な問題と、それらの解決方法について説明します。

表示される可能性のあるエラー・メッセージの詳細は、この章およびOracle Fusion Middlewareエラー・メッセージ・リファレンスを参照してください。

この章では次の項について説明します。

8.1 トラブルシューティングのスタート・ガイド

この項ではログ・ファイルの使用法と、デプロイメント失敗からリカバリする方法について説明します。内容は次のとおりです。

8.1.1 ログ・ファイルの使用

ウィザードを使用してデプロイメントを実行している場合、任意のフェーズ画面から、現在のフェーズのログを表示するには、「ログ」フィールドの下のアイコンをクリックします。ログが表示された新しいウィンドウが開きます。この新しいウィンドウの上部にある検索ボックスを使用して、ログを検索できます。ログ・ウィンドウは自動的にはリフレッシュされません。ログをリフレッシュするには、このウィンドウの上部にある検索ボックスの横の「リフレッシュ」ボタンをクリックします。

ウィザードが実行中でないときにフェーズが失敗した理由を確認するには、ログ・ディレクトリの下にある当該ログ・ファイルを調べます。LinuxではLCM_HOME/provisioning/logs/hostnameにあります。

LCM_HOMEはデプロイメント・プロファイルを作成したときに「インストールと構成」画面で指定したライフサイクル管理ストアの場所のディレクトリです。第4.4.1.8項「インストールと構成の場所の選択」を参照してください。

8.1.2 Oracle Identity and Access Managementデプロイメント失敗からのリカバリ

Oracle Identity and Access Managementデプロイメントにはバックアップやリカバリの仕組みがありませんので、失敗の場合は最初からやり直す必要があります。

さらに、実行する回避策で、Oracle Identity and Access Managementデプロイメントの再実行が必要な場合は、再実行の前に環境をクリーンアップする必要があります。環境のクリーンアップの詳細は、付録A「IAMデプロイメント再実行の前に環境をクリーンアップする」を参照してください。

8.2 一般的な問題の解決

この項では、一般的な障害と解決策について説明します。内容は次のとおりです。

8.2.1 WebLogicパッチ適用時にヌル・エラーが発生する

問題

Oracle Identity and Access Managementのデプロイメント中に、デプロイされるすべての製品(WebLogicを含む)にパッチが適用されます。これにはSmart Updateのbsuコマンドの実行が伴います。このコマンドが、詳細なエラー・メッセージを出さずに失敗することがあります。

原因

この場合、失敗はbsuコマンドがサポートするパス名より長いディレクトリ・パスが原因と思われます。bsuコマンドを手動で実行し、-logオプションを渡し、次のようなメッセージを含むスタック・トレースを探すことによりこれを検証できます。

java.lang.IllegalArgumentException: 
Node name?a?very?long?path?which?may?cause?problems?leading?to?an?IDMTOP?products?dir?utils?bsu?cache_dir too long

詳細は、パッチをOracleWebLogicサーバーに適用するOracle Smart更新プログラムのコマンド行インタフェースの使用に関する章を参照してください。

解決策

IDMデプロイメントを計画する際には、IDM_TOPパスの長さが45文字以下であることを確認してください。

8.2.2 デプロイメント後にIdentity Managementパッチ・マネージャの進行状況コマンドがアクティブ・セッションを表示する

問題

Oracle Identity and Access Managementのデプロイメント完了後にIdentity Managementパッチ・マネージャのprogressコマンドを実行した場合に、出力にIdentity Managementデプロイメント固有のアクティブ・セッションが表示されて「ACTIVE」とリストされており、一連の「PLANNED」手順が含まれています。

解決策

このエラーは無視しても問題ありません。デプロイメントにより実行されるパッチ・セッションが完了し、実行が必要なすべての手順が実行されました。新しいパッチ・セッションを作成すると、エラーなしでこの特別セッションにサイレントで置き換わります。

8.2.3 Oracle Identity and Access Managementデプロイメント・ウィザードがハングする(LinuxおよびUNIX)

問題

The Oracle Identity and Access Managementデプロイメント・ウィザードがハングします。「次へ」ボタンも「戻る」ボタンもアクティブではありません。

原因

この問題はNFSファイルが処理する古いデータが原因です。

解決策

LinuxまたはUNIXの場合は、次のコマンドを発行します。

df –k

dfコマンドが成功しても、将来分析が必要となる場合に備えてこのコマンドの出力を記録してください。たとえば、スクリーンショットをとります。

dfコマンドがハングしたり成功しない場合は、システム管理者と共同でNFS問題を解決してください。

NFS問題が解決し、dfコマンドが正常に終了したら、デプロイメントを再度実行します。

8.2.4 64ビットLinuxでRCUを実行するとエラーが発生する

問題

リポジトリ作成ユーティリティ(RCU)はIdentity and Access Managementコンポーネントに必要なデータベース・スキーマを作成します。

64ビットLinuxでは、./rcuコマンドをRCU_HOME/binディレクトリで実行してRCUを実行しようとすると、次のエラー・メッセージが表示されます。

Failed to initialize logger with location
:/home/oracle/rcuHome/rcu/log/logdir.2013-02-25_15-42/rcu.log
Initializing logger using the following location :/tmp/logdir.2013-02-25_15-42/rcu.log
Exception in thread "main" java.lang.UnsatisfiedLinkError:
/home/oracle/rcuHome/jdk/jre/lib/i386/xawt/libmawt.so: libXext.so.6: cannot open
shared object file: No such file or directory
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1703)
at java.lang.Runtime.load0(Runtime.java:770)
at java.lang.System.load(System.java:1003)
at java.lang.ClassLoader$NativeLibrary.load(Native Method)
at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1807)
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1724)
at java.lang.Runtime.loadLibrary0(Runtime.java:823)
at java.lang.System.loadLibrary(System.java:1028)
at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Toolkit.loadLibraries(Toolkit.java:1605)
at java.awt.Toolkit.<clinit>(Toolkit.java:1627)
at com.jgoodies.looks.LookUtils.isLowResolution(LookUtils.java:484)
at com.jgoodies.looks.LookUtils.<clinit>(LookUtils.java:249)
at com.jgoodies.looks.plastic.PlasticLookAndFeel.<clinit>(PlasticLookAndFeel.java:135)
at oracle.sysman.assistants.rcu.ui.InteractiveRCUModel.<init>(InteractiveRCUModel.java:117)
at oracle.sysman.assistants.rcu.Rcu.execute(Rcu.java:307)
at oracle.sysman.assistants.rcu.Rcu.main(Rcu.java:363)

原因

このエラー・メッセージはRCUが32ビットLinux以外ではサポートされていないために表示されます。

解決策

RCUを64ビットLinuxで実行するには、次の回避策を利用します。

  1. RCU_HOMEディレクトリに移動し、jdkディレクトリのバックアップを作成します。

    cd RCU_HOME
    mv jdk jdk.bak
    
  2. lnコマンドを使用して、64ビットJDKフォルダへのリンクを作成します。

    ln -s /home/oracle/jdk1.6.0_35 jdk
    
  3. ./rcuコマンドをRCU_HOME/binディレクトリから実行します。

8.2.5 その他のIdentity and Access Managementデプロイメントの問題

その他のデプロイメントの問題が発生している場合は、Oracle Fusion Middleware Oracle Identity and Access Managementエンタープライズ・デプロイメント・ガイドのIdentity and Access Managementデプロイメントのトラブルシューティングに関する項を参照してください。この項には、デプロイメントに関連するその他の一般的な問題の情報が記載されています。

8.3 My Oracle Supportを使用したその他のトラブルシューティング情報

Oracle Fusion Middlewareの問題解決にMy Oracle Support(以前のMetaLink)を使用できます。My Oracle Supportには、次のような有用なトラブルシューティング・リソースが含まれています。

  • ナレッジ・ベース記事

  • コミュニティ・フォーラムとディスカッション

  • パッチとアップグレード

  • 動作保証情報


注意:

My Oracle Supportを使用すると、サービス・リクエストのログ記録もできます。

My Oracle Supportにはhttps://support.oracle.comからアクセスできます。