Set Up IDEs and Git Clients

You can use IDEs such as Eclipse IDE, NetBeans IDE, and Oracle JDeveloper to access projects, as well as your project's Git repositories, issues, and builds. Before using an IDE, you must install and configure the required plugins.

You can also use any Git client, such as the Git command-line interface (CLI), to access Git repositories from your computer. You can’t access projects, issues, and builds from a Git client.

Eclipse IDE

To access DevCS projects and Git repositories from the Eclipse IDE, install the plugins required by Oracle Cloud and the Git from the Eclipse marketplace. After you install the plugins, you can use the Eclipse IDE to develop applications for Oracle Cloud.

If you’re using the Oracle Enterprise Pack for Eclipse (OEPE) IDE, the Oracle Cloud and the Git plugins are installed by default.

Eclipse IDE uses EGit to access and manage Git repositories. For more information about EGit and the Git actions you can perform, see http://eclipse.org/egit/ and the EGit documentation at http://wiki.eclipse.org/EGit/User_Guide.
  1. Open the Eclipse IDE.
  2. From the Help menu, select Eclipse Marketplace.
  3. In the Search tab, search for Oracle Cloud Tools, and click Go.
  4. In the search result, find the Oracle Cloud Tools plugin and click Install.
  5. Click < Install More.
  6. In the Search tab, search for EGit, and click Go.
  7. In the search result, find the EGit - Git Integration for Eclipse plugin, and click Install.
  8. Click Install Now.
  9. On the Confirm Selected Features page of the wizard, make sure that the check boxes of Oracle Cloud Tools and EGit are selected, and click Confirm.
  10. In the Review Licenses page, select the I accept the terms of the license agreements option to agree to the licensing terms and click Finish.
  11. Wait for the software to install.
  12. If prompted, restart the IDE.

After installing the Git plugin, you should set the username and email properties. DevCS pages display your username and email address as the committer's name and email ID.

  1. From the Window menu of the Eclipse IDE, select Preferences.

  2. In the Preferences dialog box, search for Git.

  3. In the Team > Git > Configuration page, set the properties.

NetBeans IDE

To access your projects and Git repositories from the NetBeans IDE, install the plugins required by DevCS and Git.

  1. Open the NetBeans IDE.
  2. From the Tools menu, select Plugins.
  3. In the Plugins dialog box, click the Available Plugins tab.
  4. Search for Oracle Developer Cloud Service and Git, and select their Install check boxes.
    If a plugin is pre-installed, check the Installed tab and make sure the plugin is active.
  5. Click Install.
  6. Read the license agreement and select the I accept the terms in all of the license agreements check box.
  7. Click Install.
After installing the Git plugin, you should set the username and email properties. DevCS pages display your username and email address as the committer's name and email ID.
  1. From the Team menu, select Git > Open Global Configuration.

  2. In the .gitconfig file, set the properties, and save the file.

JDeveloper

Oracle JDeveloper comes pre-installed with the plugins required by DevCS and Git. No additional configuration is required.

Git Command-Line Interface

If you can’t use an IDE to access and update files of a Git repository, you can install and configure a Git client on your computer. The Git command line-interface (CLI) is the most popular Git client.

Here are the steps to download, install, and configure the Git CLI.

  1. Download and install the Git CLI.

    On Windows, use the Git Bash CLI to access project Git repositories. You can download Git Bash (version 1.8.x or later) from http://git-scm.com/downloads.

    On Linux and Unix, install Git using the preferred package manager. You can download Git for Linux and Unix from http://git-scm.com/download/linux.

  2. Configure variables to set up your name and email address. DevCS pages display your username and email address as the committer's name and email ID.

    • To configure your user name, set the user.name variable.

      Example: On the Git CLI command prompt, enter git config --global user.name "John Doe"

    • To configure your email address, set the user.email variable.

      Example: git config --global user.email "johndoe@example.com"

    • To configure the proxy server or disable SSL, set http.sslVerify and http.proxy variables.

      Examples:

      git config --global http.sslVerify false

      git config --global http.proxy http://www.testproxyserver.com:80/

Tip:

To find out the value of a variable, use the git config <variable> command.

Example:

git config user.name

Access a Git Repository using SSH

You can use SSH keys to configure and connect to a DevCS project's Git repository using an SSH tunnel. Note that DevCS accepts RSA keys only.

To access project Git repositories via SSH, follow these steps:
  1. Generate an SSH private-public key pair on your computer

  2. Configure your Git client to access the private key on your computer

  3. Upload the public key to your User Preferences page

If you use multiple computers to access Git repositories, generate an SSH key pair from each computer and upload its public key to your User Preferences page.

Generate an SSH Key

To generate an SSH key pair, you can use any SSH client, including the Git CLI.

These steps assume you’re using Git CLI to generate the SSH keys.
  1. Open the Git CLI.
  2. On the command prompt, enter ssh-keygen -t rsa.
  3. When prompted, enter a file name for the key and press Enter.
    If you don’t want to specify a file name, leave the name blank and press Enter. By default, the key pair files are saved as id_rsa.pub and id_rsa in the .ssh sub-directory under the Git HOME directory. For example, on Windows, the files are saved in C:\Users\<USER_PROFILE>\.ssh\.
  4. Enter a passphrase and press Enter. If you don’t want to specify a passphrase, leave it blank and press Enter.
    When prompted to confirm the passphrase, enter the same passphrase. If you didn’t specify a passphrase earlier, leave it blank and press Enter.

Git CLI always looks at the C:\Users\<USER_PROFILE>\.ssh\ directory to access the private key. If you aren’t using the Git CLI, you may need to configure your Git client or your IDE to access the private SSH key. Check the Git client’s or IDE’s documentation to find out how to do that.

Add the Public SSH Key to Your DevCS Account

After generating an SSH private-public key pair, add the public key to your User Preferences page’s Authentication tab.

  1. On the computer where you generated the SSH key pair, navigate to the directory where the public key is saved.
  2. Open the public key file in a text editor, select the contents, and copy them to the clipboard.
  3. In DevCS, click the user avatar, and select Preferences.
  4. Click the Authentication tab.
  5. Click Add Key.
  6. In the New SSH Key dialog box, enter a unique name and paste the SSH key that you copied in Step 2.
  7. Click Create.
  8. To the left of the User Preferences title, click Close Close to return to the last opened page.