Supported Oracle Linux 8 Distributions for x86-64

Use the following information to check supported Oracle Linux 8 distributions:

Table 4-1 x86-64 Oracle Linux 8 Minimum Operating System Requirements

Item Requirements

SSH Requirement

Ensure that OpenSSH is installed on your servers. OpenSSH is the required SSH software.

Oracle Linux 8

Minimum supported versions:

  • Oracle Linux 8.1 with the Unbreakable Enterprise Kernel 6: 5.4.17-2011.0.7.el8uek.x86_64 or later

  • Oracle Linux 8 with the Red Hat Compatible Kernel: 4.18.0-80.el8.x86_64 or later

Note:

Oracle recommends that you update Oracle Linux to the latest available version and release level.

Packages for Oracle Linux 8

Subscribe to the Oracle Linux 8 channel on the Unbreakable Linux Network, or configure a yum repository from the Oracle Linux yum server website, and then install the Oracle Database Preinstallation RPM, oracle-database-preinstall-19c. The Oracle Database Preinstallation RPM, oracle-database-preinstall-19c, automatically installs all required packages listed in the table below, their dependencies for Oracle Grid Infrastructure and Oracle Database installations, and also performs other system configuration. If you install the Oracle Database Preinstallation RPM, oracle-database-preinstall-19c, then you do not have to install these packages, as the Oracle Database Preinstallation RPM automatically installs them.


bc
binutils
elfutils-libelf
elfutils-libelf-devel
fontconfig-devel
glibc
glibc-devel
ksh
libaio
libaio-devel
libXrender
libX11
libXau
libXi
libXtst
libgcc
libnsl
librdmacm
libstdc++
libstdc++-devel
libxcb
libibverbs
make
policycoreutils
policycoreutils-python-utils
smartmontools
sysstat

Note:

If you intend to use 32-bit client applications to access 64-bit servers, then you must also install (where available) the latest 32-bit versions of the packages listed in this table.

Optional Packages for Oracle Linux 8

Based on your requirement, install the latest released versions of the following packages:


ipmiutil (for Intelligent Platform Management Interface)
libnsl2 (for Oracle Database Client only)
libnsl2-devel (for Oracle Database Client only)
libvirt-libs (for KVM)
net-tools (for Oracle RAC and Oracle Clusterware)
nfs-utils (for Oracle ACFS)

Patches and Known Issues

  • For a list of latest Oracle Database Release Updates (RU) and Release Update Revisions (RUR) patches for Oracle Linux Enterprise Linux 8 and Red Hat Enterprise Linux 8, visit My Oracle Support

  • For a list of known issues and open bugs for Oracle Linux 8 and Red Hat Enterprise Linux 8, read the Oracle Database Release Notes

KVM virtualization

Kernel-based virtual machine (KVM), also known as KVM virtualization, is certified on Oracle Database 19c for all supported Oracle Linux 8 distributions. For more information on supported virtualization technologies for Oracle Database, refer to the virtualization matrix:

https://www.oracle.com/database/technologies/virtualization-matrix.html