2 Oracle Fusion Middleware 12c (12.2.1.4.0) Interoperability and Compatibility

This chapter summarizes the specific interoperability and compatibility considerations and issues for the Oracle Fusion Middleware 12c (12.2.1.4.0)release.

This chapter contains the following sections.

Products and Features Available in Oracle Fusion Middleware 12c (12.2.1.4.0)

Oracle Fusion Middleware12c (12.2.1.4.0) includes updates to the following products that were originally distributed in Oracle Fusion Middleware 12c (12.1.3):

  • Oracle JDeveloper

  • Oracle WebLogic Server and Coherence

  • Oracle Fusion Middleware Infrastructure

  • Oracle HTTP Server

  • Oracle Data Integrator

  • Oracle GoldenGate Studio

  • Oracle SOA Suite

  • Oracle Business Process Management

  • Oracle Service Bus

  • Oracle Managed File Transfer

  • Oracle Event Processing (Oracle Stream Explorer)

Oracle Fusion Middleware12c (12.2.1.4.0) also includes the following Oracle Fusion Middleware products, which have been reintroduced and re-engineered for Oracle Fusion Middleware 12c:

  • Oracle WebCenter Content

  • Oracle WebCenter Portal

  • Oracle WebCenter Sites

  • Oracle Business Intelligence

  • Oracle Traffic Director

  • Oracle MapViewer

This is not a definitive list of products released with Oracle Fusion Middleware 12c (12.2.1.4.0). For information about all the Oracle Fusion Middleware12c (12.2.1.4.0) products, see Understanding Oracle Fusion Middleware.

Oracle Fusion Middleware Compatibility with Previous Releases

Refer to the following sections for information on Oracle Fusion Middleware12c (12.2.1.4.0) compatibility with previous Oracle Fusion Middleware releases:

Compatibility with Oracle Fusion Middleware 11g

If you are currently running Oracle WebLogic Server 11g products, then be aware of the following:

  • Do not install Oracle WebLogic Server12c (12.2.1.4.0) in the same Middleware home or Oracle home as any previous Oracle Fusion Middleware 11g or Oracle WebLogic Server 11g products. This includes Oracle WebLogic Server 10.3.

  • Do not install any Oracle Fusion Middleware 11g products in the same Oracle home as Oracle Fusion Middleware 12c (12.2.1.4.0).

Similarly, you cannot extend an existing Oracle Fusion Middleware 11g or Oracle WebLogic Server 11g domain with Oracle WebLogic Server 12c (12.2.1.4.0).

Compatibility with Oracle Fusion Middleware 12c (12.2.1.4.0)

If you are currently running Oracle WebLogic Server12c (12.2.1.4.0) products, then be aware of the following:

  • Do not install Oracle WebLogic Server12c (12.2.1.4.0) in the same Oracle home used by Oracle Fusion Middleware 12c (12.1.3).

  • Do not install any Oracle Fusion Middleware 12c (12.1.3) products in the same Oracle home as Oracle Fusion Middleware12c (12.2.1.4.0).

Similarly, you cannot extend an existing Oracle Fusion Middleware 12c (12.1.3) domain with Oracle WebLogic Server 12c (12.2.1.4.0).

Interoperability with Supported Databases

Oracle Fusion Middleware12c (12.2.1.4.0) supports specific database versions for hosting the required Oracle Fusion Middleware product and component schemas and for other specific product features.

The certification information on the Oracle Technology Network provides information about the specific database versions supported by Oracle Fusion Middleware. For more information on using the certification information, see Using the Oracle Certification Matrixes.

However, in some cases, an Oracle Fusion Middleware feature or component requires a more specific database version or a specific database feature that is available in a particular database release.

The following sections describe some of those specific features and database requirements:

Oracle Database Interoperability Considerations

In addition to the information available in the certification information on the Oracle Technology Network, Table 2-1 provides some additional considerations when using specific Oracle database features.

Table 2-1 Database Version Requirements for Selected Products and Features

Product or Feature Database Requirement Restrictions More Information

Using SCAN addresses with GridLink data sources.

Oracle Database 11.2 or later, with Single Client Access Name (SCAN) enabled

None

SCAN Addresses in Administering JDBC Data Sources for Oracle WebLogic Server

JDBC Multi Data Sources

All Oracle Database versions supported by Oracle Fusion Middleware

None.

Configuring JDBC Multi Data Sources in Administering JDBC Data Sources for Oracle WebLogic Server

Using Edition-Based Redefinition (EBR) when creating schemas in an Oracle database

Oracle Database 11.2 or later

EBR is supported by all Oracle Fusion Middleware schemas, except where noted.

Support for pluggable databases (PDBs)

Oracle Database 12.1 or later

PDBs are supported for Oracle Fusion Middleware schemas.

Connecting to a multitenant container database (CDB) from the Repository Creation Utility is not supported.

Managing Pluggable Databases in Enterprise Manager Lifecycle Management Administrator's Guide.

Java DB Interoperability Considerations

Oracle supports the use of Java DB as a repository for the required Oracle Fusion Middleware schemas in a limited set of Oracle WebLogic Server domain configurations.

Specifically, for evaluation or development purposes only, you can use Java DB to host the required schemas for an Oracle Fusion Middleware Infrastructure domain.

For example, you can install the required Oracle Fusion Middleware schemas in a Java DB database and reference the Java DB data sources during the configuration of an Oracle Fusion Middleware Infrastructure domain.

Also, by default, the Oracle JDeveloper Integrated WebLogic Server, which is installed with the Oracle SOA Suite Quick Start and Oracle Business Process Management Quick Start installers, is configured to use a pre-configured instance of Java DB. For more information, see Installing SOA Suite and Business Process Management Suite Quick Start for Developers.

For more information about Java DB, see the following URL:

http://docs.oracle.com/javadb

For more information on certified databases, see Using the Oracle Certification Matrixes.

Additional Database Interoperability Considerations

The certification matrices and My Oracle Support Certifications define the following terms to differentiate between types of database support:

Application Data Access

Application Data Access refers to those applications that use the database for data access only and do not take advantage of WebLogic Server features that are Database-dependent. WebLogic Server support of databases used for application data access only are less restrictive than for database-dependent features.

WebLogic Server supports application data access to databases using JDBC drivers that meet the following requirements:

  • The driver must be thread safe.

  • The driver must implement standard JDBC transactional calls, such as setAutoCommit() and setTransactionIsolation(), when used in transactional aware environments.

Note the following restrictions:

  • JDBC drivers that do not implement serializable or remote interfaces cannot pass objects to an RMI client application.

  • Simultaneous use of automatic database connection failover and load balancing and global transactions (XA) with a highly available (HA) DBMS architecture is supported with Oracle DB RAC only, and only for the Oracle DB RAC versions indicated on the System worksheet. These HA capabilities are supported by Active GridLink for RAC and Multi-Data Sources with RAC. These HA capabilities are not supported on other Oracle DB RAC versions or with other HA DBMS technologies on other non-Oracle DB products. Multi-Data Sources are supported on other Oracle DB versions, and with non-Oracle DB technologies, but not with simultaneous use of automatic failover and load balancing and global transactions.

  • Application data access to databases meeting the restrictions is supported on other Oracle DB versions, in addition to ones documented in the certification matrix.

  • WebLogic Type 4 JDBC drivers also support the following databases. For these databases, WebLogic Server supports application data access only, and does not support WebLogic Server database-dependent features:

    • DB2 V9.1 for z/OS, DB2 V10 for z/O

    • Informix 11.0, Informix 11.5, Informix 11.7

Database Dependent Features

When WebLogic Server features use a database for internal data storage, database support is more restrictive than for application data access. The following WebLogic Server features require internal data storage:

  • Container Managed Persistence (CMP)

  • Rowsets

  • JMS/JDBC Persistence and use of a WebLogic JDBC Store

  • JDBC Session Persistence

  • RDBMS Security Providers

  • Database Leasing (for singleton services and server migration)

  • JTA Logging Last Resource optimization

  • JDBC TLog

Oracle HTTP Server Interoperability and Compatibility

This section summarizes the most common interoperability scenarios for Oracle HTTP Server and other Oracle Fusion Middleware components. The information in this section was accurate as of the publishing of this document.

For complete information about the interoperability of Oracle HTTP Server, see the certification information available on the Oracle Technology Network. For more information, see Using the Oracle Certification Matrixes.

Before you start, consider the following:

Interoperability with Oracle Identity Management Products

Oracle Identity Management (IDM) consists of the following four products:
  • Oracle Access Management (OAM)

  • Oracle Identity Governance (OIG)

  • Oracle Internet Directory (OID)

  • Oracle Unified Directory (OUD)

You can install OAM and OIG using the same product distribution (fmw_12.2.1.4.0_idm.jar). To install OID and OUD, use the platform-specific OID and fmw_12.2.1.4.0_oud.jar distributions respectively.

This section provides information about Oracle Identity Management Interoperability with Oracle Fusion Middleware 12c:

Interoperability with Oracle Access Management and Oracle Identity Governance

Table 2-2 shows the interoperability of Oracle Fusion Middleware12c (12.2.1.4.0) with the available versions of Oracle Access Management and Oracle Identity Governance.

When reviewing the interoperability of Oracle Identity and Access Management and Oracle Fusion Middleware 12c, consider the following:

  • Oracle Access Management and Oracle Identity Governance are installed in a separate Oracle home and configured in a separate Oracle WebLogic Server domain.

    For more information about Oracle home, see Oracle Home and Domain Extension Interoperability.

  • The information shown in Table 2-2 was accurate at the time this document was published. Always check the certification information on the Oracle Technology Network for the latest certification information.

  • Oracle HTTP Server 12c includes WebGate 12c, which can be used to integrate Oracle WebLogic Server or Oracle Fusion Middleware Infrastructure with Oracle Access Manager 11g (11.1.1.5) or later.

Note:

From 12c (12.2.1.4.0) onwards, you can install Oracle Access Management (OAM) and Oracle Identity Governance (OIG) from the Oracle Identity and Access Management product distribution (fmw_12.2.1.4.0_idm.jar). After you have installed the binaries, you can configure the domains for Oracle Access Management and Oracle Identity Governance individually.

Table 2-2 Oracle Access Management and Oracle Identity Governance Interoperability with Oracle Fusion Middleware 12c

Product / Version Oracle Identity and Access Management 11.1.1.9 or later Oracle Identity and Access Management 11g Release 2 (11.1.2.3) Oracle Access Management and Oracle Identity Governance 12c (12.2.1.4.0)

Oracle WebLogic Server and Coherence 12c (12.2.1.4.0)

Green check icon
Green check icon
Green check icon

Oracle Fusion Middleware Infrastructure 12c (12.2.1.4.0)

Green check icon
Green check icon
Green check icon

Interoperability with Oracle Internet Directory and Oracle Unified Directory

Table 2-2 shows the interoperability of Oracle Fusion Middleware12c (12.2.1.4.0) with the available versions of Oracle Internet Directory (OID) and Oracle Unified Directory(OUD).

When reviewing the interoperability of OID and OUD with Oracle Fusion Middleware 12c, consider the following:

  • Usually, you can use currently available versions of Oracle Internet Directory and Oracle Unified Directory with Oracle Fusion Middleware 12c because Oracle Internet Directory and Oracle Unified Directory are installed in a separate Oracle home and configured in a separate Oracle WebLogic Server domain.

    For more information about Oracle home, see Oracle Home and Domain Extension Interoperability.

  • The information shown in Table 2-3 was accurate at the time this document was published. Always check the certification information on the Oracle Technology Network for the latest certification information.

Table 2-3 Oracle Internet Directory (OID) and Oracle Unified Directory Interoperability with Oracle Fusion Middleware 12c

Product / Versions Oracle Internet Directory and Oracle Virtual Directory 11.1.1.5 or later Oracle Unified Directory 11g (11.1.2.3) Oracle Internet Directory and Oracle Unified Directory 12c (12.2.1.4.0)

Oracle WebLogic Server and Coherence 12c (12.2.1.4.0)

Green check icon
Green check icon
Green check icon

Oracle Fusion Middleware Infrastructure 12c (12.2.1.4.0)

Green check icon
Green check icon
Green check icon

Oracle Web Services Interoperability

Web services are Web-based applications that use open, XML-based standards and transport protocols to exchange data with clients.

Web services are developed using Java Technology APIs and tools provided by an integrated Web services category.

Oracle supports several Web services categories, which are associated with specific Oracle Fusion Middleware products and components. For more information about Web Services, see Understanding Web Services.

These Oracle Web services categories support a variety of Web services message formats, capabilities, and security features. While this support varies from one category to another, all the Oracle Web services categories support the following standard features in the communication messages they send and receive:

  • Plain SOAP

  • WS-Security, With SSL

  • WS-Security, No SSL

As a result, if you develop Web services applications that support these types of Web services messages, then the services you create can be used Interoperability with any of the Oracle Web services security categories.

For a more information about the supported WS-Security scenarios between the categories and information on how to configure Web services endpoints, see Interoperability Solutions Guide for Oracle Web Services Manager.

Oracle Home and Domain Extension Interoperability

The following sections provide information about the interoperability of Oracle Fusion Middleware products when installing products in an Oracle home and when extending existing Oracle WebLogic Server domains:

Oracle Home Interoperability

When installing Oracle Fusion Middleware products, be sure that each Oracle home you create contains only products that are at the same version or patch set. Each product has its own maintenance schedule, and it is possible that future interoperability issues could result.

For example, unless otherwise documented, you cannot install Oracle SOA Suite 11g Release 1 (11.1.1.9.0) into the same Oracle home with 12c.

This rule applies when installing new products, as well as when applying patches.

Domain Extension Interoperability

You can extend an existing Oracle Fusion Middleware product domain to support another Oracle Fusion Middleware product, as long as they are the same version number or patch set.

For example, if you have an existing SOA Suite 11g Release 1 (11.1.1.7.0) domain, do not attempt to extend or patch that domain using Oracle Fusion Middleware 12c. To avoid potential interoperability issues, wait until both suites are available at equivalent versions.

Note:

Oracle does not support the configuration of Oracle Business Process Management 12c and Oracle SOA Suite for Healthcare Integration 12c in the same domain. If you plan to use both these Oracle Fusion Middleware products, be sure to configure them in separate domains.

Interoperability with Custom and Client Applications

When you upgrade to Oracle Fusion Middleware 12c, or if you apply any patches on an existing Oracle Fusion Middleware, you should consider the impact on your custom applications, such as:

  • Applications written using JDeveloper

  • Applications using any other IDE, but also using any of the Oracle Fusion Middleware public Java APIs.

Specifically, the information in this section applies in the following situations:

  • If you have created custom applications that you have deployed on Oracle Application Server 10g or Oracle Fusion Middleware 11g.

  • If you have created or if you maintain client applications that interact with applications you deployed on Oracle Application Server 10g or Oracle Fusion Middleware 11g.

Oracle attempts to support binary and source-level compatibility between the current version of Fusion Middleware and patch set updates applied to it. Where incompatibilities arise with public interfaces, they are documented in the related API reference guides. For more information about APIs, see Reference and APIs in the Oracle Fusion Middleware12c (12.2.1.4.0) documentation library.

Oracle recommends that you ensure the business applications adopting new versions or upgrades are tested through your normal release process to ensure there are no regressions.

In general, applying Oracle Fusion Middleware patch sets should require no additional changes to your custom or client applications. When upgrading, however, you should expect some changes.

For more information about compatibility with WebLogic Server, see WebLogic Server 12.2.1 Compatibility with Previous Releases in Upgrading Oracle WebLogic Server.

Oracle Data Integration 12c (12.2.1.4.0) Interoperability with Other Fusion Middleware Products

Oracle Data Integrator is designed to be used with specific Oracle SOA Suite, Oracle Enterprise Data Quality (EDQ), and Oracle GoldenGate software releases. The following table shows which releases of these software products can be used with Oracle Data Integrator 12c (12.2.1.4.0).

The asterisk (*) indicates that the software is interoperable with releases later than one shown.

Oracle Data Integrator 12c (12.2.1.4.0)Component Can be used with... Interoperability Details

Oracle Data Integrator (Agent, Console, Studio)

Oracle Enterprise Data Quality 11.1.1.7.*

You can configure, launch, and monitor EDQ jobs from Oracle Data Integrator.

Oracle Data Integrator (Agent, Studio)

Oracle Enterprise Data Quality 12.*

You can launch and monitor EDQ jobs from Oracle Data Integrator.

Oracle Data Integrator (Agent, Console, Studio)

Oracle GoldenGate 11.2.1.*

You can configure, launch, and monitor GoldenGate jobs from Oracle Data Integrator.

Oracle Data Integrator (Agent, Console, Studio)

Oracle GoldenGate 12.*

You can configure, launch, and monitor GoldenGate jobs from Oracle Data Integrator.

Oracle Data Integrator Agent

Oracle SOA Suite 11.1.1.9.0

Oracle SOA Suite 12.2.1.0.0

  • Oracle Data Integrator can invoke SOA Web services.

  • Oracle SOA Suite can launch ODI Web services.

Oracle Data Integrator Agent

Oracle SOA Suite 12.2.1.0.0

  • You can install Oracle Data Integrator in the same Oracle home as Oracle SOA Suite

  • Oracle Data Integrator can invoke SOA Web services.

  • Oracle SOA Suite can launch ODI Web services.

Oracle Enterprise Data Quality 12c (12.2.1.4.0) Interoperability with Other Fusion Middleware Products

Oracle Enterprise Data Quality (EDQ) is designed to be used with specific releases of the EDQ Address Verification Server and EDQ Customer Data Services Pack. The following table shows which releases of these software products can be used with EDQ 12c (12.2.1.4.0).

The asterisk (*) indicates that the software is interoperable with releases later than one shown.

Oracle Enterprise Data Quality 12c (12.2.1.4.0) Component Can be used with...

Oracle Enterprise Data Quality

Oracle Enterprise Data Quality Address Verification Server 14.* and 15.*

Oracle Enterprise Data Quality Seibel Connector

Oracle Enterprise Data Quality Customer Data Services Pack 11.* and 12.*

Oracle GoldenGate Interoperability with Other Fusion Middleware Products

Oracle GoldenGate is designed to be used with specific releases of the GoldenGate software components. The following table shows which releases of these components can be used with GoldenGate 12c (12.2.1.4.0)*.

Oracle GoldenGate 12c (12.2.1.4.0)* Component Can be used with...

Oracle GoldenGate Studio 12.2.1.4.0*

Oracle GoldenGate 12.2.0.1*

Oracle GoldenGate 12.3.0.1* Classic

Oracle GoldenGate 18.1* Classic

Oracle GoldenGate 19.1* Classic

Oracle GoldenGate Big Data 12.3.2.1*, 19.1.*

Oracle GoldenGate Monitor Agent 12.2.1.2.190530+

The asterisk (*) indicates that the software is interoperable with releases later than one shown

The following table shows which releases of these components can be used with Oracle Enterprise Manager and other Oracle GoldenGate components.

Oracle GoldenGate Plug-In for Oracle Enterprise Manager Component Can be used with...

Oracle GoldenGate Plug-In for Oracle Enterprise Manager 13.2.3.0.*

Oracle GoldenGate 18.1* Classic & Microservices

Oracle GoldenGate 19.1* Classic & Microservices

Oracle GoldenGate Big Data 12.3.2.1*

Oracle GoldenGate Monitor Agent 12.2.1.2.190530*

Oracle Enterprise Manager 13.3.0.0.0 Release 3

Oracle GoldenGate Plug-In for Oracle Enterprise Manager 13.4.1.*

Oracle GoldenGate 18.1* Classic & Microservices

Oracle GoldenGate 19.1* Classic & Microservices

Oracle GoldenGate Big Data 19.1.*

Oracle GoldenGate Monitor Agent 12.2.1.2.200131+

Oracle Enterprise Manager 13.4.0.0.0 Release 1

The asterisk (*) indicates that the software is interoperable with releases later than one shown

Oracle WebCenter Interoperability with Other Fusion Middleware Products

Oracle WebCenter includes the following products:
  • Oracle WebCenter Content

  • Oracle WebCenter Enterprise Capture

  • Oracle WebCenter Imaging

  • Oracle WebCenter Portal

  • Oracle WebCenter Sites

The following table shows which releases of these components can be used with WebCenter 12c (12.2.1.4.0)*
Product Can be used with... Interoperability Details
WebCenter Content Siebel Siebel 19.*

WebCenter Enterprise Capture

WebCenter Content

12cR2 (12.2.1.*)

WebCenter Enterprise Capture

WebCenter Imaging

11gR1 (11.1.1.9.0)

12c (12.2.1.4.0)

WebCenter Enterprise Capture

WebCenter Forms Recognition (WFR)

11gR1 (11.1.1.9.*)

12c (12.2.1.4.0)

WebCenter Imaging

WebCenter Content

12c (12.2.1.4.0)

WebCenter Imaging

Oracle E-Business Suite

12.2.8

See Doc ID 1927793.1 on My Oracle Support.

WebCenter Imaging

PeopleSoft Enterprise

PeopleTools 8.56

WebCenter Imaging

Oracle SOA Suite

12c (12.2.1.4.0)

WebCenter Imaging

Oracle Business Process Management

12c (12.2.1.4.0)

WebCenter Portal

WebCenter Content

12c (12.2.1.4.0)

Note: This is required if WCP is using WCC as content repository.

WebCenter Portal

Oracle SOA Suite

BPEL Server

WebCenter Portal and SOA installed in separate ORACLE_HOMES and domains: SOA can be on versions 12.2.1.1, 12.2.1.2, 12.2.1.3, or 12.2.1.4

WebCenter Portal and SOA installed in same ORACLE_HOME and domain: Both WebCenter Portal and SOA product versions can be either 12.2.1.3 or 12.2.1.4. You must not have different versions for each product in the same domain.

WebCenter Portal

Oracle Business Intelligence Enterprise Edition (OBIEE)

WebCenter Portal 12.2.1.2.0 works with OBIEE 12.2.1.2 and 12.2.1.3

WebCenter Portal 12.2.1.3.0 works with OBIEE 12.2.1.2 and 12.2.1.3

Note:

If not full integration with OBIEE and only calling OBIEE reports from WebCenter Portal as links, then using any OBIEE 12.2.1.X version is supported.

WebCenter Sites

WebCenter Content

12c (12.2.1.4.0)

Oracle Forms Interoperability and Compatibility with Reporting Products

This section summarizes the most common compatibility and interoperability scenarios for Oracle Forms and Oracle Reports and/or BI-Publisher.

Before you start, consider the following:
  • Compatibility between versions (such as between Oracle Forms 12c (12.2.1.4.0) and Oracle Reports 12c (12.2.1.3.0)) are supported only when the products are installed in separate Oracle homes. In general, Oracle does not support the installation of products of different versions in the same Oracle home. For more information, see Oracle Home and Domain Extension Interoperability.

  • Support for any combination extends until the end of support of the lowest version. For best results, you are encouraged to use the latest version where possible. If you are using Oracle Reports 12c (12.2.1.4.0), migrate to BI-Publisher for better results.

  • Support for using Oracle Forms with Oracle Reports assumes that these two products are on the same network subnet.

Table 2-4 Oracle Forms 12c (12.2.1.4.0) Interoperability with Reporting Products

Oracle Forms Can be used with...

Oracle Forms 12c (12.2.1.4.0)

Oracle Reports 12.2.1.3.0

Oracle BI-Publisher 12.2.1.3.0

Oracle BI-Publisher 12c (12.2.1.4.0)