man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

sof_newconn_ready(9F)

Name

sof_newconn_ready, sof_newconn_close - accept or discard a deferred connection

Synopsis

#include <sys/sockfilter.h>

void sof_newconn_ready(sof_handle_t hdl);
void sof_newconn_close(sof_handle_t hdl);

Parameters

hdl

per-socket filter handle

Description

The sof_newconn_ready() function informs the framework that the deferred connection should be made available to the application via accept(3SOCKET) . In the presence of multiple filters, the connection will only be made available once all filters have called sof_newconn_ready().

The sof_newconn_close() function causes the connection to be closed immediately. The normal close sequence will be executed, and filters will therefore observe a SOF_EV_CLOSING event (see sofop_notify(9E)) followed by a call to sofop_detach(9E).

Calling either sof_newconn_ready() or sof_newconn_close() on a connection that is not deferred has no effect.

Context

The sof_newconn_ready() and sof_newconn_close() functions can be called from any context

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/kernel
Interface Stability
Uncommitted

See also

accept(3SOCKET), attributes(5) , sofop_attach_passive(9E), sofop_detach(9E), sofop_notify(9E),