|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures|
- data structure describing events related to network interfaces
#include <sys/neti.h> #include <sys/hook.h> #include <sys/hook_event.h>
Solaris DDI specific (Solaris DDI).
The hook_nic_event structure contains fields that relate to an event that has occurred and belongs to a network interface. This structure is passed through to callbacks for NE_PLUMB, NE_UNPLUMB, NE_UP, NE_DOWN and NE_ADDRESS_CHANGE events.
A callback may not alter any of the fields in this structure.
net_data_t hne_family; phy_if_t pkt_private; lif_if_t hne_lif; nic_event_t hne_event; nic_event_data_t hne_data; size_t hne_datalen;
The following fields are set for each event:
A valid reference for the network protocol that owns this network interface and can be in calls to other netinfo(9F) functions.
The physical interface to which an event belongs.
A value that indicates the respective event. The current list of available events is:
an interface has just been created.
An interface has just been destroyed and no more events should be received for it.
An interface has changed the state to “up” and may now generate packet events.
An interface has changed the state to “down” and will no longer generate packet events.
An address on an interface has changed. hne_lif refers to the logical interface for which the change is occurring, hne_data is a pointer to a sockaddr structure that is hne_datalen bytes long and contains the new network address.
An interface index has changed. hne_lif refers to the logical interface for which the change is occurring, hne_data is a new ifindex value.
See attributes(5) for descriptions of the following attributes: