|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures|
- SCSI inquiry structure
Solaris DDI specific (Solaris DDI).
The scsi_inquiry structure contains 36 required bytes, followed by a variable number of vendor-specific parameters. Bytes 59 through 95, if returned, are reserved for future standardization. This structure is part of scsi_device(9S) structure and typically filled in by scsi_probe(9F).
uchar_t inq_dtype; /* Periph. qualifier, dev. type */ uchar_t inq_rmb :1; /* Removable media */ uchar_t inq_qual :7; /* Dev. type qualifier */ uchar_t inq_iso :2; /* ISO version */ uchar_t inq_ecma :3; /* ANSI version */ uchar_t inq_aenc :1; /* Async event notif. cap. */ uchar_t inq_trmiop :1; /* Supports TERMINATE I/O PROC msg */ uchar_t inq_rdf :4; /* Response data format */ uchar_t inq_len; /* Additional length */ uchar_t inq_reladdr :1; /* Supports relative addressing */ uchar_t inq_wbus32 :1; /* Supports 32 bit wide data xfers */ uchar_t inq_wbus16 :1; /* Supports 16 bit wide data xfers */ uchar_t inq_sync :1; /* Supports synchron. data xfers */ uchar_t inq_linked :1; /* Supports linked commands */ uchar_t inq_cmd_que :1; /* Supports command queueing */ uchar_t inq_sftre :1; /* Supports Soft Reset option */ char inq_vid; /* Vendor ID */ char inq_pid; /* Product ID */ char inq_revision; /* Revision level */
inq_dtype identifies the type of device. Bits 0 - 4 represent the Peripheral Device Type and bits 5 - 7 represent the Peripheral Qualifier. The following values are appropriate for Peripheral Device Type field:
Array controller device (for example, RAID).
Direct-access device (for example, magnetic disk).
Enclosure services device.
Sequential-access device (for example, magnetic tape).
Write-once device (for example, some optical disks).
Optical memory device (for example, some optical disks).
Medium Changer device (for example, jukeboxes).
Unknown or no device type.
Mask to isolate Peripheral Device Type field.
The following values are appropriate for the Peripheral Qualifier field:
The specified peripheral device type is currently connected to this logical unit. If the target cannot determine whether or not a physical device is currently connected, it uses this peripheral qualifier when returning the INQUIRY data. This peripheral qualifier does not imply that the device is ready for access by the initiator.
The target is capable of supporting the specified peripheral device type on this logical unit. However, the physical device is not currently connected to this logical unit.
The target is not capable of supporting a physical device on this logical unit. For this peripheral qualifier, the peripheral device type shall be set to DTYPE_UNKNOWN to provide compatibility with previous versions of SCSI. For all other peripheral device type values, this peripheral qualifier is reserved.
This is a vendor-unique qualifier.
DTYPE_NOTPRESENT is the peripheral qualifier DPQ_NEVER and the peripheral device type DTYPE_UNKNOWN combined.
inq_rmb, if set, indicates that the medium is removable.
inq_qual is a device type qualifier.
inq_iso indicates ISO version.
inq_ecma indicates ECMA version.
inq_ansi indicates ANSI version.
inq_aenc, if set, indicates that the device supports asynchronous event notification capability as defined in SCSI-2 specification.
inq_trmiop, if set, indicates that the device supports the TERMINATE I/O PROCESS message.
inq_rdf, if reset, indicates the INQUIRY data format is as specified in SCSI-1.
inq_inq_len is the additional length field that specifies the length in bytes of the parameters.
inq_reladdr, if set, indicates that the device supports the relative addressing mode of this logical unit.
inq_wbus32, if set, indicates that the device supports 32-bit wide data transfers.
inq_wbus16, if set, indicates that the device supports 16-bit wide data transfers.
inq_sync, if set, indicates that the device supports synchronous data transfers.
inq_linked, if set, indicates that the device supports linked commands for this logical unit.
inq_cmdque, if set, indicates that the device supports tagged command queueing.
inq_sftre, if reset, indicates that the device responds to the RESET condition with the hard RESET alternative. If this bit is set, this indicates that the device responds with the soft RESET alternative.
inq_vid contains eight bytes of ASCII data identifying the vendor of the product.
inq_pid contains sixteen bytes of ASCII data as defined by the vendor.
inq_revision contains four bytes of ASCII data as defined by the vendor.
ANSI Small Computer System Interface-2 (SCSI-2)