|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- WPA and WPA2 protocol daemon
/usr/lib/inet/wpad [-i interface] [-k pre_shared_key_name]
The wpad daemon provides common client functionality for the WiFi Protected Access (WPA) versions 1 and 2, as defined by IEEE802.11i standard. WPA was created by the WiFi Alliance, an industry trade group. WPA implements the majority of the IEEE 802.11i standard, and was intended as an intermediate measure to take the place of Wired Equivalent Privacy (WEP) while 802.11i was prepared. WPA2 implements the full standard.
wpad provides the following WPA/IEEE 802.11i features:
Key management for CCMP, TKIP, WEP104, WEP40
Stop and start the wpad daemon using dladm(1M). Use:
# dladm connect-wifi
...to start the wpad daemon. Use:
# dladm disconnect-wifi
...to stop the daemon.
The following options are supported:
Specify a WiFi Link interface to start the wpad daemon.
Specify the pre-shared key used for the WiFi Link.
Example 1 Starting the wpad Daemon on Specific WiFi Link
To create the WPA key psk, enter the following command:
# dladm create-secobj -c wpa psk
To use key psk to connect to ESSID wlan on link ath0, enter the following command:
# dladm connect-wifi -k psk -e wlan ath0
Example 2 Stopping the wpad Daemon on Specific WiFi Link
To stop the daemon on the link ath0, enter:
# dladm disconnect-wifi ath0
See attributes(5) for descriptions of the following attributes:
The wpad service is managed by the service management facility, smf(5), under the service identifier: