|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
- time zone dumper
zdump [--version] [-v] [-c [loyear,]hiyear] [zonename]...
The zdump command prints the current time for each time zone (zonename) listed on the command line. Specify zonename as the name of the time zone database file relative to /usr/share/lib/zoneinfo.
Specifying an invalid time zone (zonename) to zdump does not return an error, rather zdump uses UTC. This is consistent with the behavior of the library calls; zdump reflects the same behavior of the time routines in libc. See ctime(3C) and mktime(3C).
The following options are supported:
Outputs version information and exits.
Displays the entire contents of the time zone database file for zonename. Prints the time at the lowest possible time value; the time one day after the lowest possible time value; the times both one second before and exactly at each time at which the rules for computing local time change; the time at the highest possible time value; and the time at one day less than the highest possible time value. See mktime(3C) and ctime(3C) for information regarding time value (time_t). Each line of output ends with isdst=1 if the given time is Daylight Saving Time, or isdst=0 otherwise.
Cuts off the verbose output near the start of the given year(s) . By default, the program cuts off verbose output near the start of the years -500 and 2500.
The following exit values are returned:
An error occurred.
Standard zone information directory
See attributes(5) for descriptions of the following attributes: