ヘッダーをスキップ
Oracle® Communications Data Modelインストレーション・ガイド
リリース11.3.1
B70211-01
  目次へ移動
目次
索引へ移動
索引

前
前
 
次
次
 

B BRMアダプタのインストールおよび構成

この付録では、次のものをインストールおよび設定する方法について示します。

この付録には、次の項が含まれます。


注意:

この付録の手順の実行に時間がかかる場合があります。

BRMアダプタは、Oracle Communications Data Modelの「アプリケーション・アダプタ」タイプのインストールを使用してインストールできます。BRMアダプタには、Oracle Communications Data Modelステージング・レイヤーに対してOracle GoldenGateを使用してリアルタイムのデータをフィードしたり、Oracle Data Integratorを使用してバッチ・モードのデータを抽出、ロードおよび変換したりするオプションが含まれます。

BRMアダプタ構成の前提条件

次に、Oracle Communication Data ModelアダプタにBilling and Revenue Managementをインストールするための前提条件を説明します。

Oracle Data Integrator Enterprise Editionがインストールされていることの確認

Oracle Data Integrator Enterprise Editionのインストールを確認するには、ODI Studioを起動します。

  1. 「スタート」メニューで、「すべてのプログラム」→「Oracle」→「Oracle Data Integrator」→「ODI Studio」の順に選択します。

  2. デザイナ・ナビゲータで「リポジトリへの接続」をクリックします。

Oracle Data Integrator Enterprise Editionがインストールされていない場合、「Oracle Data Integrator Enterprise Edition」を参照してください。

Oracle GoldenGateがインストールされていることの確認

Oracle Communication Data ModelアダプタにBilling and Revenue Management (BRMアダプタ)をインストールする場合、Oracle GoldenGateの使用、インストールおよび構成は、BRMアダプタでリアルタイム・ステージングを使用するかどうかによってオプションになります。

Oracle GoldenGateがインストールされていない場合、「Oracle GoldenGate」を参照してください。

BRMアダプタのインストールの概要

Oracle Communication Data ModelアダプタにBilling and Revenue Managementをインストールして設定するには、Oracle GoldenGate抽出およびReplicatプロセスと、Oracle Data Integratorコンポーネントを使用してE-LT操作環境を作成します。この付録のタスクを順番に実行します。

この付録には、ソース・データのデータ・ロード、変換および検証にステージング・データベースを設定する手順が含まれます。作業を開始するには、ODIマスター・リポジトリおよび作業リポジトリを設定し、Oracle Data Integrator(ODI)を使用する必要があります。オプションで、Oracle GoldenGateを使用している場合、Oracle GoldenGateをインストールおよび構成してリアルタイムETLを実行する必要があります。

注意:

Oracle Communications Data Modelアダプタのインストールの概要:

次の手順は、Oracle Communication Data ModelアダプタにBilling and Revenue Management (BRM)をインストールする方法を示しています。これらの手順には、ソース・データのデータ・ロード、変換および検証のためのステージング・データベースを設定する方法が含まれます。BRMアダプタのインストールを開始する前に、ODIマスター・リポジトリおよび作業リポジトリを設定する必要があります。

Oracle Data Integrator (ODI)およびOracle GoldenGateを併用して、リアルタイムETLを実行します。

Oracle Communications Data Modelアダプタのインストールの手順:

  1. スキーマOCDM_SYSの参照表のBRMアダプタのロード値の設定

  2. BRMアダプタのステージング・スキーマの設定

  3. BRMアダプタのOracle Data Integratorの構成(Oracle GoldenGateオプションなし)

  4. BRMアダプタのOracle GoldenGateの設定

スキーマOCDM_SYSの参照表のBRMアダプタのロード値の設定

create_brm_stg.sqlスクリプトの実行中に、このスクリプトによって、ターゲット・スキーマ(OCDM_SYS)に必要とされる適切な参照表およびスクリプトが作成されます。

BRMアダプタのステージング・スキーマの設定

ステージング・スキーマの作成(brm_stgの例を使用)

sys/systemユーザーとして接続し、sqlplusからスクリプトcreate_brm_stg.sqlを実行してステージング・スキーマ(brm_stg)を作成します。

スクリプトの場所: $BRM_OCDM_HOME/staging_install_ddl/create_brm_stg.sql

SQL> @./create_brm_stg.sql
Creating Relational Schema and Granting required privilages
Enter value for user_name: brm_stg [Depends on stage-schema name of the user]
Enter value for password: passwd

Connecting Target Schema (OCDM_SYS)
Enter value for user_name: ocdm_sys
Enter value for password: passwd

create_brm_stg.sqlファイルの実行によって、次のオブジェクトとファイルがbrm_stgおよびocdm_sysスキーマに作成されます。

作成されるステージング・スキーマ(brm_stg)オブジェクト:

注意: ここでは日次更新であると仮定します。ただし、更新頻度の高低にかかわらず(リアルタイム変更でも)同じ表が使用されます。

作成されるターゲット・スキーマ(ocdm_sys)オブジェクト:

表B-1 作成されるocdm_sysオブジェクト

プロシージャ

DEL_OCDM

DISB_CONS

ENAB_CONS

GEO_CITY_MAP

GEO_CNTRY_MAP

GEO_STATE_MAP

INSERT_REF

POSTCD_MAP

UPDATE_ACCT_ACCT

UPDATE_ACCT_BILLINFO

UPDATE_ACCT_PREF_PYMT_MTHD

UPDATE_ADDR_LOC

UPDATE_BASE_PROD_KEY

UPDATE_CUST

UPDATE_CUST_FCNG_SRVC

UPDATE_PROD

UPDATE_PROD_MKT_PLN

UPDATE_PROD_RTNG_PLN

UPDATE_PRTY

UPDATE_PRTY_FOR_CUST

UPDATE_SBRP

UPDATE_SBRP_CHRGS

UPDATE_SRVC_SPEC


UTC_TO_ORACLEファンクション:

追加のUTC to Oracle日付ファンクション: UTC_TO_ORACLE

作成されるステージングおよびターゲット・スキーマ(brm_stgおよびocdm_sys)オブジェクト(ディレクトリ$BRM_OCDM_HOME/staging_install_ddlに作成されるファイル):

表B-2 作成されるスクリプト・ファイル

作成されるファイル

brm_disable_constraint.sql

brm_map_tab.sql

brm_views.sql

ddl_rqd_tables_stg_delta.sql

ddl_rqd_tables_stg_delta_h.sql

ddl_rqd_tables_stg_ld.sql

ddl_rqd_tables_stg_normal.sql

del_ocdm.sql

disabled_constraint.sql

enabled_constraint.sql

etl_parameter.sql

grant_script.sql

index_on_stage_tables.sql

insert_brm_mapping_tab.sql

insert_ref.sql

insert_script.sql

ocdm_procedures.sql

post_staging_load.sql

pre_ocdm_load.sql

pre_staging_load.sql

scd2_update.sql

utc_to_oracle.sql

utc_to_oracle.sql


BRMアダプタのOracle Data Integratorの構成(Oracle GoldenGateオプションなし)

BRMアダプタとともに使用するOracle Communications Data Model用のOracle Data Integratorの構成には、次の手順が含まれます。

ODIマスター・リポジトリの作成および接続

sysdbaとしてDBAユーザーに接続します。

SQL>/ as sysdba

マスターおよび作業リポジトリ用にRDBMSスキーマおよびユーザー(Oracle 11g)を作成する必要があります。スキーマは、次のSQLコマンドを実行して作成できます。

SQL> create user repo identified by repo default tablespace users temporary tablespace temp;
SQL> create user wrep identified by wrep default tablespace users temporary tablespace temp;

次のSQLコマンドを実行して、新しく作成したユーザーに接続権限を付与します。

SQL> grant connect, resource to repo;
SQL> grant execute on dbms_lock to repo;
SQL> grant connect, resource to wrep;
SQL> grant execute on dbms_lock to repo;

記載されているユーザーは単なる例です。任意のユーザーを選択できますが、ODI用のリポジトリおよびログイン情報を作成する際は、同じユーザーを使用していることを確認してください。

  1. 図B-1に示すように、ODI Studioを開きます。

    「スタート」→「プログラム」→「Oracle」→「Oracle Data Integrator」→「ODI Studio」

    図B-1 ODI Studioを開く

    図B-1の説明が続きます
    「図B-1 ODI Studioを開く」の説明

  2. 図B-2に示すように、新規ギャラリを開きます。

    「ファイル」→「新規」

    新規ギャラリの「カテゴリ」ツリーで、「ODI」を選択します。

    「項目」リストから「マスター・リポジトリ作成ウィザード」を選択します。

    「OK」をクリックします。

    マスター・リポジトリ作成ウィザードが表示されます。

    図B-2 ODI Studio新規ギャラリ

    図B-2の説明が続きます
    「図B-2 ODI Studio新規ギャラリ」の説明

    図B-3 ODI Studio新規ギャラリのマスター・リポジトリの作成

    図B-3の説明が続きます
    「図B-3 ODI Studio新規ギャラリのマスター・リポジトリの作成」の説明

  3. マスター・リポジトリ作成ウィザードで、JDBCドライバの参照アイコン、Oracle JDBCドライバの順に選択します。「OK」をクリックします。

    JDBC URLを編集して、jdbc:oracle:thin: @localhost:1521:orcを読み取ります。

    ユーザーにrepo、パスワードにpasswordと入力します。

    「接続のテスト」をクリックして、正常な接続を確認します。

    「OK」をクリックします。

    図B-4に示すように、「マスター・リポジトリ作成ウィザード」画面で、「次へ」をクリックします。

    図B-4 ODI Studioマスター・リポジトリ作成ウィザード

    図B-4の説明が続きます
    「図B-4 ODI Studioマスター・リポジトリ作成ウィザード」の説明

    図B-5 ODI Studioマスター・リポジトリの正常な作成

    図B-5の説明が続きます
    「図B-5 ODI Studioマスター・リポジトリの正常な作成」の説明

  4. 認証ウィンドウで、スーパーバイザ・パスワードにpasswordと入力します。

    図B-6に示すように、パスワードの確認のため再度passwordと入力します。

    「次へ」をクリックします。

    注意: ODIユーザー名およびパスワードは、大文字/小文字が区別されます。

    図B-6 ODI Studioマスター・リポジトリ作成パスワード

    図B-6の説明が続きます
    「図B-6 ODI Studioマスター・リポジトリ作成パスワード」の説明

  5. パスワード記憶域ウィンドウで、「内部パスワード記憶域」を選択し、「終了」をクリックします。マスター・リポジトリを正しく作成すると、Oracle Data Integrator情報メッセージが表示されます。

    「OK」をクリックします。ODIマスター・リポジトリが作成されます。

    図B-7 ODI Studioマスター・リポジトリの作成終了

    図B-7の説明が続きます
    「図B-7 ODI Studioマスター・リポジトリの作成終了」の説明

    図B-8 ODI Studioマスター・リポジトリの作成完了

    図B-8の説明が続きます
    「図B-8 ODI Studioマスター・リポジトリの作成完了」の説明

  6. 新しいODIマスター・ログインを作成して、ODIマスター・リポジトリに接続します。「ファイル」→「新規」を選択して新規ギャラリを開きます。新規ギャラリの「カテゴリ」ツリーで、「ODI」を選択します。図B-9に示すように、「項目」リストから「新規ODIリポジトリ・ログインの作成」を選択します。

    図B-9 ODI Studio新規ギャラリのODIリポジトリ・ログイン

    図B-9の説明が続きます
    「図B-9 ODI Studio新規ギャラリのODIリポジトリ・ログイン」の説明

  7. 次に示す表のパラメータを使用して、リポジトリ接続を構成します。JDBC URLを入力するには、画面に示すように、「JDBC URL」フィールドの横にあるボタンをクリックし、jdbc:oracle:thin:@<host>:<port>:<sid>を選択して、URLを編集します。「マスター・リポジトリのみ」ボタンを選択します。

    「テスト」をクリックします。

    正常な接続を確認して、「OK」をクリックします。

    「OK」をクリックして接続を保存します。

    表B-3 Oracle Data Integrator接続

    パラメータ 値

    ログイン名

    master_repo

    ユーザー

    SUPERVISOR

    パスワード

    password


    表B-4 データベース接続(マスター・リポジトリ)

    パラメータ 値

    ユーザー

    repo

    パスワード

    password

    ドライバ・リスト

    Oracle JDBCドライバ

    ドライバ名

    oracle.jdbc.OracleDriver

    URL

    jdbc:oracle:thin:@<system_name>:<listener port>:<SID>

    次に例を示します。

    jdbc:oracle:thin:@localhost:1521:orcl
    

    注意: 「JDBC URL」フィールドでコピーして貼り付けないでください。有効なURL文字列の入力で問題が発生する場合があります。かわりに、ドロップダウン・メニューを開いて、リストから正しいドライバを選択します。「URL」フィールドで正しいURLを入力します。

    図B-10 ODI Studioリポジトリ接続情報

    図B-10の説明が続きます
    「図B-10 ODI Studioリポジトリ接続情報」の説明

    図B-11 ODI Studioリポジトリ接続の成功

    図B-11の説明が続きます
    「図B-11 ODI Studioリポジトリ接続の成功」の説明

  8. 「リポジトリへの接続」をクリックします。ドロップダウン・リストから新しく作成したリポジトリ接続のマスター・リポジトリを選択します。「OK」をクリックします。ODIトポロジ・マネージャが起動します。ODIトポロジ・マネージャに正常にログインしています。

    図B-12 ODI Studioリポジトリ接続

    図B-12の説明が続きます
    「図B-12 ODI Studioリポジトリ接続」の説明

    図B-13 Oracle Data Integratorログイン

    図B-13の説明が続きます
    「図B-13 Oracle Data Integratorログイン」の説明

    図B-14 Oracle Data Integratorマスター・リポジトリ・トポロジ

    図B-14の説明が続きます
    「図B-14 Oracle Data Integratorマスター・リポジトリ・トポロジ」の説明

ODI作業リポジトリの作成および接続

  1. Oracle Databaseスキーマおよびユーザーを作成した後、ODIトポロジ・ナビゲータを使用してODI作業リポジトリを作成します。

    ODIで、「トポロジ・ナビゲータ」タブ、「リポジトリ」パネルの順にクリックします。「作業リポジトリ」ノードを右クリックして「新規作業リポジトリ」を選択します。

    作業リポジトリの作成ウィザードが開きます。

    図B-15 ODIトポロジ・ナビゲータの新規作業リポジトリ

    図B-15の説明が続きます
    「図B-15 ODIトポロジ・ナビゲータの新規作業リポジトリ」の説明

  2. 後続の画面で、表B-5に示すパラメータを入力します。

    「テスト接続」をクリックして正常な接続を確認し、「OK」をクリックします。

    「次へ」をクリックします。

    表B-5 新規作業リポジトリのパラメータ

    パラメータ 値

    テクノロジ

    Oracle

    ドライバ名

    oracle.jdbc.driver.OracleDriver

    JDBC URL

    jdbc:oracle:thin:@<system_name>:<listener port>:<SID>

    次に例を示します。

    jdbc:oracle:thin:@localhost:1521:orcl

    ユーザー

    wrep

    パスワード

    password


    図B-16 ODI Studio作業リポジトリの作成のテスト接続

    図B-16の説明が続きます
    「図B-16 ODI Studio作業リポジトリの作成のテスト接続」の説明

    図B-17 ODIリポジトリの作業リポジトリの作成の接続成功

    図B-17の説明が続きます
    「図B-17 ODIリポジトリの作業リポジトリの作成の接続成功」の説明

  3. 図B-18に示すように、作業リポジトリ・プロパティの指定ページで、次の値を設定します。

    「ID」を5に設定します。

    「名前」をWORKREP_KOLKATA_SERVERに設定します。

    「パスワード」にpasswordと入力します。

    「作業リポジトリ・タイプ」リストで、「開発」を選択します。

    「終了」をクリックします。

    図B-18 ODI Studio ODI作業リポジトリの作成のプロパティ

    図B-18の説明が続きます
    「図B-18 ODI Studio ODI作業リポジトリの作成のプロパティ」の説明

    図B-19 ODI Studio ODI作業リポジトリの作成のODIアクションの開始中

    図B-19の説明が続きます
    「図B-19 ODI Studio ODI作業リポジトリの作成のODIアクションの開始中」の説明

  4. 作業リポジトリ・ログインの作成ウィンドウで、「はい」をクリックします。

    ログイン名にWORKREP_KOLKATA_SERVERと入力します。

    「OK」をクリックします。

    新しく作成した作業リポジトリが作業リポジトリ・ツリー・ビューにあることを確認します。

    図B-20 ODI Studio ODI作業リポジトリの作成のログイン名の作成

    図B-20の説明が続きます
    「図B-20 ODI Studio ODI作業リポジトリの作成のログイン名の作成」の説明

    図B-21 ODI Studio ODI作業リポジトリの作成のログインの作成

    図B-21の説明が続きます
    「図B-21 ODI Studio ODI作業リポジトリの作成のログインの作成」の説明

    図B-22 ODI Studio ODI作業リポジトリのトポロジ

    図B-22の説明が続きます
    「図B-22 ODI Studio ODI作業リポジトリのトポロジ」の説明

  5. マスター・リポジトリから切断して、作業リポジトリに接続します。「ODI」をクリックしてmaster_repoの切断を選択します。

    図B-23 ODI Studioマスター・リポジトリからの切断

    図B-23の説明が続きます
    「図B-23 ODI Studioマスター・リポジトリからの切断」の説明

  6. 「リポジトリへの接続」をクリックします。

    「ログイン名」ドロップダウン・リストから「WORKREP_KOLKATA_SERVER」を選択します。

    「パスワード」にpasswordと入力します。

    「OK」をクリックします。

    「デザイナ」タブをクリックします。

    図B-25に示すように、ODIのログイン・ダイアログが表示されます。

    図B-24 ODI Studio作業リポジトリ接続

    図B-24の説明が続きます
    「図B-24 ODI Studio作業リポジトリ接続」の説明

    図B-25 ODI Studio Oracle Data Integratorログイン

    図B-25の説明が続きます
    「図B-25 ODI Studio Oracle Data Integratorログイン」の説明

    ODI作業リポジトリが正常に作成され、接続されています。

  7. 「デザイナ」タブを確認すると、新しい作業リポジトリにプロジェクトやモデルは表示されていません。

    図B-26 ODI Studioデザイナ・タブ

    図B-26の説明が続きます
    「図B-26 ODI Studioデザイナ・タブ」の説明

ODIマスター・リポジトリのインポート

マスター・リポジトリのインポートおよびエクスポート手順を実行すると、トポロジ・ドメインおよびセキュリティ・ドメインを含むリポジトリ全体をあるリポジトリから別のリポジトリに転送できます。

既存のマスター・リポジトリのマスター・リポジトリをインポートする手順は、次のとおりです。

  1. トポロジ・ナビゲータのツールバー・メニューから、「インポート」→「マスター・リポジトリ」の順に選択します。

  2. 「インポート・モード」を選択して、フォルダまたはZIPファイルをインポートします。

  3. 「OK」をクリックします。

  4. 指定したファイルが現在のマスター・リポジトリにインポートされます。

    図B-27 ODI Studioマスター・リポジトリのインポート

    図B-27の説明が続きます
    「図B-27 ODI Studioマスター・リポジトリのインポート」の説明

    図B-28 ODI Studioマスター・リポジトリのインポートのモードおよびオプション

    図B-28の説明が続きます
    「図B-28 ODI Studioマスター・リポジトリのインポートのモードおよびオプション」の説明

  5. 指定された場所からマスター・リポジトリを参照します。

    リポジトリの場所:

    "$BRM_OCDM_HOME/odi_repository/brm_ocdm_adapter_master.zip"

    図B-29 マスター・リポジトリのインポート

    図B-29の説明が続きます
    「図B-29 マスター・リポジトリのインポート」の説明

    図B-30 ODI Studioマスター・リポジトリのインポートの進行中

    図B-30の説明が続きます
    「図B-30 ODI Studioマスター・リポジトリのインポートの進行中」の説明

  6. 図B-31に示すように、「インポート・レポート」を確認し、「保存」をクリックしてこのレポートを保存します。

    図B-31 リポジトリのインポート・レポート

    図B-31の説明が続きます
    「図B-31 リポジトリのインポート・レポート」の説明

ODI作業リポジトリのインポート

作業リポジトリをインポートまたはエクスポートすると、すべての作業リポジトリのオブジェクトをあるリポジトリから別のリポジトリに転送できます。

作業リポジトリをインポートするには:

  1. デザイナ・ナビゲータのツールバー・メニューから、「インポート」→「作業リポジトリ」の順に選択します。

  2. 「インポート・モード」を選択して、フォルダまたはZIPファイルをインポートします。

  3. 「OK」をクリックします。

指定したファイルが作業リポジトリにインポートされます。

図B-32 ODI Studio作業リポジトリのインポート

図B-32の説明が続きます
「図B-32 ODI Studio作業リポジトリのインポート」の説明

図B-33 ODI Studio ZIPファイルからの作業リポジトリのインポート

図B-33の説明が続きます
「図B-33 ODI Studio ZIPファイルからの作業リポジトリのインポート」の説明

指定された場所から作業リポジトリを参照します。

$BRM_OCDM_HOME/odi_repository/brm_ocdm_adapter_work.zip

図B-34 ODI Studio ZIPファイルからの作業リポジトリのインポート

図B-34の説明が続きます
「図B-34 ODI Studio ZIPファイルからの作業リポジトリのインポート」の説明

図B-35 ODI Studio作業リポジトリのオープンおよびインポートの進行中

図B-35の説明が続きます
「図B-35 ODI Studio作業リポジトリのオープンおよびインポートの進行中」の説明

図B-36 ODI Studio作業リポジトリのインポートの警告

図B-36の説明が続きます
「図B-36 ODI Studio作業リポジトリのインポートの警告」の説明

図B-37に示すように、インポート・レポートを確認できます。レポートを保存する場合は、「保存」をクリックします。

図B-37 ODI Studio作業リポジトリのインポート・レポート

図B-37の説明が続きます
「図B-37 ODI Studio作業リポジトリのインポート・レポート」の説明

「デザイナ」タブのプロジェクトおよびモデルを使用すると、作業リポジトリのプロジェクトおよびモデルを表示できます。

図B-38 ODIデザイナ・ナビゲータとプロジェクトおよびモデルの表示

図B-38の説明が続きます
「図B-38 ODIデザイナ・ナビゲータとプロジェクトおよびモデルの表示」の説明

ODIトポロジの設定

ODIトポロジを設定するには、次の手順に従います。

物理データ・サーバーの設定

  1. トポロジ・ナビゲータから「物理アーキテクチャ」タブを表示します。

  2. 「テクノロジ」ノードを開きます。

  3. Oracleノードを開いて、物理データ・サーバーを表示します。

    図B-39 ODI Studio物理データ・サーバー

    図B-39の説明が続きます
    「図B-39 ODI Studio物理データ・サーバー」の説明

  4. BRM_STGノードをダブルクリックして、データ・サーバー: <Name>ダイアログを表示します。

  5. 「定義」タブを表示して、次に示すように適切な情報を入力します。

    図B-40 ODI Studioデータ・サーバー定義ダイアログ

    図B-40の説明が続きます
    「図B-40 ODI Studioデータ・サーバー定義ダイアログ」の説明

    表B-6 ODI Studioデータ・サーバー定義のフィールドおよび値

    フィールド 説明

    名前

    データ・サーバーの名前を変更しないでください。

    テクノロジ

    デフォルト値のOracleを変更しないでください。

    インスタンス/dblink(データ・サーバー)

    データベース・インスタンス名を指定します。

    Oracle SID名を使用します。たとえば、ORCLなどです。

    ユーザー

    <User Name>を指定します。たとえば、brm_stgなどです。

    これは、ウェアハウス・データベース・ユーザー名です。

    パスワード

    <Password>を指定します。

    これは、ウェアハウス・データベース・ユーザー名のデフォルトのパスワードです。

    配列フェッチ・サイズ

    環境に適した値を指定します。

    (デフォルト値は変更しないでください)。

    バッチ更新サイズ

    環境に適した値を指定します。

    (デフォルト値は変更しないでください)。


  6. 「JDBC」タブを表示して、表B-7に示すように適切な情報を入力します。

    図B-41 ODI Studioデータ・サーバーのJDBCタブ

    図B-41の説明が続きます
    「図B-41 ODI Studioデータ・サーバーのJDBCタブ」の説明

    表B-7 ODI Studioデータ・サーバーのJDBCタブのフィールドおよび値

    フィールド 説明

    JDBCドライバ

    oracle.jdbc.driver.OracleDriverを指定します。

    JDBC URL

    jdbc:oracle:thin:@<host>:<port>:<sid>形式で指定します。

    <host>、<port>および<sid>をODIリポジトリをホストするデータベースの値に置き換えます。

    たとえば、'jdbc:oracle:thin:@localhost:1521:orcl'などです。


  7. 必要な値を入力したら、「テスト」をクリックします。これにより、図B-42のダイアログが表示されます。

    図B-42 ODI Studioデータ・サーバーのテスト接続

    図B-42の説明が続きます
    「図B-42 ODI Studioデータ・サーバーのテスト接続」の説明

  8. <Connection>ダイアログで、「テスト」をクリックしてテスト接続を表示します。

    図B-43 テスト接続情報ダイアログ

    図B-43の説明が続きます
    「図B-43 テスト接続情報ダイアログ」の説明

  9. 「保存」アイコンをクリックして、詳細を保存します。

物理スキーマの設定

データ・サーバーの物理スキーマを設定する手順は、次のとおりです。

  1. トポロジ・ナビゲータから「物理アーキテクチャ」タブを表示します。

  2. 「テクノロジ」ノードを開きます。

  3. Oracleノードを開いて、物理データ・サーバーを表示します。

  4. 「データ・サーバー」ノードを開きます。

    図B-44 ODI Studio物理アーキテクチャのデータ・サーバー・ノード

    図B-44の説明が続きます
    「図B-44 ODI Studio物理アーキテクチャのデータ・サーバー・ノード」の説明

  5. BRM_STG.BRM_STGをダブルクリックして、物理スキーマ: <Name>ダイアログを表示します。

  6. 「定義」タブを表示して、表B-8に示すように適切な情報を入力します。

    図B-45 ODI Studio物理スキーマの定義タブ

    図B-45の説明が続きます
    「図B-45 ODI Studio物理スキーマの定義タブ」の説明

    表B-8 ODI Studio物理スキーマの定義タブのプロパティおよび値

    フィールド 説明

    スキーマ(スキーマ)

    <Physical Schema>がドロップダウン・リストから選択されていることを確認します(たとえば、BRM_STAGEなど)。

    スキーマ(作業スキーマ)

    <Physical Schema>がドロップダウン・リストから選択されていることを確認します(たとえば、BRM_STGなど)。


    注意: 他のフィールド値を変更しないでください。

  7. クリックして詳細を保存します。

注意: 同じ手順(1-7)に従って、BRM_SRCおよびOCDM_SYS物理スキーマを構成します。

論理データ・サーバーの設定

論理データ・サーバーを設定する手順は、次のとおりです。

  1. トポロジ・ナビゲータから「論理アーキテクチャ」タブを表示します。

  2. 「テクノロジ」ノードを開きます。

  3. Oracleノードを開いて、論理データ・サーバーを表示します。

    図B-46 ODI Studio論理データ・サーバーの論理アーキテクチャ

    図B-46の説明が続きます
    「図B-46 ODI Studio論理データ・サーバーの論理アーキテクチャ」の説明

  4. BRM_STG_LSノードをダブルクリックして、論理データ・サーバー: <Name>ダイアログを表示します。

  5. 「定義」タブを表示します。

  6. BRM_STG_LS論理データ・サーバーを編集して、適切なコンテキスト(たとえば、グローバル、開発など)に対して「物理スキーマ」列の値がBRM_STG_BRM_STG (物理データ・サーバーで作成された物理スキーマ)に設定されていることを確認します。

    図B-47 ODI Studio論理スキーマの論理データ・サーバー定義タブ

    図B-47の説明が続きます
    「図B-47 ODI Studio論理スキーマの論理データ・サーバー定義タブ」の説明

  7. 「保存」アイコンをクリックして、詳細を保存します。

  8. コンテキストが適切に設定されているかどうかを確認したら、「トポロジ」→「物理アーキテクチャ」タブで、物理スキーマの「コンテキスト」タブが正しい論理コンテキストを示していることを確認します。

    図B-48 ODI Studio論理データ・サーバーのコンテキスト・タブ

    図B-48の説明が続きます
    「図B-48 ODI Studio論理データ・サーバーのコンテキスト・タブ」の説明

注意: これらの手順(1-7)に従って、BRM_SRC_LSおよびOCDM_SYS_LS論理データ・サーバーを構成します。これらの手順を終了したら、ODIのインストールは完了です。

BRMアダプタのOracle GoldenGateの設定

Oracle Communications Data Modelに対してOracle GoldenGateを設定するには、次の手順を実行します。

BRMアダプタのターゲットへのOracle GoldenGateのインストール

BRMアダプタのリアルタイム取得を使用するには、次のようにOracle GoldenGate (GG)をインストールして構成します。

  1. ディレクトリをデータベース・インストール・パスに変更します(たとえば、/u02/app/oracle/productなど)。

    図B-49 Oracle Databaseインストール・パスへのディレクトリの変更

    図B-49の説明が続きます
    「図B-49 Oracle Databaseインストール・パスへのディレクトリの変更」の説明

  2. 製品フォルダの下にOracle GoldenGateをインストールする(gg)という名前のディレクトリを作成します。

    [oracle@server product]$ mkdir /u02/app/oracle/product/gg
    

    または、製品フォルダに直接移動して、フォルダ(gg)を手動で作成します。

    [oracle@server product]$ export GGATE=/u02/app/oracle/product/gg
    [oracle@server product]$ cd $GGATE
    [oracle@server gg]$
    
  3. ダウンロードしたソフトウェア(たとえば、V22228-01.zipなど)をggフォルダ(Oracle GoldenGateのダウンロードの詳細は、「Oracle GoldenGate」を参照してください)にコピーします。

  4. 次のコマンドを使用して、フォルダのソフトウェアを解凍します。

    [oracle@server gg]$ unzip V22228-01.zip
    
  5. ファイルを解凍した後、tarコマンドで.tar拡張子のファイルを使用してOracle GoldenGateを抽出します。

    次のコマンドを使用して、Oracle GoldenGate .tarファイルを圧縮します。

    [oracle@server gg] tar -xf filename.tar
    
  6. 次のコマンドを使用して、GGライブラリのパスをLD_LIBRARY_PATHにエクスポートします。

    export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$GGATE
    
  7. GGコマンドライン・ユーティリティ(ggsci)を起動します。

    [oracle@server gg]$. /ggsci
    

    このコマンドにより、Oracle GoldenGateサーバーに接続されます。次に例を示します。

    Oracle GoldenGate Command Interpreter for Oracle
    Version 11.1.1.0.0 Build 078
    Linux, x86, 32bit (optimized), Oracle 11 on Jul 28 2010 13:22:25
    Copyright (C) 1995, 2010, Oracle and/or its affiliates. All rights reserved
    
  8. ggに必要な作業ディレクトリを作成します。

    GGSCI (server.oracle.com) 1>create subdirs
    GGSCI (server.oracle.com) 2>exit
    [oracle@server gg]$ mkdir $GGATE/diroby
    
  9. これらの手順の実行後、Oracle GoldenGateがインストールされます。

Oracle GoldenGateをインストールした後、Oracle GoldenGate Replicationのソースおよびターゲット・データベースを準備します。

注意: 「BRMアダプタのターゲットへのOracle GoldenGateのインストール」の手順1から9は、ソース・データベースとターゲット・データベースの両方に共通です。これらの同じ手順は、「BRMアダプタのソースへのOracle GoldenGateのインストール」にも記載されています。

BRMアダプタのターゲットでのOracle GoldenGateの構成

Oracle GoldenGateスキーマを設定するには、次の手順を実行します。

  1. ggateスキーマを作成します。

    SQL>sqlplus / as sysdba;
    SQL> create user ggate identified by ggate default tablespace users temporary tablespace temp;
    

    注意: Oracle GoldenGateスキーマでは、デフォルト・パスワード(ggateなど)が設定フェーズ中に提供されます。これは変更できますが、関連するprmおよびobyファイルでデフォルト・パスワードを変更する必要もあります(詳細は、手順4「ggateのデフォルトのスキーマおよびパスワードの編集」を参照してください)。

  2. ggateスキーマに権限を付与します。

    SQL> grant connect, resource, unlimited tablespace to ggate;
    SQL> grant select any dictionary to ggate;
    SQL> grant execute on utl_file to ggate;
    SQL> grant alter any table to ggate;
    SQL> grant create table to ggate;
    SQL> grant select any table, insert any table, update any table, delete any table to ggate;
    SQL>exit;
    
  3. ターゲット構成ファイルを$GGATEディレクトリにコピーします。

    ターゲット・マシンのファイルは次の場所に生成されています。

    $OCDM\utl\adapter\brm\goldengate_param\stg

    これらのファイルをターゲット・マシンの次の場所($GGATEE)に、同じディレクトリ構造を使用してコピーする必要があります。

    • goldengate_param\stg\dirprmに含まれるファイルを$GGATEE\dirprmにコピーします。

    • goldengate_param\stg\dirobyに含まれるファイルを$GGATEE\dirobyにコピーします。

  4. デフォルトのスキーマおよびパスワードを編集します。

    デフォルトのスキーマおよびパスワードは、ggateです。

    • 環境に応じてファイル$GGATE\diroby\ brm_ogg_stg_cdc_cmd.obyを編集します。次のコマンドで適切な値を使用します。

    DBLOGIN USERID userid, PASSWORD passwd
    
    • 環境に応じてファイル$GGATE\dirprm\ globals.prmを編集します。次のコマンドで値を変更します。

    GGSCHEMA ggate
    CHECKPOINTTABLE ggate.ggschkpt
    
  5. マネージャ・ポートを構成します。

    ターゲットのデフォルト・マネージャ・ポートは7809ですが、必要に応じて次のファイルでポートを編集します。

    $GGATEE\dirprm\mgr.prm
    
  6. REPLICATでBRM_SRCおよびBRM_STGを編集します。

    デフォルトのBRM_SRCおよびBRM_STGスキーマはbrm_srcおよびbrm_stgです。ファイル$GGATEE\dirprm\repbrm.prmを編集し、環境に応じて2つのスキーマ名を変更します。たとえば、次のような行を探して変更します。

    map brm_src.ACCOUNT_NAMEINFO_T, TARGET brm_stg.ACCOUNT_NAMEINFO_T, KEYCOLS (OBJ_ID0,REC_ID), REPERROR (1403, DISCARD)
    

    これを次のように変更します。

    map pin5003.ACCOUNT_NAMEINFO_T, TARGET brm_stg_ogg.ACCOUNT_NAMEINFO_T, KEYCOLS (OBJ_ID0,REC_ID), REPERROR (1403, DISCARD)
    
  7. Replicatグループを追加します。

    <target>システムで、次のコマンドを実行してrepbrmという配信グループを追加します。

    [oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/ brm_ogg_stg_cdc_cmd.oby
    

    注意: brm_ogg_stg_cdc_cmd.obyのバッチ・コマンドを手動で実行すると、1つのコマンドごとに結果を参照できます。次に例を示します。

    最初にggsciにログインして次のコマンドを実行します。

    ./ggsci

    GGSCI (slc00tcw) 1> ADD REPLICAT repbrm, EXTTRAIL ./dirdat/rt, checkpointtable ggate.ggschkpt
    

BRMアダプタのソースへのOracle GoldenGateのインストール

BRMアダプタのリアルタイム取得を使用するには、次のようにOracle GoldenGate (GG)をインストールして構成します。

  1. ディレクトリをデータベース・インストール・パスに変更します(たとえば、/u02/app/oracle/productなど)。

    図B-50 Oracle Databaseインストール・パスへのディレクトリの変更

    図B-50の説明が続きます
    「図B-50 Oracle Databaseインストール・パスへのディレクトリの変更」の説明

  2. 製品フォルダの下にOracle GoldenGateをインストールする(gg)という名前のディレクトリを作成します。

    [oracle@server product]$ mkdir /u02/app/oracle/product/gg
    

    または、製品フォルダに直接移動して、フォルダ(gg)を手動で作成します。

    [oracle@server product]$ export GGATE=/u02/app/oracle/product/gg
    [oracle@server product]$ cd $GGATE
    [oracle@server gg]$
    
  3. ダウンロードしたソフトウェア(たとえば、V22228-01.zipなど)をggフォルダ(Oracle GoldenGateのダウンロードの詳細は、「Oracle GoldenGate」を参照してください)にコピーします。

  4. 次のコマンドを使用して、フォルダのソフトウェアを解凍します。

    [oracle@server gg]$ unzip V22228-01.zip
    
  5. ファイルを解凍した後、tarコマンドで.tar拡張子のファイルを使用してOracle GoldenGateを抽出します。

    次のコマンドを使用して、Oracle GoldenGate .tarファイルを圧縮します。

    [oracle@server gg] tar -xf filename.tar
    
  6. 次のコマンドを使用して、GGライブラリのパスをLD_LIBRARY_PATHにエクスポートします。

    export LD_LIBRARY_PATH=$ORACLE_HOME/lib:$GGATE
    
  7. GGコマンドライン・ユーティリティ(ggsci)を起動します。

    [oracle@server gg]$. /ggsci
    

    このコマンドにより、Oracle GoldenGateサーバーに接続されます。次に例を示します。

    Oracle GoldenGate Command Interpreter for Oracle
    Version 11.1.1.0.0 Build 078
    Linux, x86, 32bit (optimized), Oracle 11 on Jul 28 2010 13:22:25
    Copyright (C) 1995, 2010, Oracle and/or its affiliates. All rights reserved
    
  8. ggに必要な作業ディレクトリを作成します。

    GGSCI (server.oracle.com) 1>create subdirs
    GGSCI (server.oracle.com) 2>exit
    [oracle@server gg]$ mkdir $GGATE/diroby
    
  9. これらの手順の実行後、Oracle GoldenGateがインストールされます。

BRMアダプタのソース・システムでのOracle GoldenGateの構成

  1. 次のようにデータベースをアーカイブ・ログ・モードに切り替えます。

    [oracle@server dbhome_1]$ sqlplus / as sysdba
    SQL>shutdown immediate
    SQL>startup mount
    SQL>alter database archivelog;
    SQL>alter database open;
    
  2. 最小サプリメンタル・ロギングを有効にします。

    SQL>alter database add supplemental log data;
    

    ログを切り替えて、サプリメンタル・ロギングを開始します。

    SQL> ALTER SYSTEM SWITCH LOGFILE;
    SQL> ALTER SYSTEM SWITCH LOGFILE;
    

    サプリメンタル・ロギングが有効であることを確認します(結果がYESになります)。

    SQL> SELECT SUPPLEMENTAL_LOG_DATA_MIN FROM V$DATABASE;
    
  3. データベースのリサイクルビンをオフにします。

    SQL>alter system set recyclebin=off scope=spfile;
    
  4. ggateスキーマを作成します。

    SQL> create user ggate identified by ggate default tablespace users temporary tablespace temp;
    

    注意: Oracle GoldenGateスキーマでは、デフォルト・パスワード(ggateなど)が設定フェーズ中に提供されます。これは変更できますが、関連するprmおよびobyファイルでデフォルト・パスワードを変更する必要もあります。

  5. ggateスキーマに権限を付与します。

    SQL> grant connect, resource, unlimited tablespace to ggate;
    SQL> grant select any dictionary to ggate;
    SQL> grant select any table to ggate;
    SQL> grant alter any table to ggate;
    SQL> grant flashback any table to ggate;
    SQL> grant execute on dbms_flashback to ggate;
    SQL> grant execute on utl_file to ggate;
    SQL> exit;
    

    Trandataを実行するには、ソース・システムでサプリメンタル・ロギングを有効にする必要があります。サプリメンタル・ロギングを有効にするには、次のコマンドを使用します。

    alter database add supplemental log data;
    
  6. ソース構成ファイルを$GGATEディレクトリにコピーします。

    ソース・マシンのファイルは$OCDM \utl\adapter\brm\goldengate_param\srcに生成されています。

    これらのファイルをソース・マシンの次の場所($GGATEE)に、同じディレクトリ構造を使用してコピーする必要があります。

    • goldengate_param\src\dirprmのファイルを$GGATEE\dirprmにコピーします。

    • goldengate_param\src\dirobyのファイルを$GGATEE\dirobyにコピーします。

  7. マネージャ・ポートを構成します。

    ソースのデフォルト・マネージャ・ポートは7890です。必要に応じて次のファイルでこのポートを編集します。

    $GGATEE\dirprm\mgr.prm

  8. RMTHOSTを構成します。

    作業環境の必要に応じて、$GGATEE\dirprmディレクトリのexpbrm.prmファイルでRMTHOSTおよびMGRPORTを変更します。

    RMTHOST <Remote Host Name>, MGRPORT <Port>
    

    次に例を示します。

    rmthost slc00tcw, mgrport 7809
    
  9. EXTRACTでBRM_SRCスキーマを構成します。

    BRMアダプタのデフォルト・ソース・スキーマは、BRM_SRCです。ソース・システム・スキーマを通じてソース・スキーマ名を変更します。たとえば、brm_src ->pin5003です。

    $GGATE\dirprm\extbrm.prmでBRM_SRCスキーマを変更します。

    次に例を示します。

    Table pin5003.ACCOUNT_NAMEINFO_T, KEYCOLS (OBJ_ID0,REC_ID)
    

    $GGATE\dirprm\extpbrm.prmでBRM_SRCスキーマを変更します。

    次に例を示します。

    Table pin5003.ACCOUNT_NAMEINFO_T;
    

    $GGATE\diroby\ brm_ogg_src_cdc_cmd.obyでBRM_SRCスキーマを変更します。次に例を示します。

    add TRANDATA pin5003.ACCOUNT_NAMEINFO_T COLS(OBJ_ID0,REC_ID), NOKEY
    

    注意:

    1. ファイルbrm_ogg_src_cdc_cmd.obyで、ACCOUNT_T表を除く現在のすべてのマッピング表に対して次のコマンドを使用します。

      ADD TRANDATA <Source Schema Name>.<Table Name> COLS(col1, col2,…), NOKEY
      
    2. 各表のTRANDATAが実行されている場合、次のコマンドを使用してそれを削除します。

      DELETE TRANDATA <Source Schema Name>.*
      
  10. データ・ポンプを使用した変更取得の構成

    この方法の目標は、次のとおりです。

    • 変更を取得する抽出プロセスを構成および追加します。

    • これらの変更を格納するローカル・トレイルを追加します。

    • データ・ポンプ抽出を構成および追加してローカル・トレイルを読み取り、ターゲットのリモート・トレイルを作成します。

    • リモート・トレイルを追加します。

    <source>システムで、次のコマンドを実行してextbrmという抽出グループおよびextpbrmというデータ・ポンプ抽出を定義し、Oracle GoldenGateローカル・トレイルからデータを抽出してターゲットのOracle GoldenGateにこれらの変更をルーティングします。

    [oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/brm_ogg_src_cdc_cmd.oby
    

    注意: ほとんどの場合、obyファイルに記載されているバッチ・コマンドを、Oracle GoldenGateコマンドライン・ユーティリティ(ggsci)で1つずつ手動で実行します。

ソース・システムでのOracle GoldenGateプロセスの起動

プライマリ抽出プロセスおよびデータ・ポンプ抽出プロセスを起動するには、ソース・システムで次のコマンドを実行します。

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/brm_ogg_src_cdc_start_cmd.oby

ターゲット・システムでのOracle GoldenGateプロセスの起動

ターゲット・システムでOracle GoldenGateプロセスを起動するには、ターゲット・システムで次のコマンドを実行します。

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/brm_ogg_stg_cdc_start_cmd.oby

Oracle GoldenGate処理確認コマンド・リファレンス

表B-9に、Oracle GoldenGateプロセス・コマンドの概要を示します。注意: GGSCIからこれらのコマンドを実行します。

表B-9 Oracle GoldenGateプロセス・コマンドの概要

プロセス領域 コマンド

すべてのサービスの起動

マネージャ: Start Manager

抽出: Start Extract <Extract Group>

レプリケート: Start Replicat <Replicat Group>

抽出およびReplicat: Start ER *

すべてのサービスの停止

マネージャ: Stop Manager

抽出: Stop Extract <Extract Group>

レプリケート: Stop Replicat <Replicat Group>

抽出およびReplicat: Stop ER *

サービス・ステータスの確認

すべてのサービス: Info All

マネージャ: Info Mgr

抽出: Info Extract <Extract Group>

レプリケート: Info Replicat <Replicat Group>

レポートの表示

抽出: View Report <Extract Group>

レプリケート: View Report <Replicat Group>


BRMアダプタのインストールのトラブルシューティング

既存のリポジトリを削除するには、次の操作を実行します。

Drop user (Master_Repo_user) cascade;
create user (Master_Repo_user) identified by (pswd) default tablespace users temporary tablespace temp;
grant connect, resource to (Master_Repo_user);
grant execute on dbms_lock to (Master_Repo_user);

この項の内容は次のとおりです。

マスターおよび作業リポジトリのインポート・エラー

エラー・メッセージ:

Error: /…./…./…./….xml (No such file or directory)

このエラーは、「ZIPファイルからインポート」オプションを使用してリポジトリをインポートする場合に発生する可能性があります。

回避策:

このエラーを解決するには、マスターおよび作業リポジトリのZIPファイルを解凍し、「フォルダからインポート」オプションを使用して再度インポートを開始します。

エラー・リカバリ: マスター・リポジトリの再インポート

(既存のマスター・リポジトリの)マスター・リポジトリをインポートする手順は、次のとおりです。

  1. トポロジ・ナビゲータのツールバー・メニューから、「インポート」→「マスター・リポジトリ」の順に選択します(図B-51を参照)。

    図B-51 ODI Studioマスター・リポジトリのインポート

    図B-51の説明が続きます
    「図B-51 ODI Studioマスター・リポジトリのインポート」の説明

  2. 「インポート・モード」で「フォルダからインポート」を選択し、「OK」をクリックします(図B-52)。

    図B-52 再インポート: フォルダからインポート

    図B-52の説明が続きます
    「図B-52 再インポート: フォルダからインポート」の説明

    指定したファイルが現在のマスター・リポジトリにインポートされます。

  3. 指定された場所からマスター・リポジトリを参照します。

    リポジトリの場所:"$BRM_OCDM_HOME/odi_repository/brm_ocdm_adapter_master"

    図B-53 ODI Studioマスター・リポジトリのオープンおよびインポート

    図B-53の説明が続きます
    「図B-53 ODI Studioマスター・リポジトリのオープンおよびインポート」の説明

    図B-54 ODI Studioマスター・リポジトリのインポートの進行中

    図B-54の説明が続きます
    「図B-54 ODI Studioマスター・リポジトリのインポートの進行中」の説明

  4. インポート・レポートを確認し、「保存」をクリックしてこのレポートを保存できます。

    図B-55 再インポート: インポート・レポートのリスト

    図B-55の説明が続きます
    「図B-55 再インポート: インポート・レポートのリスト」の説明

エラー・リカバリ: 作業リポジトリの再インポート

作業リポジトリをインポートするには:

  1. デザイナ・ナビゲータのツールバー・メニューから、「インポート」→「作業リポジトリ」の順に選択します(図B-56を参照)。

    図B-56 ODI Studio作業リポジトリのインポート

    図B-56の説明が続きます
    「図B-56 ODI Studio作業リポジトリのインポート」の説明

  2. 「インポート・モード」で「フォルダからインポート」または「ZIPファイルからインポート」を選択し、「OK」をクリックします。

    図B-57 ODI Studio ZIPファイルからの作業リポジトリのインポート

    図B-57の説明が続きます
    「図B-57 ODI Studio ZIPファイルからの作業リポジトリのインポート」の説明

    指定したファイルが作業リポジトリにインポートされます。

  3. 指定された場所から作業リポジトリを参照します。

    リポジトリの場所:

    $BRM_OCDM_HOME/odi_repository/brm_ocdm_adapter_work.zip

    図B-58 ODI Studio ZIPファイルからの作業リポジトリのインポート

    図B-58の説明が続きます
    「図B-58 ODI Studio ZIPファイルからの作業リポジトリのインポート」の説明

    図B-59 ODI Studio作業リポジトリのオープンおよびインポートの進行中

    図B-59の説明が続きます
    「図B-59 ODI Studio作業リポジトリのオープンおよびインポートの進行中」の説明

    図B-60 再インポート: 作業リポジトリの警告メッセージ・ダイアログ

    図B-60の説明が続きます
    「図B-60 再インポート: 作業リポジトリの警告メッセージ・ダイアログ」の説明

    インポート・レポートを確認し、レポートを保存するために「保存」をクリックします。

    図B-61 再インポート: 作業リポジトリのレポート

    図B-61の説明が続きます
    「図B-61 再インポート: 作業リポジトリのレポート」の説明

「デザイナ」タブの「プロジェクト」および「モデル」領域を表示して、作業リポジトリの内容を参照できます。

図B-62 ODIデザイナ・ナビゲータとプロジェクトおよびモデルの表示

図B-62の説明が続きます
「図B-62 ODIデザイナ・ナビゲータとプロジェクトおよびモデルの表示」の説明

エラーODI-26005: 別のリポジトリからのオブジェクトのインポート

エラー・メッセージ:

ODI-26005: 別のリポジトリからオブジェクトを同じ識別子でインポートしようとしています。

考えられる原因: インポート・ファイルのオブジェクトに、リポジトリにすでに存在する識別子が含まれます。

図B-63 BRMアダプタの問題のトラブルシューティング

図B-63の説明が続きます
「図B-63 BRMアダプタの問題のトラブルシューティング」の説明

回避策:

一意の識別子を使用するように、インポートXMLファイルのcom.sunopsis.dwg.dwgobj.SnpImportRepオブジェクト・セクションを手動で変更することを検討します。

このエラー(ODI-26005)を解決するには、リポジトリに応じて変更を行います。

マスター・リポジトリでのODIエラーの解決

マスター・リポジトリ: ODIマスター・リポジトリのIDを変更するには、次の手順に従ってリポジトリIDの再番号付けを行います。

  1. トポロジ・ナビゲータで、「リポジトリ」タブを開きます。

  2. 図B-64に示すように、マスター・リポジトリを右クリックして「再番号付け」をクリックします。

    図B-64 マスター・リポジトリの再番号付け

    図B-64の説明が続きます
    「図B-64 マスター・リポジトリの再番号付け」の説明

  3. これにより、「リポジトリの再番号付け - ステップ1」ダイアログが表示されます。図B-65に示すように、「はい」をクリックしてリポジトリIDの再番号付けを行います。

    図B-65 リポジトリの再番号付け(ステップ1)

    図B-65の説明が続きます
    「図B-65 リポジトリの再番号付け(ステップ1)」の説明

  4. マスター・リポジトリの新しいIDを入力して「OK」をクリックします。これにより、図B-66に示すように、「リポジトリの再番号付け - ステップ2」ダイアログが表示されます。

    図B-66 リポジトリの再番号付け(ステップ2)

    図B-66の説明が続きます
    「図B-66 リポジトリの再番号付け(ステップ2)」の説明

  5. IDの変更を確認するには、図B-67に示すように、マスター・リポジトリをダブルクリックし、「バージョン」タブを開いて新しいIDが割り当てられているかどうかを確認します。

    図B-67 リポジトリIDの確認

    図B-67の説明が続きます
    「図B-67 リポジトリIDの確認」の説明

作業リポジトリでのODIエラーの解決

ODI作業リポジトリのIDを変更するには、次の手順に従ってリポジトリIDの再番号付けを行います。

  1. トポロジ・ナビゲータで、「リポジトリ」タブを開きます。

  2. 「作業リポジトリ」を開き、作業リポジトリを右クリックして「再番号付け」をクリックします。

    図B-68 作業リポジトリの再番号付け

    図B-68の説明が続きます
    「図B-68 作業リポジトリの再番号付け」の説明

  3. これにより、「リポジトリの再番号付け - ステップ1」ダイアログが表示されます。「はい」をクリックしてリポジトリIDの再番号付けを行います。

    図B-69 作業リポジトリの再番号付け(ステップ1)

    図B-69の説明が続きます
    「図B-69 作業リポジトリの再番号付け(ステップ1)」の説明

  4. 「リポジトリの再番号付け - ステップ2」ダイアログで「OK」をクリックします。

    図B-70 作業リポジトリの再番号付け(ステップ2)

    図B-70の説明が続きます
    「図B-70 作業リポジトリの再番号付け(ステップ2)」の説明

  5. 作業リポジトリの新しいIDを入力して「OK」をクリックします。

    図B-71 作業リポジトリの再番号付け(ステップ3)

    図B-71の説明が続きます
    「図B-71 作業リポジトリの再番号付け(ステップ3)」の説明

  6. 「はい」をクリックして変更を確定します。

    図B-72 再番号付け操作の確認

    図B-72の説明が続きます
    「図B-72 再番号付け操作の確認」の説明

  7. IDの変更を確認するには、作業リポジトリをダブルクリックし、「バージョン」タブを開いて新しいIDが割り当てられていることを確認します。

    図B-73 リポジトリIDの変更の確認

    図B-73の説明が続きます
    「図B-73 リポジトリIDの変更の確認」の説明

エラーのトラブルシューティング: ダイアグラムのオープン中に発生する内部エラー

ODIリリース11.1.1.5.0の問題に関連する次のエラーが発生することがあります。

ERROR: An internal error occurred while opening the diagram

回避策:

ODI Studioで、破損した統合インタフェースを開き、「バージョン」タブに移動して内部IDを取得します。ODI作業リポジトリ表をホストするデータベースに接続し、次のSQLコマンドを実行して変更を適用します。

delete from SNP_TXT
where I_TXT in (
select I_TXT_XMI_DATA
from SNP_DIAGRAM
where I_POP = <your internal ID>);
delete from SNP_DIAGRAM
where I_POP = <your internal ID>;
commit;

この次に統合インタフェースを開くと、新しいマッピングおよびフロー・マップが作成され、問題が解決されます。