ヘッダーをスキップ
Oracle® Communications Data Modelインストレーション・ガイド
リリース11.3.1
B70211-01
  目次へ移動
目次
索引へ移動
索引

前
前
 
次
次
 

A NCCアダプタのインストールおよび構成

この付録では、次のものをインストールおよび設定する方法について示します。

この付録には、次の項が含まれます。


注意:

この項の手順の実行に時間がかかる場合があります。

アプリケーション・アダプタ・タイプ・インストールでインストールされるNCCアダプタは、Oracle Communications Network Charging and ControlアプリケーションからOracle Communications Data Modelにプリペイド請求データをフィードします。NCCアダプタには、Oracle Communications Data Modelステージング・レイヤーに対してOracle GoldenGateを使用してリアルタイムのデータをフィードしたり、Oracle Data Integratorを使用してバッチ・モードのデータを抽出、ロードおよび変換したりするオプションが含まれます。

NCCアダプタ構成の前提条件

Oracle Communications Data ModelのOracle Communications Network Charging and Controlアダプタ(NCCアダプタ)をインストールする前提条件は、次のとおりです。

Oracle Data Integrator Enterprise Editionがインストールされていることの確認

Oracle Data Integrator Enterprise Editionのインストールを確認するには、ODI Studioを起動します。

  1. 「スタート」メニューで、「すべてのプログラム」→「Oracle」→「Oracle Data Integrator」→「ODI Studio」の順に選択します。

  2. デザイナ・ナビゲータで「リポジトリへの接続」をクリックします。

Oracle Data Integrator Enterprise Editionがインストールされていない場合、「Oracle Data Integrator Enterprise Edition」を参照してください。

Oracle GoldenGateがインストールされていることの確認

Oracle Communications Data ModelのOracle Communications Network Charging and Controlアダプタ(NCCアダプタ)をインストールする場合、Oracle GoldenGateの使用、インストールおよび構成は、NCCアダプタでリアルタイム・ステージングを使用するかどうかによってオプションになります。

Oracle GoldenGateがインストールされていない場合、「Oracle GoldenGate」を参照してください。

Oracle Communications Data ModelのNCCアダプタのインストールの概要

この付録には、ソース・データのデータ・ロード、変換および検証にステージング・データベースを設定する手順が含まれます。作業を開始するには、ODIマスター・リポジトリおよび作業リポジトリを設定し、Oracle Data Integrator(ODI)を使用する必要があります。オプションで、Oracle GoldenGateを使用している場合、Oracle GoldenGateをインストールおよび構成してリアルタイムETLを実行する必要があります。

スキーマOCDM_SYSの参照表のNCCのロード値の設定

Oracle Communications Data Modelスキーマ(OCDM_SYS)の次のスクリプトを実行して不明な(-1)レコードをすべての参照表に挿入し、Oracle Communications Data Model表とNCCソース・データ間の参照整合性を維持します。

スクリプトの場所:

"$NCC_OCDM_HOME/utl/disable_constraint.sql”

"$NCC_OCDM_HOME/utl/enable_constraint.sql”

"$NCC_OCDM_HOME/utl/insert_dummy_reference.sql”

"$NCC_OCDM_HOME/utl/disable_constraint_final.sql”

sqlplusからOCDM_SYSスキーマに接続し、"$NCC_OCDM_HOME/utl"ディレクトリから次のスクリプトを次のように実行します。

SQL> @./disable_constraint.sql
SQL> @./enable_constraint.sql
SQL> @./insert_dummy_reference.sql

SQL> exec disb_cons;
SQL> exec insert_ref;
SQL> exec enab_cons;
SQL> @./disable_constraint_final.sql

次のプロシージャを実行します。

"disable_constraint_final.sql"のスクリプトは、特定のOracle Communications Data ModelのFK制約を無効にして、NCCソース・データを挿入します。

Oracle Communications Data ModelのNCCアダプタのステージング・スキーマの設定

NCCアダプタのステージング・スキーマの説明は、次のとおりです。

Oracle Communications Data ModelのNCCアダプタのOracle Data Integratorの構成

Oracle Communications Data ModelのOracle Data Integratorの構成には、次の手順が含まれます。

ODIマスター・リポジトリの作成および接続

  1. ODI Studioを開きます。

    「スタート」→「プログラム」→「Oracle」→「Oracle Data Integrator」→「ODI Studio」

    図A-1 ODI Studioを開く

    図A-1の説明が続きます
    「図A-1 ODI Studioを開く」の説明

  2. 新規ギャラリを開きます。

    「ファイル」→「新規」

    新規ギャラリの「カテゴリ」ツリーで、「ODI」を選択します。

    「項目」リストから「マスター・リポジトリ作成ウィザード」を選択します。

    「OK」をクリックします。

    マスター・リポジトリ作成ウィザードが表示されます。

    図A-2 ODI Studio新規ギャラリ

    図A-2の説明が続きます
    「図A-2 ODI Studio新規ギャラリ」の説明

    図A-3 ODI Studio新規ギャラリのマスター・リポジトリの作成

    図A-3の説明が続きます
    「図A-3 ODI Studio新規ギャラリのマスター・リポジトリの作成」の説明

  3. マスター・リポジトリ作成ウィザードで、JDBCドライバの参照アイコン、Oracle JDBCドライバの順に選択します。「OK」をクリックします。

    JDBC URLを編集して、jdbc:oracle:thin: @localhost:1521:orcを読み取ります。

    ユーザーにrepo、パスワードにpasswordと入力します。

    「接続のテスト」をクリックして、正常な接続を確認します。

    「OK」をクリックします。

    「マスター・リポジトリ作成ウィザード」画面で、「次へ」をクリックします。

    図A-4 ODI Studioマスター・リポジトリ作成ウィザード

    図A-4の説明が続きます
    「図A-4 ODI Studioマスター・リポジトリ作成ウィザード」の説明

    図A-5 ODI Studioマスター・リポジトリの正常な作成

    図A-5の説明が続きます
    「図A-5 ODI Studioマスター・リポジトリの正常な作成」の説明

  4. 認証ウィンドウで、スーパーバイザ・パスワードにpasswordと入力します。

    パスワードの確認のため再度passwordと入力します。

    「次へ」をクリックします。

    注意: ODIユーザー名およびパスワードは、大文字/小文字が区別されます。

    図A-6 ODI Studioマスター・リポジトリ作成パスワード

    図A-6の説明が続きます
    「図A-6 ODI Studioマスター・リポジトリ作成パスワード」の説明

  5. パスワード記憶域ウィンドウで、「内部パスワード記憶域」を選択し、「終了」をクリックします。マスター・リポジトリを正しく作成すると、Oracle Data Integrator情報メッセージが表示されます。

    「OK」をクリックします。ODIマスター・リポジトリが作成されます。

    図A-7 ODI Studioマスター・リポジトリの作成終了

    図A-7の説明が続きます
    「図A-7 ODI Studioマスター・リポジトリの作成終了」の説明

    図A-8 ODI Studioマスター・リポジトリの作成完了

    図A-8の説明が続きます
    「図A-8 ODI Studioマスター・リポジトリの作成完了」の説明

  6. 新しいODIマスター・ログインを作成して、ODIマスター・リポジトリに接続します。「ファイル」→「新規」を選択して新規ギャラリを開きます。新規ギャラリの「カテゴリ」ツリーで、「ODI」を選択します。「項目」リストから「新規ODIリポジトリ・ログインの作成」を選択します。

    図A-9 ODI Studio新規ギャラリのODIリポジトリ・ログイン

    図A-9の説明が続きます
    「図A-9 ODI Studio新規ギャラリのODIリポジトリ・ログイン」の説明

  7. 次に示す表のパラメータを使用して、リポジトリ接続を構成します。JDBC URLを入力するには、画面に示すように、「JDBC URL」フィールドの横にあるボタンをクリックし、jdbc:oracle:thin:@<host>:<port>:<sid>を選択して、URLを編集します。「マスター・リポジトリのみ」ボタンを選択します。

    「テスト」をクリックします。

    正常な接続を確認して、「OK」をクリックします。

    「OK」をクリックして接続を保存します。

    表A-1 Oracle Data Integrator接続

    パラメータ 値

    ログイン名

    NCC Master Repository

    ユーザー

    SUPERVISOR

    パスワード

    password


    表A-2 データベース接続(マスター・リポジトリ)

    パラメータ 値

    ユーザー

    repo

    パスワード

    password

    ドライバ・リスト

    Oracle JDBCドライバ

    ドライバ名

    oracle.jdbc.OracleDriver

    URL

    jdbc:oracle:thin:@<system_name>:<listener port>:<SID>

    次に例を示します。

    jdbc:oracle:thin:@localhost:1521:orcl
    

    注意: 「JDBC URL」フィールドでコピーして貼り付けないでください。有効なURL文字列の入力で問題が発生する場合があります。かわりに、ドロップダウン・メニューを開いて、リストから正しいドライバを選択します。「URL」フィールドで正しいURLを入力します。

    図A-10 ODI Studioリポジトリ接続情報

    図A-10の説明が続きます
    「図A-10 ODI Studioリポジトリ接続情報」の説明

    図A-11 ODI Studioリポジトリ接続の成功

    図A-11の説明が続きます
    「図A-11 ODI Studioリポジトリ接続の成功」の説明

  8. 「リポジトリへの接続」をクリックします。ドロップダウン・リストから新しく作成したリポジトリ接続のマスター・リポジトリを選択します。「OK」をクリックします。ODIトポロジ・マネージャが起動します。ODIトポロジ・マネージャに正常にログインしています。

    図A-12 ODI Studioリポジトリ接続

    図A-12の説明が続きます
    「図A-12 ODI Studioリポジトリ接続」の説明

    図A-13 Oracle Data Integratorログイン

    図A-13の説明が続きます
    「図A-13 Oracle Data Integratorログイン」の説明

    図A-14 Oracle Data Integrator NCCマスター・リポジトリ・トポロジ

    図A-14の説明が続きます
    「図A-14 Oracle Data Integrator NCCマスター・リポジトリ・トポロジ」の説明

ODI作業リポジトリの作成および接続

  1. Oracle Databaseスキーマおよびユーザーを作成した後、ODIトポロジ・ナビゲータを使用してODI作業リポジトリを作成します。

    ODIで、「トポロジ・ナビゲータ」タブ、「リポジトリ」パネルの順にクリックします。「作業リポジトリ」ノードを右クリックして「新規作業リポジトリ」を選択します。

    作業リポジトリの作成ウィザードが開きます。

    図A-15 ODIトポロジ・ナビゲータの新規作業リポジトリ

    図A-15の説明が続きます
    「図A-15 ODIトポロジ・ナビゲータの新規作業リポジトリ」の説明

  2. 後続の画面で、表A-3に示すパラメータを入力します。

    「テスト」をクリックして正常な接続を確認し、「OK」をクリックします。

    「次へ」をクリックします。

    表A-3 新規作業リポジトリのパラメータ

    パラメータ 値

    テクノロジ

    Oracle

    ドライバ名

    oracle.jdbc.driver.OracleDriver

    JDBC URL

    jdbc:oracle:thin:@<system_name>:<listener port>:<SID>

    次に例を示します。

    jdbc:oracle:thin:@localhost:1521:orcl

    ユーザー

    wrep

    パスワード

    password


    図A-16 ODI Studio作業リポジトリの作成のテスト接続

    図A-16の説明が続きます
    「図A-16 ODI Studio作業リポジトリの作成のテスト接続」の説明

    図A-17 ODIリポジトリの作業リポジトリの作成の接続成功

    図A-17の説明が続きます
    「図A-17 ODIリポジトリの作業リポジトリの作成の接続成功」の説明

  3. ODI作業リポジトリ・プロパティの指定ページで、次の値を設定します。

    「ID」を1に設定します。

    「名前」をWORKREP_NCCに設定します。

    「パスワード」にpasswordと入力します。

    「作業リポジトリ・タイプ」リストで、「開発」を選択します。

    「終了」をクリックします。

    図A-18 ODI Studio ODI作業リポジトリの作成のプロパティ

    図A-18の説明が続きます
    「図A-18 ODI Studio ODI作業リポジトリの作成のプロパティ」の説明

    図A-19 ODI Studio ODI作業リポジトリの作成のODIアクションの開始中

    図A-19の説明が続きます
    「図A-19 ODI Studio ODI作業リポジトリの作成のODIアクションの開始中」の説明

  4. 作業リポジトリ・ログインの作成ウィンドウで、「はい」をクリックします。

    ログイン名にNCC Work Repositoryと入力します。

    「OK」をクリックします。

    新しく作成した作業リポジトリが作業リポジトリ・ツリー・ビューにあることを確認します。

    図A-20 ODI Studio ODI作業リポジトリの作成のログインの作成

    図A-20の説明が続きます
    「図A-20 ODI Studio ODI作業リポジトリの作成のログインの作成」の説明

    図A-21 ODI Studio ODI作業リポジトリのログイン名の入力

    図A-21の説明が続きます
    「図A-21 ODI Studio ODI作業リポジトリのログイン名の入力」の説明

    図A-22 ODI Studio ODI作業リポジトリのトポロジ

    図A-22の説明が続きます
    「図A-22 ODI Studio ODI作業リポジトリのトポロジ」の説明

  5. マスター・リポジトリから切断して、作業リポジトリに接続します。

    「ODI」をクリックして、NCCマスター・リポジトリの切断を選択します。

    図A-23 ODI Studioマスター・リポジトリからの切断

    図A-23の説明が続きます
    「図A-23 ODI Studioマスター・リポジトリからの切断」の説明

  6. 「リポジトリへの接続」をクリックします。

    「ログイン名」ドロップダウン・リストからNCC作業リポジトリを選択します。

    「パスワード」にpasswordと入力します。

    「OK」をクリックします。

    「デザイナ」タブをクリックします。

    ODIデザイナ画面が図A-24に示すように表示されます。

    図A-24 ODI Studio NCC作業リポジトリへのリポジトリ接続

    図A-24の説明が続きます
    「図A-24 ODI Studio NCC作業リポジトリへのリポジトリ接続」の説明

    図A-25 ODI Studio Oracle Data Integratorログイン

    図A-25の説明が続きます
    「図A-25 ODI Studio Oracle Data Integratorログイン」の説明

    ODI作業リポジトリが正常に作成され、接続されています。

  7. 「デザイナ」タブを確認すると、プロジェクトおよびモデルがこの作業リポジトリにありません。

    図A-26 ODI Studioデザイナ・タブ

    図A-26の説明が続きます
    「図A-26 ODI Studioデザイナ・タブ」の説明

ODIマスター・リポジトリのインポート

マスター・リポジトリのインポートおよびエクスポート手順を実行すると、トポロジ・ドメインおよびセキュリティ・ドメインを含むリポジトリ全体をあるリポジトリから別のリポジトリに転送できます。

既存のマスター・リポジトリのマスター・リポジトリをインポートする手順は、次のとおりです。

  1. トポロジ・ナビゲータのツールバー・メニューから、「インポート」→「マスター・リポジトリ」の順に選択します。

  2. 「インポート・モード」を選択して、フォルダまたはZIPファイルをインポートします。

  3. 「OK」をクリックします。

指定したファイルが現在のマスター・リポジトリにインポートされます。

図A-27 ODI Studioマスター・リポジトリのインポート

図A-27の説明が続きます
「図A-27 ODI Studioマスター・リポジトリのインポート」の説明

図A-28 ODI Studioマスター・リポジトリのインポートのモードおよびオプション

図A-28の説明が続きます
「図A-28 ODI Studioマスター・リポジトリのインポートのモードおよびオプション」の説明

次に指定する場所からマスター・リポジトリを参照します。

リポジトリの場所:

"$NCC_OCDM_HOME/odi_repository/ncc_ocdm_adapter_master.zip"

図A-29 ODI Studioマスター・リポジトリのオープンおよびインポート

図A-29の説明が続きます
「図A-29 ODI Studioマスター・リポジトリのオープンおよびインポート」の説明

図A-30 ODI Studioマスター・リポジトリのインポートの進行中

図A-30の説明が続きます
「図A-30 ODI Studioマスター・リポジトリのインポートの進行中」の説明

「インポート・レポート」を確認し、「保存」をクリックしてこのレポートを保存します。

図A-31 ODI Studioマスター・リポジトリのインポート・レポート

図A-31の説明が続きます
「図A-31 ODI Studioマスター・リポジトリのインポート・レポート」の説明

ODI作業リポジトリのインポート

作業リポジトリをインポートまたはエクスポートすると、すべての作業リポジトリのオブジェクトをあるリポジトリから別のリポジトリに転送できます。

作業リポジトリをインポートするには:

  1. デザイナ・ナビゲータのツールバー・メニューから、「インポート」→「作業リポジトリ」の順に選択します。

  2. 「インポート・モード」を選択して、フォルダまたはZIPファイルをインポートします。

  3. 「OK」をクリックします。

指定したファイルが作業リポジトリにインポートされます。

図A-32 ODI Studio作業リポジトリのインポート

図A-32の説明が続きます
「図A-32 ODI Studio作業リポジトリのインポート」の説明

図A-33 ODI Studio ZIPファイルからの作業リポジトリのインポート

図A-33の説明が続きます
「図A-33 ODI Studio ZIPファイルからの作業リポジトリのインポート」の説明

指定された場所から作業リポジトリを参照します。

$NCC_OCDM_HOME/odi_repository/ncc_ocdm_adapter_work.zip

図A-34 ODI Studio作業リポジトリを開く

図A-34の説明が続きます
「図A-34 ODI Studio作業リポジトリを開く」の説明

図A-35 ODI Studio作業リポジトリのオープンおよびインポートの進行中

図A-35の説明が続きます
「図A-35 ODI Studio作業リポジトリのオープンおよびインポートの進行中」の説明

図A-36 ODI Studio作業リポジトリのインポートの警告

図A-36の説明が続きます
「図A-36 ODI Studio作業リポジトリのインポートの警告」の説明

インポート・レポートを確認し、「保存」をクリックしてレポートを保存できます。

図A-37 ODI Studio作業リポジトリのインポート・レポート

図A-37の説明が続きます
「図A-37 ODI Studio作業リポジトリのインポート・レポート」の説明

「デザイナ」タブのプロジェクトおよびモデルを使用すると、作業リポジトリのプロジェクトおよびモデルを表示できます。

図A-38 ODI Studioデザイナ・タブのプロジェクトおよびモデルの表示

図A-38の説明が続きます
「図A-38 ODI Studioデザイナ・タブのプロジェクトおよびモデルの表示」の説明

ODIトポロジの設定

ODIトポロジを設定するには、次の手順に従います。

物理データ・サーバーの設定

物理データ・サーバーを設定する手順は、次のとおりです。

  1. トポロジ・ナビゲータから「物理アーキテクチャ」タブを表示します。

  2. 「テクノロジ」ノードを開きます。

  3. Oracleノードを開いて、物理データ・サーバーを表示します。

    図A-39 ODI Studio物理データ・サーバー

    図A-39の説明が続きます
    「図A-39 ODI Studio物理データ・サーバー」の説明

  4. NCC_STGノードをダブルクリックして、データ・サーバー: <Name>ダイアログを表示します。

  5. 「定義」タブを表示して、表A-4に示すように適切な情報を入力します。

    図A-40 ODI Studioデータ・サーバー定義ダイアログ

    図A-40の説明が続きます
    「図A-40 ODI Studioデータ・サーバー定義ダイアログ」の説明

    表A-4 ODI Studioデータ・サーバー定義のフィールドおよび値

    フィールド 説明

    名前

    データ・サーバーの名前を変更しないでください。

    テクノロジ

    デフォルト値のOracleを変更しないでください。

    インスタンス/dblink(データ・サーバー)

    データベース・インスタンス名を指定します。

    Oracle SID名を使用します。たとえば、ORCLなどです。

    ユーザー

    <User Name>を指定します。たとえば、ncc_stgなどです。

    これは、ウェアハウス・データベース・ユーザー名です。

    パスワード

    <Password>を指定します。たとえば、ncc_stgなどです。

    これは、ウェアハウス・データベース・ユーザー名のデフォルトのパスワードです。

    配列フェッチ・サイズ

    環境に適した値を指定します。

    (デフォルト値は変更しないでください)。

    バッチ更新サイズ

    環境に適した値を指定します。

    (デフォルト値は変更しないでください)。


  6. 「JDBC」タブを表示して、表A-5に示すように適切な情報を入力します。

    図A-41 ODI Studioデータ・サーバーのJDBCタブ

    図A-41の説明が続きます
    「図A-41 ODI Studioデータ・サーバーのJDBCタブ」の説明

    表A-5 ODI Studioデータ・サーバーのJDBCタブのフィールドおよび値

    フィールド 説明

    JDBCドライバ

    oracle.jdbc.driver.OracleDriverを指定します。

    JDBC URL

    jdbc:oracle:thin:@<host>:<port>:<sid>形式で指定します。

    <host>、<port>および<sid>をODIリポジトリをホストするデータベースの値に置き換えます。

    たとえば、'jdbc:oracle:thin:@localhost:1521:orcl'などです。


  7. <Connection>ダイアログで、「テスト」をクリックしてテスト接続を表示します。

    図A-42 ODI Studioデータ・サーバーのテスト接続

    図A-42の説明が続きます
    「図A-42 ODI Studioデータ・サーバーのテスト接続」の説明

  8. 「保存」アイコンをクリックして、詳細を保存します。


注意:

同じ手順(1-8)に従って、NCC_BE, NCC_CCSおよびOCDM_SYS物理データ・サーバーを構成します。

物理スキーマの設定

データ・サーバーの物理スキーマを設定する手順は、次のとおりです。

  1. トポロジ・ナビゲータから「物理アーキテクチャ」タブを表示します。

  2. 「テクノロジ」ノードを開きます。

  3. Oracleノードを開いて、物理データ・サーバーを表示します。

  4. 「データ・サーバー」ノードを開きます。

    図A-43 ODI Studio物理アーキテクチャのデータ・サーバー・ノード

    図A-43の説明が続きます
    「図A-43 ODI Studio物理アーキテクチャのデータ・サーバー・ノード」の説明

  5. NCC_STG.NCC_STGをダブルクリックして、物理スキーマ: <Name>ダイアログを表示します。

  6. 「定義」タブを表示して、表A-6に示すように適切な情報を入力します。

    図A-44 ODI Studio物理スキーマの定義タブ

    図A-44の説明が続きます
    「図A-44 ODI Studio物理スキーマの定義タブ」の説明

    表A-6 ODI Studio物理スキーマの定義タブのプロパティおよび値

    フィールド 説明

    スキーマ(スキーマ)

    <Physical Schema>がドロップダウン・リストから選択されていることを確認します(たとえば、NCC_STGなど)。

    スキーマ(作業スキーマ)

    <Physical Schema>がドロップダウン・リストから選択されていることを確認します(たとえば、NCC_STGなど)。


    注意: 他のフィールド値を変更しないでください。

  7. クリックして詳細を保存します。

注意: 同じ手順(1-7)に従って、NCC_BE、NCC_CCSおよびOCDM_SYS物理スキーマを構成します。

論理データ・サーバーの設定

論理データ・サーバーを設定する手順は、次のとおりです。

  1. トポロジ・ナビゲータから「論理アーキテクチャ」タブを表示します。

  2. 「テクノロジ」ノードを開きます。

  3. Oracleノードを開いて、論理データ・サーバーを表示します。

    図A-45 ODI Studio論理データ・サーバーの論理アーキテクチャ

    図A-45の説明が続きます
    「図A-45 ODI Studio論理データ・サーバーの論理アーキテクチャ」の説明

  4. NCC_STG_LSノードをダブルクリックして、論理データ・サーバー: <Name>ダイアログを表示します。

  5. 「定義」タブを表示します。

  6. NCC_STG_LS論理データ・サーバーを編集して、適切なコンテキスト(たとえば、グローバル、開発など)に対して「物理スキーマ」列の値がNCC_STG.NCC_STG (物理データ・サーバーで作成された物理スキーマ)に設定されていることを確認します。

    図A-46 ODI Studio論理スキーマの論理データ・サーバー定義タブ

    図A-46の説明が続きます
    「図A-46 ODI Studio論理スキーマの論理データ・サーバー定義タブ」の説明

  7. 「保存」アイコンをクリックして、詳細を保存します。

    注意: 同じ手順(1-7)に従って、NCC_BE_LS、NCC_CCS_LSおよびOCDM_SYS_LS論理データ・サーバーを構成します。

Oracle Communications Data ModelのNCCアダプタのOracle GoldenGateの設定

Oracle Communications Data Modelに対してOracle GoldenGateを設定するには、次の手順を実行します。

Oracle GoldenGateのインストール

Oracle GoldenGateをインストールするには、次の手順に従います。

  1. ディレクトリをデータベース・インストール・パスに変更します(たとえば、/u02/app/oracle/productなど)。

    図A-47 Oracle GoldenGateインストール・パスへのディレクトリの変更

    図A-47の説明が続きます
    「図A-47 Oracle GoldenGateインストール・パスへのディレクトリの変更」の説明

  2. 製品フォルダの下にOracle GoldenGateをインストールする(gg)という名前のディレクトリを作成します。

    [oracle@server product]$ mkdir /u02/app/oracle/product/gg
    

    または、製品フォルダに直接移動して、フォルダ(gg)を手動で作成します。

    [oracle@server product]$ export GGATE= /u02/app/oracle/product/gg
    [oracle@server product]$ cd $GGATE
    [oracle@server gg]$
    
  3. ダウンロードしたOracle GoldenGate(たとえば、V22228-01.zipなど)をggフォルダ(Oracle GoldenGateのダウンロードの詳細は、「Oracle GoldenGate」を参照してください)にコピーします。

  4. 次のコマンドを使用して、フォルダのソフトウェアを解凍します。

    [oracle@server gg]$ unzip V22228-01.zip
    
  5. ファイルを解凍した後、.tar拡張子のファイルを使用してOracle GoldenGateを抽出します。

  6. 次のコマンドを使用して、Oracle GoldenGate .tarファイルを圧縮します。

    [oracle@server gg] tar -xf <filename>.tar
    
  7. 次のコマンドを使用して、GGライブラリのパスをLD_LIBRARY_PATHにエクスポートします。

    export LD_LIBRARY_PATH=$ORACLE_HOME/lib:/u02/app/oracle/product/gg
    
  8. GGコマンドライン・ユーティリティ(ggsci)を起動します。

    [oracle@server gg]$. /ggsci
    

    このコマンドにより、Oracle GoldenGateサーバーに接続されます。

    次に例を示します。

    Oracle GoldenGate Command Interpreter for Oracle Version 11.1.1.0.0 Build 078 Linux, x86, 32bit (optimized), Oracle 11 on Jul 28 2010 13:22:25 Copyright (C) 1995, 2010, Oracle and/or its affiliates. All rights reserved.
    
    GGSCI (server.oracle.com) 1>
    
  9. ggに必要な作業ディレクトリを作成します。

    GGSCI (server.oracle.com) 1>create subdirs
    GGSCI (server.oracle.com) 2>exit
    [oracle@server gg]$ mkdir $GGATE/diroby
    [oracle@server gg]$ mkdir $GGATE/discard
    
  10. これらの手順の実行後、Oracle GoldenGateがインストールされます。

    Oracle GoldenGateをインストールした後、Oracle GoldenGate Replicationのソースおよびターゲット・データベースを準備および構成します。

Oracle GoldenGateの構成

Oracle GoldenGateスキーマを設定する手順は、次のとおりです。

  1. データベース・サーバーをアーカイブ・ログ・モードに切り替えます。


    注意:

    アーカイブ・ログ・モードへのデータベース・サーバーの設定は、本番システムにお薦めします。このモードは、開発システムのテストまたは使用では必要ありません。

    oracleユーザーからsqlplusに接続します。

    [oracle@server dbhome_1]$ sqlplus / as sysdba
    SQL>shutdown immediate
    SQL>startup mount
    SQL>alter database archivelog;
    SQL>alter database open;
    
  2. 最小サプリメンタル・ロギングを有効にします。

    SQL>alter database add supplemental log data;
    

    図A-48 Oracle GoldenGate構成のデータベース・オプションを設定するコマンド

    図A-48の説明が続きます
    「図A-48 Oracle GoldenGate構成のデータベース・オプションを設定するコマンド」の説明

    ログを切り替えて、サプリメンタル・ロギングを開始します。

    SQL> ALTER SYSTEM SWITCH LOGFILE;
    SQL> ALTER SYSTEM SWITCH LOGFILE;
    

    サプリメンタル・ロギングが有効であることを確認します(次のコマンドで結果が'YES'になります)。

    SQL> SELECT SUPPLEMENTAL_LOG_DATA_MIN FROM V$DATABASE;
    
  3. データベースを準備して、データベース・レプリケーションをサポートします。データベースのリサイクルビンをオフにします。

    SQL>alter system set recyclebin=off scope=spfile;
    
  4. ddlレプリケーションのスキーマを作成します。

    SQL>create user ggate identified by qwerty default tablespace users temporary tablespace temp;
    
  5. 必要な権限を新しいユーザーに付与します。

    SQL> grant connect,resource to ggate;
    SQL> grant select any dictionary, select any table to ggate;
    SQL> grant create table to ggate;
    SQL> grant flashback any table to ggate;
    SQL> grant execute on dbms_flashback to ggate;
    SQL> grant execute on utl_file to ggate;
    SQL> GRANT SELECT ANY TABLE, INSERT ANY TABLE, UPDATE ANY TABLE, DELETE ANY
    TABLE TO GGATE;
    SQL> Grant alter any table to ggate; 
    
  6. SQLを終了します。

    SQL>exit
    

    次のパスに移動して、次のコマンドを発行します。

    [oracle@server product]$ export GGATE= /u02/app/oracle/product/gg
    [oracle@server product]$ cd $GGATE
    

    これらのコマンドは、プロンプトを次のように変更します。

    [oracle@server gg]$
    

    sqlplusを起動します。

    [oracle@server gg]$sqlplus '\ as sysdba'
    
  7. 指定されたスクリプトを実行して、ddlレプリケーションをサポートする必要なオブジェクトの作成を確認します。

    1. 次のスクリプトを実行します。

      SQL> @$GGATE/marker_setup.sql
      

      このコマンドを使用すると、スキーマの名前が求められます。

      スキーマにggateと入力します。

      図A-49に、これらの手順の画面を示します。

      図A-49 Oracle GoldenGateの構成

      図A-49の説明が続きます
      「図A-49 Oracle GoldenGateの構成」の説明

    2. スクリプトを実行します。

      SQL> @$GGATE/ddl_setup.sql
      

      図A-50 Oracle GoldenGate ddl_setupスクリプトを実行する構成

      図A-50の説明が続きます
      「図A-50 Oracle GoldenGate ddl_setupスクリプトを実行する構成」の説明

      値Yesの入力後、図A-51に示す値が表示されます。

      図A-51 Oracle GoldenGate ddl_setupスクリプトの構成値

      図A-51の説明が続きます
      「図A-51 Oracle GoldenGate ddl_setupスクリプトの構成値」の説明

      INITIALSETUPの入力後、図A-52に示す結果が表示されます。

      図A-52 Oracle GoldenGate ddl_setupスクリプトが完了した構成画面

      図A-52の説明が続きます
      「図A-52 Oracle GoldenGate ddl_setupスクリプトが完了した構成画面」の説明

    3. コマンドを入力して、role_setup.sqlスクリプトを実行します。

      SQL> @$GGATE/role_setup.sql
      
    4. コマンドを入力して、アクセス権をGGS_GGUSER_ROLEに付与します。

      SQL> grant GGS_GGSUSER_ROLE to ggate;
      
    5. コマンドを入力して、ddl_enable.sqlスクリプトを実行します。

      SQL> @$GGATE/ddl_enable.sql
      

      図A-53に示すプロンプトに従います。

      図A-53 Oracle GoldenGateスクリプトの構成: role_setup.sql

      図A-53の説明が続きます
      「図A-53 Oracle GoldenGateスクリプトの構成: role_setup.sql」の説明

    6. ggateユーザーに接続し、次の13個の表が作成されたことを確認します。

      GGS_BF_CACHE
      GGS_DDL_COLUMNS
      GGS_DDL_HIST
      GGS_DDL_HIST_ALT
      GGS_DDL_LOG_GROUPS
      GGS_DDL_OBJECTS
      GGS_DDL_PARTITIONS
      GGS_DDL_PRIMARY_KEYS
      GGS_MARKER
      GGS_SETUP
      GGS_STICK
      GGS_TEMP_COLS
      GGS_TEMP_UK
      

注意:

「Oracle GoldenGateのインストール」および「Oracle GoldenGateの構成」と同じ手順に従って、ソース・システム(ncc_ccsおよびncc_be)とステージング・サーバー(ncc_stg)にOracle GoldenGateをインストールおよび構成します。

Oracle GoldenGate処理確認コマンド・リファレンス

表A-7に、Oracle GoldenGateプロセス・コマンドの概要を示します。注意: GGSCIからこれらのコマンドを実行します。

表A-7 Oracle GoldenGateプロセス・コマンドの概要

プロセス領域 コマンド

すべてのサービスの起動

マネージャ: Start Manager

抽出: Start Extract <Extract Group>

レプリケート: Start Replicat <Replicat Group>

抽出およびReplicat: Start ER *

すべてのサービスの停止

マネージャ: Stop Manager

抽出: Stop Extract <Extract Group>

レプリケート: Stop Replicat <Replicat Group>

抽出およびReplicat: Stop ER *

サービス・ステータスの確認

すべてのサービス: Info All

マネージャ: Info Mgr

抽出: Info Extract <Extract Group>

レプリケート: Info Replicat <Replicat Group>

レポートの表示

抽出: View Report <Extract Group>

レプリケート: View Report <Replicat Group>


データ・ポンプを使用した変更取得の構成

この方法の目標は、次のとおりです。

プライマリ抽出およびデータ・ポンプの構成

抽出グループおよびデータ・ポンプ抽出グループを追加します。

src_ccsソース・システム:

CCS <source>システムで、次のコマンドを実行してext1という抽出グループおよびdpumpというデータ・ポンプ抽出を定義し、GoldenGateローカル・トレイルからデータを抽出してターゲットのGoldenGateにこれらの変更をルーティングします。

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/ncc_ogg_src_cdc_cmd_101_sms.oby

be_ccsソース・システム:

BE <source>システムで、次のコマンドを実行してext1という抽出グループおよびdpumpというデータ・ポンプ抽出を定義し、GoldenGateローカル・トレイルからデータを抽出してターゲットのGoldenGateにこれらの変更をルーティングします。

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/ ncc_ogg_src_cdc_cmd_102_vws.oby

注意: Oracle RAC以外の環境では、THREADSパラメータを省略できます。また、THREADS <instances>を1に設定できます。

変更配信の構成

Replicatグループを追加します。<staging>システムで、次のコマンドを実行してrep1およびrep2という配信グループを追加します。

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/ ncc_ogg_stg_cdc_cmd.oby

注意: 正しい2文字の抽出設定<trail id>を参照してください。

抽出プロセスの開始

プライマリ抽出プロセスおよびデータ・ポンプ抽出プロセスを開始します。

<source>システムで、次のコマンドを実行します。

src_ccsソース・システム:

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/ncc_ogg_src_cdc_start_cmd_101.oby

be_ccsソース・システム:

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/ncc_ogg_src_cdc_start_cmd_102.oby

Replicatプロセスの開始

<staging>システムで、次のコマンドを実行します。

[oracle@server gg]$ $GGATE/./ggsci paramfile $GGATE/diroby/ncc_ogg_stg_cdc_start_cmd.oby