- OCF server
ocfserv [-D] [-p path]
The OCF server, ocfserv, is a per-host daemon that acts as the central point of communications with all smartcards connected to the host. Applications that need to use a smartcard can do so by using the APIs in libsmartcard.so or smartcard.jar. The internal implementation of these APIs communicates with ocfserv to perform the requested function.
inetd(1M) automatically starts the ocfserv command when it is needed. Once started, ocfserv runs forever. If ocfserv is killed or crashes, it restarts automatically if necessary.
Because ocfserv is run automatically, there really is not a reason to run it manually. You must have root privileges to execute this utility.
The following options are supported:
Run ocfserv in debug mode.
Specify property file name.
The following exit values are returned:
An error occurred.
File where server stores properties
See attributes(5) for descriptions of the following attributes:
The ocfserv service is managed by the service management facility, smf(5), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). Responsibility for initiating and restarting this service is delegated to inetd(1M). Use inetadm(1M) to make configuration changes and to view configuration information for this service. The service's status can be queried using the svcs(1) command.