- NetXen 10/1 Gigabit Ethernet network driver
The ntxn 10/1 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, dlpi(7P), on NetXen 10/1 Gigabit Ethernet controllers.
The ntxn driver functions include chip initialization, frames transmit and receive, promiscuous and multicast support, TCP and UDP checksum off-load (IPv4) and 9600 bytes jumbo frame.
The ntxn driver and hardware support the 10GBASE CX4, 10GBASE-SR/W, LR/W, and 10/100/1000BASE-T physical layers.
The cloning character-special device, /dev/ntxn, is used to access all NetXen devices installed within the system.
The values returned by the driver in the DL_INFO_ACK primitive in response to your DL_INFO_REQ are:
Maximum SDU is 9600.
Minimum SDU is 0.
DLSAP address length is 8.
MAC type is DL_ETHER.
SAP (Service Access Point) length value is -2, meaning the physical address component is followed immediately by a 2-byte SAP component within the DLSAP address.
Broadcast address value is the Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).
By default, the ntxn driver works without any configuration file.
Special character device.
32–bit device driver (x86).
64–bit device driver (x86).
See attributes(5) for descriptions of the following attributes:
STREAMS Programming Guide
Network Interfaces Programmer's Guide