Sun Microsystems Logo
Products and Services
 
Support and Training
 
 

A  B  C  D  E  F  G  H  I  J  K  L  M  N  O  P  Q  R  S  T  U  V  W  X  Y  Z  
 
Application Server Utilityclsetup(1m)


NAME

 clsetup - automates the cluster setup process

SYNOPSIS

 clsetup [ --help ] [ --instancefile instance_file ] [ --resourcefile resource_file ] [ --passwordfile password_file ]
 clsetup [ --help ] [ --instancefile instance_file ] [ --passwordfile password_file ]verify

DESCRIPTION

Use clsetup command to simplify the task of setting up a cluster on a typical machine configuration. The clsetup command can create instances if they do not already exist, and perform cluster setup on these instances based on the configurations in the input files.

The following input files are required for the clsetup command to function:

clinstance.conf

contains information about the application server instances that are part of the cluster.

clresource.conf

contains information about the HADB database and other resource information.

clpassword.conf

contains the asadmin password and is pre-populated with the correct password during a standard installation.

By default, the input files are located in the application server configuration directory:/etc/opt/SUNWappserver7. Additionally, the clsetup command is located by default in installdir/bin.

Before editing the input files, ensure the following:

  • The order of the entries must not be changed.

  • Any line that starts with a hash mark (#) is treated as a comment.

  • If the entities to be handled (HADB database nodes and application server instances) already exist, the clsetup command does not delete or reconfigure them, and the respective configuration steps are skipped.

Before running the clsetup command you must:

  • have the asadmin and hadbm command on the local machine.

  • use the clsetup command as-is to setup a typical cluster configuration.

  • set up HADB for administration. The HADB management agents should be running on all hosts that are part of the cluster.

  • use the same administrator password for all domains that are part of the cluster.

  • start the administration servers of all instances that are part of the cluster.

During standard installation, the clinstance.conf file is created with entries for two instances. This occurs only if the Sun Java System Application Server is also installed. However, if only the application server administration client is installed on the machine, the clinstance and clpassword files installed on this machine are not pre-populated. If you add more instances to the cluster, you must update the clinstance.conf file with the information for the new instances. The information about the instances in each cluster must be defined in the instance file (default name is clinstance.conf). The following are the possible entries in the clinstance.conf file:

Table 1: Entries in the clinstance.conf file
EntryDefinitionDefault Value(s)
instanceName of the application server instanceserver1, server2
userAdministration server user nameadmin
hostHost namelocalhost
portPort number of the Administration Server4848
domainName of the Administrative domaindomain1
instanceportPort number of the application server instance80, 81
masterBoolean to indicate the master instancetrue. For first time installation.

The clresource.conf file contains information about the HADB database, JDBC connection pool, JDBC resource, session store, and session persistence. Permissions 0600 are preset on the clresource.conf file and it can be accessed only by the root user. The following are the possible entries in the clresource.conf file:


Table 2: Entries in the clresource.conf file
EntryDefinitionDefault Value
HADB Database Information
historypathPath for the history filesOn Unix: /var/tmpOn Windows: REPLACEDIR (REPLACEDIR is replaced by the actual URL at runtime.)
devicepathPath for the data and log devicesOn Unix: installdir/SUNWhadb/4.4.*On Windows: C:\Sun\AppServer7\SUNWhadb\4.4.*
datadevicesThe number of data devices on each node1
portbaseThe port base number used for node 015200
sparesThe number of spare nodes0
setComma separated list of database configuration attributes in the name=value format. This option allows for specifying different file paths for each node.Node-nodeno.device-devno.Path=pathAny device path that is not set for a particular node or device defaults to the --devicepath value.NOTE; The managementProtocol attribute has been deprecated.
agentSpecifies the host and port number where the management agent is listening. This value can be modified to be a remote machine if HADB is located on a different machine than where the application Server is installed. The value for the remote agent would be of the form: hostname (or IP address):port.localhost:1862
adminpassword The new adminpassword option introduced in HADB 4.4 version provides additional security. The default used in the clresource.conf file is: password. Users can change the default value to suit their requirements. password
devicesizeSize of the device in MB512
dbpasswordPassword for the system user of the databasepassword
hostsAll hosts used for all data nodeslocalhost,localhost
JDBC Connection Pool Information
steadypoolsizeMinimum and initial number of connections maintained in the pool8
maxpoolsizeMaximum number of connections that can be created32
datasourceclassnameName of the vendor supplied JDBC datasourcecom.sun.hadb.jdbc.ds.HadbDataSource
isolationlevelTransaction isolation level on the pooled database connectionsrepeatable-read
isisolationguaranteedTransaction isolation level guaranteedtrue
validationmethodtype of validation methodmeta-data
propertyProperty used to specify username, password, and resource configurationusername=appservusr:password=password:cacheDataBaseMetaData=false:eliminateRedundantEndTransaction=true:serverList=replaceurl
JDBC Resource Information
connectionpoolidName of the connection poolappservCPL
Session Store Information
storeurlJDBC URL of the HADB databasereplaceurlValue is replaced by the actual URL at runtime.
storeuserHADB user who has access to session storeappservusr
storepasswordpassword for store userpassword
dbsystempasswordDatabase system passwordpassword
Session Persistence Information
typeThe session persistence typeha
frequencyThe session persistence frequencyweb-method
scopeThe session scopesession
storeSession storejdbc/hastore
Stateful Session Bean Information
sfsbThe stateful session bean failovertrue
RMI IIOP Failover Information
rmi_iiopRMI IIOP cluster configurationtrue
Cluster ID Information
cluster_idCluster IDcluster1

The clpassword.conf file contains the administration server password. While executing the cladmin command, the asadmin command requires the administration server password specified in the clpassword.conf file. The format for the clpassword.conf file is :

AS_ADMIN_PASSWORD=password

Where password is the administration server password.

Permissions 0600 are preset on the clpassword.conf file and it can be accessed only by the root user.

A log file, named clsetup.log, is available in the /var/tmp directory. By default the clsetup command executes in verbose mode and logs information in the log file. Log file entries start and end with timestamp tags. If the log file exists prior to execution, the output is appended to the existing log file. Scan the log after each execution to verify that it ran properly.

OPTIONS

--help

displays the syntax of the command

--instancefile

filepath location to the instance filename (default is install_config_dir/ clinstance.conf).

--resourcefile

filepath location to the resource filename (default is install_config_dir/ clresource.conf).

--passwordfile

filepath location to the password filename (default is install_config_dir/ clpassword.conf).

OPERANDS

verify

Compares the configuration of the master instance with the other instances in the cluster. The applications, resources and cluster configuration is compared and the differences are written to the clsetup.log file. The --verify option cannot be used if --resourcefile is specified.

EXIT STATUS

0

successful exit

2

syntax error

3

instance file not found

4

instance file cannot be read

5

resource file not found

6

resource file cannot be read

7

password file not found

8

password file cannot be read

10

script cannot find asadmin

11

script cannot find hadbm

12

cannot create temporary file

13

session store configuration failed

14

create HADB database failed

15

HADB get JDBC URL failed

16

user exits in welcome message

17

cluster verification failed

ATTRIBUTES

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPEATTRIBUTE VALUE
Interface StabilityUnstable

SEE ALSO

asadmin(1M), cladmin(1M), hadbm(1M)


Sun Java System Application Server Enterprise Edition 7 2004Q2Go To TopLast Changed 29 Dec 2003