|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- set up NIS client
/usr/sbin/ypinit [-c] [-m] [-s master_server]
ypinit can be used to set up an NIS client system. You must be the superuser to run this command. This script need not be used at all if ypbind(1M) is started with the -broadcast option (it is invoked with this option from the svc:/network/nis/client:default service).
Normally, ypinit is run only once after installing the system. It may be run whenever a new NIS server is added to the network or an existing one is decommissioned.
ypinit prompts for a list of NIS servers to bind the client to; this list should be ordered from the closest to the furthest server. It is recommended that you list each of these NIS servers by name and numeric IP address in /etc/hosts. Though the practice is not recommended, NIS allows you to list servers by numeric address only, bypassing /etc/hosts. In such a configuration, ypwhich(1) returns a numeric address instead of a name.
ypinit stores the list of servers to which a client can bind in the file /var/yp/binding/domain/ypservers. This file is used by ypbind when run without the -broadcast option.
Set up a ypclient system.
Build a master ypserver data base.
Slave data base. master_server must be the same master configured in the YP maps and returned by the ypwhich -m command.
File in which it is recommended that NIS servers be listed.
Lists the servers to which the NIS client is allowed to bind.
See attributes(5) for descriptions of the following attributes:
The NIS client service is managed by the service management facility, smf(5), under the service identifier:
ypinit sets up the list of NIS servers only for the current domain on the system when it is run, that is, the domain returned by the SI_SRPC_DOMAIN command to sysinfo(2). Care should be taken to ensure that this is the same as the desired domain for NIS client processes.