|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- zones monitoring daemon
zonestatd is a system daemon that is started during system boot. It monitors the utilization of system resources by zones, as well as zone and system configuration information such as psrset psets, pool psets, and resource control settings.
This daemon is started automatically by the zone management software and should not be invoked directly. It does not constitute a programming interface; it is classified as a private interface.
The zonestat service in the global zone must be online for the zonestat service in each non-global zone (NGZ) to function properly. The zonestat service in each NGZ does not directly read system configuration and utilization data, but rather reads from the zonestat service on the global zone.
See attributes(5) for descriptions of the following attributes:
The zonestat service is managed by the service management facility, smf(5), under the service identifier:
The zonestat service has the following SMF configuration property:
This property sets the zonestatd sample interval. This is the interval used by the zones monitoring daemon, zonestatd to sample resource utilization. This is also the interval used to determine configuration changes such as processor set changes, resource control changes, and zone state changes.
The default interval is 5 seconds.
The zonestat service makes use of extended accounting facility. If not already enabled, it enables the tracking of process accounting resources, and configures a process accounting file. The zonestat service will roll the process accounting log at its configured interval (see zonestat(1)).
If extended process accounting is enabled externally, the zonestat service will use the process accounting log as configured. It will not roll the accounting log, but will operate correctly if the accounting log is rolled externally.