|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Information Library|
System Administration Commands - Part 1
System Administration Commands - Part 2
System Administration Commands - Part 3
- file transport program for the uucp system
/usr/lib/uucp/uucico [-f] [-c type] [-d spool-directory] [-i interface] [-r role-number] [-s system-name] [-x debug-level]
uucico is the file transport program for uucp work file transfers.
The following options are supported:
This option is used to "force execution" of uucico by ignoring the limit on the maximum number of uucicos defined in the /etc/uucp/Limits file.
The first field in the Devices file is the "Type" field. The -c option forces uucico to only use entries in the "Type" field that match the user specified type. The specified type is usually the name of a local area network.
This option specifies the directory spool-directory that contains the uucp work files to be transferred. The default spool directory is /var/spool/uucp.
This option defines the interface used with uucico. The interface only affects slave mode. Known interfaces are UNIX (default), TLI (basic Transport Layer Interface), and TLIS (Transport Layer Interface with Streams modules, read/write).
The role-number 1 is used for master mode. role-number 0 is used for slave mode (default). When uucico is started by a program or cron, role-number 1 should be used for master mode.
The -s option defines the remote system (system-name) that uucico will try to contact. It is required when the role is master; system-name must be defined in the Systems file.
Both uux and uucp queue jobs that will be transferred by uucico. These jobs are normally started by the uusched scheduler, for debugging purposes, and can be started manually. For example, the shell Uutry starts uucico with debugging turned on. The debug-level is a number between 0 and 9. Higher numbers give more detailed debugging information.
See attributes(5) for descriptions of the following attributes:
uucp(1C), uustat(1C), uux(1C), Uutry(1M), cron(1M), uusched(1M), attributes(5)