|Skip Navigation Links|
|Exit Print View|
|man pages section 4: File Formats Oracle Solaris 11.1 Information Library|
- name service cache daemon configuration
The SMF service svc:/system/name-service-cache contains the configuration information for nscd(1M). The nscd.conf file is considered obsolete.
The following nscd properties are supported:
config Property Group config/enable_per_user_lookup Enable per-user lookups config/per_user_nscd_time_to_live Per-user Nscd time to live config/logfile Log file location config/debug_level Debugging/Log level flags config/debug_components subsystem debugging config/global_check_smf_state_interval SMF status check interval
Enables or disables the ability of nscd to create a per-user nscd. A per-user nscd performs per-user lookups and manages the per-user cache. The per-user lookups might not be possible if the corresponding name service switch backends do not support it or are not configured to do so. The value of this attribute can be true or false.
Sets the time-to-live value for a per-user nscd based on the last time the per-user nscd was active. value is an integer that specifies a number of seconds.
Specifies name of the file to which debug info should be written. Use /dev/tty for standard output.
Sets the debug level desired. Note the configuration values and output of the debugging command is not likely to remain the same from release-to-release. Use the svccfg describe command to see the available levels. Debugging output formats should not be depended upon in scripts. Use the svccfg describe command to see release specific values.
Sets the nscd components to generate debugs messages. The configuration values and output of the debugging command is not likely to remain the same from release-to-release. Use the svccfg describe command to see the available levels. Debugging output formats should not be depended upon in scripts. Use the svccfg destribe command to see release specific values.
Additionally the following set of property groups share the same set of properties and manage the individual caches for each of the name service switch databases. The default property group contains any common configuration values for all caches. Additionally the following property groups can contain cache specific configuration:
host, password, group, network, protocol, rpc, ether, netmask, bootparam, publickey, netgroup, service, printer, project, auth_attr, prof_attr, tnrhtp, tnrhdb
The following properties are common to all the above property groups:
Enables or disables checking the file belonging to the specified cachename for changes. If enabled (which is the default), changes in the corresponding file cause the cache to be invalidated within 10 seconds. Can be disabled if files are never modified for a slight performance boost, particularly over NFS. value can be either true or false.
Enables or disables the specified cache. value can be either true or false.
This attribute allows the administrator to set the number of entries nscd(1M) is to keep current in the specified cache. value is an integer number which should approximate the number of entries frequently used during the day.
Sets the time-to-live for negative entries (unsuccessful queries) in the specified cache. value is in integer seconds. Can result in significant performance improvements if there are several files owned by uids (user IDs) not in system databases. Should be kept small to reduce cache coherency problems.
Sets the time-to-live for positive entries (successful queries) in the specified cache. value is in integer seconds. Larger values increase cache hit rates and reduce mean response times, but increase problems with cache coherence. Sites that push (update) NIS maps nightly can set value to be the equivalent of 12 hours or more with very good performance implications.
See attributes(5) for descriptions of the following attributes:
nscd(1M), auth_attr(4), bootparams(4), ethers(4), exec_attr(4), group(4), hosts(4), netmasks(4), networks(4), passwd(4), prof_attr(4), project(4), protocols(4), rpc(4), services(4), user_attr(4), attributes(5)