Sun Ethernet Fabric Operating System

Exit Print View

Updated: July 2015
 
 

Define TCP and UDP Traffic

You can define TCP and UDP traffic from a given subnet. Both rules are applied to interface 0/2. This application enables traffic to be separated from one port into two classes, then enqueued to separate queues on egress.

  1. Use the ip access-list and ip access-group commands to define the TCP and UDP traffic.
    SEFOS# configure terminal 
    SEFOS(config)# ip access-list extended 101 
    SEFOS(config-ext-nacl)# permit tcp 10.123.1.0 255.255.255.0 any 
    SEFOS(config-ext-nacl)# exit 
    SEFOS(config)# ip access-list extended 102 
    SEFOS(config-ext-nacl)# permit udp 10.123.1.0 255.255.255.0 any 
    SEFOS(config-ext-nacl)# exit 
    SEFOS(config)# ip access-list extended 110 
    SEFOS(config-ext-nacl)# permit ip any any 
    SEFOS(config-ext-nacl)# exit 
    SEFOS(config)# interface extreme-ethernet 0/2 
    SEFOS(config-if)# ip access-group 101 in 
    SEFOS(config-if)# ip access-group 102 in 
    SEFOS(config-if)# ip access-group 110 in 
    SEFOS(config-if)# end 
    
  2. Review the access list for ip 101.
    SEFOS# show access-lists ip 101 
    Extended IP Access List 101 
    ----------------------------- 
    Filter Priority                   : 1 
    Filter Protocol Type              : TCP 
    IP address Type                   : IPV4 
    Source IP address                 : 10.123.1.0 
    Source IP address mask            : 255.255.255.0 
    Source IP Prefix Length           : 24 
    Destination IP address            : 0.0.0.0 
    Destination IP address mask       : 0.0.0.0 
    Destination IP Prefix Length      : 0 
    Flow Identifier                   : 0 
    In Port List                      : Ex0/2 
    Out Port List                     : NIL 
    Filter TOS                        : NIL 
    Filter DSCP                       : NIL 
    Filter Source Ports From          : 0 
    Filter Source Ports Till          : 65535 
    Filter Destination Ports From     : 0 
    Filter Destination Ports Till     : 65535 
    Filter Action                     : Permit 
    Status                            : Active 
    
  3. Review the access list for ip 102.
    SEFOS# show access-lists ip 102 
    Extended IP Access List 102 
    ----------------------------- 
    Filter Priority                  : 1 
    Filter Protocol Type             : UDP 
    IP address Type                  : IPV4 
    Source IP address                : 10.123.1.0 
    Source IP address mask           : 255.255.255.0 
    Source IP Prefix Length          : 24 
    Destination IP address           : 0.0.0.0 
    Destination IP address mask      : 0.0.0.0 
    Destination IP Prefix Length     : 0 
    Flow Identifier                  : 0 
    In Port List                     : Ex0/2 
    Out Port List                    : NIL 
    Filter TOS                       : NIL 
    Filter DSCP                      : NIL 
    Filter Source Ports From         : 0 
    Filter Source Ports Till         : 65535 
    Filter Destination Ports From    : 0 
    Filter Destination Ports Till    : 65535 
    Filter Action                    : Permit 
    Status                           : Active
    
  4. Review the access list for ip 110.
    SEFOS# show access-lists ip 110 
    Extended IP Access List 110 
    ----------------------------- 
    Filter Priority               : 1 
    Filter Protocol Type          : ANY 
    IP address Type               : IPV4 
    Source IP address             : 0.0.0.0 
    Source IP address mask        : 0.0.0.0 
    Source IP Prefix Length       : 0 
    Destination IP address        : 0.0.0.0 
    Destination IP address mask   : 0.0.0.0 
    Destination IP Prefix Length  : 0 
    Flow Identifier               : 0 
    In Port List                  : Ex0/2 
    Out Port List                 : NIL 
    Filter TOS                    : NIL 
    Filter DSCP                   : NIL 
    Filter Action                 : Permit 
    Status                        : Active