HTTP Error 400 or 403 when Accessing Analysis Reports and Dashboards

Problem

When attempting to access Analysis Reports or a dashboard in Reporting and Analytics, the web browser returns HTTP error 400 - Bad Request or 403 - Forbidden.

Causes

The following problems can cause the error messages:
  • The server times may have de-synchronized.

  • The Published URL for the OBIEE server or the Reporting and Analytics server may be incorrect.

Resolutions

  • Make sure the server times are synchronized to the second. Use a domain controller or other time synchronization method to ensure that the servers do not become out of sync.

  • Verify the published site URLs:
    1. In the Oracle WebLogic console, navigate to the Summary of Servers page, click appServ1, click Configuration, click Federation Services, click SAML 2.0 General, and then and confirm and make note of the Published Site URL.

    2. A SAML 2.0 Identity Provider partner is an entity that generates SAML 2.0 assertions consumed by the Service Provider site. Navigate to Security Realms, click myrealm, click Providers, click Authentication, click the saml2AP identity assertion provider, click Management, and then click the app_data identity provider partner. Verify that the published site URL is used by the service endpoints.

    3. A SAML 2.0 Service Provider partner is an entity that consumes the SAML 2.0 assertions generated by the Identity Provider site. Navigate to Security Realms, click myrealm, click Providers, click Credential Mapper, click the saml2CMP credential mapping provider, click Management, and then click the obiee service provider partner. Verify that the published site URL is used by the service endpoints.

  • These instructions provide a high-level overview and basic guidance to the areas within the Oracle WebLogic console that apply to this task. The Oracle WebLogic Server documentation contains detailed information and instructions for understanding and performing configurations within the Oracle WebLogic console.