Deployment Time Outs

Problem

When manually deploying or re-deploying the web service Enterprise Application Archive (EAR) files, the Oracle WebLogic server times out.

Cause

Depending on your deployment, the web service EAR files can become large, causing the Oracle WebLogic Administration Server to time out despite still processing the file.

Resolution

  1. Log in to the Oracle WebLogic console.

  2. In the Domain Structure, click Environment, click Servers, and then click micros_cluster.

  3. Click the Configuration tab, click the Tuning tab, and then enter a larger time in seconds in the Stuck Thread Max Time field.

  4. In the Domain Structure, click your domain name.

  5. Click the Configuration tab, click the JTA tab, and then enter a larger time in seconds in the Timeout Seconds field.

If the problem persists, the Oracle Business WebLogic documentation contains more troubleshooting information and instructions.