Go to main content

man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: July 2017
 
 

tran_tgt_free(9E)

Name

tran_tgt_free - request to free HBA resources allocated on behalf of a target

Synopsis

#include <sys/scsi/scsi.h>

void prefixtran_tgt_free(dev_info_t *hba_dip, dev_info_t *tgt_dip,
     scsi_hba_tran_t *hba_tran, struct scsi_device *sd);

Interface Level

Solaris architecture specific (Solaris DDI).

Parameters

hba_dip

Pointer to a dev_info_t structure, referring to the HBA device instance.

tgt_dip

Pointer to a dev_info_t structure, referring to the target device instance.

hba_tran

Pointer to a scsi_hba_tran(9S) structure, consisting of the HBA's transport vectors.

sd

Pointer to a scsi_device(9S) structure, describing the target.

Description

The tran_tgt_free() vector in the scsi_hba_tran(9S) structure may be initialized during the HBA driver's attach(9E) to point to an HBA driver function to be called by the system when an instance of a target device is being detached. The tran_tgt_free () vector, if not NULL, is called after the target device instance has returned successfully from its detach(9E) entry point, but before the dev_info node structure is removed from the system. The HBA driver should release any resources allocated during its tran_tgt_init() or tran_tgt_probe() initialization performed for this target device instance.

See Also

attach(9E), detach(9E), tran_tgt_init(9E), tran_tgt_probe(9E), scsi_device(9S), scsi_hba_tran(9S)

Writing Device Drivers for Oracle Solaris 11.3