scgeo_protectiongroup_get -G protection-group -p property [-d] [-r]
The scgeo_protectiongroup_get command accesses information about an Oracle Solaris Cluster disaster recovery framework protection group.
Information is output by this command to the standard output (stdout) in formatted strings, as described in the scha_cmds(8HA) man page. Output is a string or several strings that are output on separate lines. You can store the output in shell variables. You can also parse the output by using the awk(1) command or other shell commands for further use by the script.
You must be root to use this command.
The following options are supported:
Specifies debug mode.
Indicates the protection-group information to be accessed.
Specifies the name of a protection-group property. The following property values retrieve the corresponding value of the named property.
APPLICATION_RG_LIST APPLICATION_RG_NODE_LIST CLUSTER_NAME CLUSTER_ROLE DESCRIPTION DEVICEGROUP_ENTRY_LIST EXTERNAL_DEPENDENCY_ALLOWED LOCAL_APPLICATION_RG_NODE_LIST LOCAL_CLUSTER_NAME LOCAL_CLUSTER_ROLE PARTNERSHIP_NAME PG_CREATION_NODENAME PG_VALIDATED PG_VALIDATED_LOCALLY PG_VALIDATED_REMOTELY REMOTE_APPLICATION_RG_NODE_LIST REMOTE_CLUSTER_NAME REMOTE_CLUSTER_ROLE ROLE_CHANGE_ACTION_ARGS ROLE_CHANGE_ACTION_COMMAND TIMEOUT
Additionally, you can specify property names that are specific to a data replication product.
Selects the remote value for non-global properties.
Use the following command to retrieve the name of the MySQL configuration script create_config_script that is used in the sbp-pg protection group.
# /usr/cluster/lib/geo/lib/scgeo_protectiongroup_get -G sbp-pg -p create_config_script /var/tmp/create.sh
The following exit values are returned:
The command completed successfully.
A general usage error occurred.
An error occurred.
Failure error codes are described scha_calls(3HA).
See attributes(7) for descriptions of the following attributes: