|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- notify timezone update
The tzreload command notifies active (running) processes to reread timezone information. The timezone information is cached in each process, absent a tzreload command, is never reread until a process is restarted. In response to a tzreload command, active processes reread the current timezone information at the next call to ctime(3C) and mktime(3C). By default, the tzreload notification is sent to the processes within the current zone.
In addition to notifying active processes, the tzreload command also notifies cron(1M), to reinitialize the job scheduler with the new timezone information.
The following options are supported:
Notify processes in all zones.
Standard zone information directory.
See attributes(5) for descriptions of the following attributes:
rpc.cmsd(1M), part of the CDE man page set.
Although tzreload reinitializes cron(1M), applications that are affected by timezone changes still need to be restarted or reinitialized if they do not reread the new timezone information before timezone changes take place.