|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- report WCI RSM driver statistics
/usr/platform/sun4u/sbin/wrsmstat controller [-c controller_id]
wrsmstat wrsm [-i wrsm_instance_num] [-v]
wrsmstat route [-c controller_id] [-h node_hostname]
wrsmstat set [-i wrsm_instance_num] -c cmmu -s start -e end
The wrsmstat command provides statistics on remote shared memory (RSM) controllers, routes to nodes, and WCI interfaces managed by the WCI RSM driver (wrsm). It also provides an interface for setting extended performance counter control registers that constrain the wrsm counters available through busstat(1M).
The following options are supported:
Displays information describing the state of the specified controller, or of all controllers if none is specified. The following is sample output:
$ wrsmstat controller -c 5 Controller 5 ------------ Controller state: up Local RSM Hardware address: 0x4 Exported segments: 0 # published: 0 # connections: 0 total bound memory: 0 Imported segments: 0 Send Queues: 0 Registered Handlers: 0 Assigned WCIs: 4 Available WCIs: 2
Displays information describing the state of the specified RSM WCI, or of all RSM WCIs if none is specified. The following is sample output:
$ wrsmstat wrsm -i 2 WCI instance 2 -------------- Portid: 5 Controller ID: 0 Config Version: 5 Link Error Shutdown Trigger: 40000 Link #0 is not present. Link #1 Link Enabled: yes Link State: up Remote RSM HW addr: 1 Remote wnode ID: 1 Remote link num: 1 Remote WCI port ID: 3 Error takedowns: 0 Bad Config takedowns: 0 Failed bringups: 0 Total link errors: 0 Maximum link errors: 0 Average link errors: 0 Auto shutdown enabled: yes Link #2 is not present.
If you specify the -v option, the following additional information is displayed:
Cluster Error Count: 0 Uncorrectable SRAM ECC error: no Maximum SRAM ECC errors: 0 Average SRAM ECC errors: 0
Displays the route to the specified node through the specified controller. If no node is specified, displays the routes to all nodes. If no controller is specified, displays the specified node's route through all controllers. If neither is specified, displays the routes to all nodes through all controllers. The following is sample output:
$ wrsmstat -c 3 -h fred Controller 3 - Route to fred ---------------------------- Config Version: 1 FM node id: 0x345543 RSM hardware address: 0x9 Route Changes: 3 Route Type: Passthrough Number of WCIs: 2 Stripes: 4 WCI #0 Port ID: 3 Instance: 0 Num of hops: 2 Num of links: 2 link# 1, first hop RSM HW addr: 0x4 link# 2, first hop RSM HW addr: 0x2 WCI #1 Port ID: 13 Instance: 1 Num of hops: 2 Num of links: 2 link# 0, first hop RSM HW addr: 0x4 link# 2, first hop RSM HW addr: 0x2
For the specified WCI (or for each RSM WCI if none specified), configure the specified range of CMMU entries so that transactions through them are counted by wrsm busstat kstats. Each call will cause transactions to be counted through the new ranges of cmmu entries in addition to the previously specified ranges. To count transactions through all CMMUs, specify a start value of 0 and end value of 0. To clear all ranges (and not count transactions through any cmmu entries), specify a start value of 0 and end value of -1.
This command returns 0 on successful completion, and a non-zero value if an error occurred.
See attributes(5) for descriptions of the following attributes: