Go to main content

man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: July 2017
 
 

sofop_notify(9E)

Name

sofop_notify - notification entry point

Synopsis

#include <sys/sockfilter.h>

void prefix_notify(sof_handle_t hdl, void *cookie,
     sof_event_t event, uintptr_t event_data);

Parameters

hdl

per-socket filter handle

cookie

per-socket filter-private data

event

socket event. The following events are possible:

SOF_EV_CLOSING

Socket is closing.

SOF_EV_CONNECT_DONE

A connect operation has finished, and event_data, treated as an uint32_t, indicates the result:

0

Connect operation was successful.

>0

An error, as described in Intro(2), occurred.

SOF_EV_SHUTDOWN

An event has occurred that has impacted the socket's ability to receive and/or send data. event_data, treated as an uint32_t, describes what has been shut down:

SHUT_RD

The receive side has shut down.

SHUT_WR

The send side has shut down.

SHUT_RDWRSHUT_RDWR

The receive and send sides have shut down.

SOF_EV_FLOWCTRL_CLR

Flow control has been cleared. event_data, treated as an int32_t, indicate the direction:

SOF_FLOWCTRL_DATA_IN

Receive side.

SOF_FLOWCTRL_DATA_OUT

Send side.

event_data

event specific information

Description

The sofop_notify() entry point is called in response to state changes for the socket. Notifications are purely informational and cannot be modified by the filter.

Context

The sofop_notify() entry point can be called from interrupt context, except when event is SOF_EV_CLOSING, in which case sofop_notify() is guaranteed to be called from kernel or user context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/kernel
Interface Stability
Uncommitted

See Also

Intro(2), attributes(5), sof_ops(9S)