Go to main content

man pages section 9: DDI and DKI Driver Entry Points

Exit Print View

Updated: July 2017
 
 

tran_quiesce(9E)

Name

tran_quiesce, tran_unquiesce - quiesce and unquiesce a SCSI bus

Synopsis

#include <sys/scsi/scsi.h>

int prefixtran_quiesce(dev_info_t *hba_dip);
int prefixtran_unquiesce(dev_info_t *hba_dip);

Interface Level

Solaris DDI

Parameters

hba_dip

The dev_info_t pointer associated with the SCSI HBA.

Description

The tran_quiesce() and tran_unquiesce() vectors in the scsi_hba_tran(9S) structure should be initialized during the HBA driver's attach(9E). They are HBA entry points to be called when a user initiates quiesce and unquiesce operations through device control interfaces.

tran_quiesce() should wait for all outstanding commands to complete and blocks (or queues) any I/O requests issued. tran_unquiesce() should allow I/O activities to resume on the SCSI bus.

Implementation is hardware specific.

Return Values

tran_quiesce() and tran_unquiesce() should return:

0

Successful completion.

Non-zero

An error occurred.

Attributes

See attributes(5) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(5), tran_bus_reset(9E), scsi_hba_tran(9S)