|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- start the Sun WBEM CIM WorkShop application
The cimworkshop command starts Sun WBEM CIM WorkShop, a graphical user interface that enables you to create, modify, and view the classes and instances that describe the managed resources on your system.
Managed resources are described using a standard information model called Common Information Model (CIM). A CIM class is a computer representation, or model, of a type of managed resource, such as a printer, disk drive, or CPU. A CIM instance is a particular managed resource that belongs to a particular class. Instances contain actual data. Objects can be shared by any WBEM-enabled system, device, or application. CIM objects are grouped into meaningful collections called schema. One or more schemas can be stored in directory-like structures called namespaces.
The CIM WorkShop application displays a Login dialog box. Context help is displayed on the left side of the CIM WorkShop dialog boxes. When you click on a field, the help content changes to describe the selected field.
By default, CIM WorkShop uses the RMI protocol to connect to the CIM Object Manager on the local host, in the default namespace, root\cimv2. You can select HTTP if you want to communicate to a CIM Object Manager using the standard XML/HTTP protocol from the Desktop Management Task Force. When a connection is established, all classes contained in the default namespace are displayed in the left side of the CIM WorkShop window.
The name of the current namespace is listed in the tool bar. All programming operations are performed within a namespace. Four namespaces are created in a root namespace during installation:
Contains the default CIM classes that represent managed resources on your system.
Contains the security classes used by the CIM Object Manager to represent access rights for users and namespaces.
Contains properties for configuring the CIM Object Manager.
Contains pre-defined SNMP-related classes and all SNMP MOF files that are compiled.
The cimworkshop application allows you to perform the following tasks:
Use the CIM WorkShop application to view all namespaces. A namespace is a directory-like structure that can store CIM classes and instances.
You cannot modify the unique attributes of the classes that make up the CIM and Solaris Schema. You can create a new instance or subclass of the class and modify the desired attributes in that instance or subclass.
You can add instances to a class and modify its inherited properties or create new properties. You can also change the property values of a CIM instance.
You can set input values for a parameter of a method and invoke the method.
When CIM WorkShop connects to the CIM Object Manager in a particular namespace, all subsequent operations occur within that namespace. When you connect to a namespace, you can access the classes and instances in that namespace (if they exist) and in any namespaces contained in that namespace.
When you use CIM WorkShop to view CIM data, the WBEM system validates your login information on the current host. By default, a validated WBEM user is granted read access to the CIM Schema. The CIM Schema describes managed objects on your system in a standard format that all WBEM-enabled systems and applications can interpret.
Allows read-only access to CIM Schema objects. Users with this privilege can retrieve instances and classes, but cannot create, delete, or modify CIM objects.
Allows full read, write, and delete access to all CIM classes and instances.
Allows write and delete, but not read access to all CIM classes and instances.
Allows no access to CIM classes and instances.
The cimworkshop command is not a tool for a distributed environment. Rather, this command is used for local administration on the machine on which the CIM Object Manager is running.
The cimworkshop utility terminates with exit status 0.
See attributes(5) for descriptions of the following attributes: