|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- add (create) a new group definition on the system
/usr/sbin/groupadd [-g gid [-o]] group
The groupadd command creates a new group definition on the system by adding the appropriate entry to the /etc/group file.
The following options are supported:
Assigns the group id gid for the new group. This group id must be a non-negative decimal integer below MAXUID as defined in /usr/include/sys/param.h. The group ID defaults to the next available (unique) number above the highest number currently assigned. For example, if groups 100, 105, and 200 are assigned as groups, the next default group number is 201. (Group IDs from 0-99 are reserved by SunOS for future applications.)
Allows the gid to be duplicated (non-unique).
The following operands are supported:
A string consisting of characters from the set of lower case alphabetic characters and numeric characters. A warning message is written if the string exceeds MAXGLEN-1, which is usually eight characters. The group field must contain at least one character; it accepts lower case or numeric characters or a combination of both, and must not contain a colon (:) or NEWLINE.
The following exit values are returned:
Invalid command syntax. A usage message for the groupadd command is displayed.
An invalid argument was provided to an option.
The gid is not unique (when -o option is not used).
The group is not unique.
The /etc/group file cannot be updated.
See attributes(5) for descriptions of the following attributes:
groupadd only adds a group definition to the local system. If a network name service such as NIS or NIS+ is being used to supplement the local /etc/group file with additional entries, groupadd cannot change information supplied by the network name service. However, groupadd verifies the uniqueness of group name and group ID against the external name service.