|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- prints and updates customer data associated with FRUs
/usr/platform/sun4u/sbin/fruadm [-r] path [text]
fruadm prints or sets the customer data for Field-Replaceable Units (FRUs).
Without arguments, fruadm prints the paths of all FRU ID-capable FRUs (containers) in the system, along with the contents of the customer data record, if present, for each such FRU; for FRUs without customer data, fruadm prints only the container's path.
Only a privileged user can create or update data in containers. The privileges required to perform these write operations are hardware dependent. Typically, a default system configuration restricts write operations to the superuser or to the platform-administrator user.
The following options are supported:
List the system's frutree paths.
Recursively display or update the data for all containers rooted at the argument path.
The following operands are supported:
A full or partial system frutree path for or under which to print or set the customer data. The first field of each line of output of fruadm -l gives the valid full frutree paths for the system.
Paths can include shell meta-characters; such paths should be quoted appropriately for the user's shell. For partial paths, the first matching full path is selected for display or update. Without the -r option, the path must be that of a container; with the -r option, all containers (if any) under path will be selected.
Up to 80 characters of text set as the customer data. If the text contains white space or shell metacharacters, it should be quoted appropriately for the user's shell.
Example 1 Displaying All Customer Data
The following example prints all customer data available from FRUs on the system. For containers with no customer data, only the containers' paths will be listed.
Example 2 Displaying Customer Data For a Single FRU
The following command prints the customer data, if present, for the specified FRU:
example% fruadm /frutree/chassis/system-board
Example 3 Displaying Customer Data For a Single FRU
The following command prints the customer data, if present, for the first mem-module found:
example% fruadm mem-module
Example 4 Setting Customer Data
The following example sets the customer data for a FRU:
example# fruadm system-board 'Asset Tag 123456'
Example 5 Setting Customer Data
The following command sets the customer data for all FRUs under chassis:
example# fruadm -r /frutree/chassis "Property of XYZ, Inc."
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes: