|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- activate a boot environment
/usr/sbin/luactivate [-l error_log] [-o outfile] [-s] [BE_name] [-X]
The luactivate command is part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The luactivate command, with no arguments, displays the name of the boot environment (BE) that will be active upon the next reboot of the system. When an argument (a BE) is specified, luactivate activates the specified BE.
luactivate activates a BE by making the BE's root partition bootable. On an x86 machine, this might require that you take steps following the completion of luactivate. If so, luactivate displays the correct steps to take.
To successfully activate a BE, that BE must meet the following conditions:
The BE must have a status of “complete,” as reported by lustatus(1M).
The BE you want to activate cannot be involved in an lucompare(1M) operation.
After activating a specified BE, luactivate displays the steps to be taken for fallback in case of any problem on the next reboot. Make note of these instructions and follow them exactly, if necessary.
Note - Before booting a new BE, you must run luactivate to specify that BE as active. luactivate performs a number of tasks, described below, that ensure correct operation of the BE. In some cases, a BE is not bootable until after you have run the command.
The luactivate command performs the following tasks:
The first time you boot from a newly created BE, Live Upgrade software synchronizes this BE with the BE that was last active. (This is not necessarily the BE that was the source for the newly created BE.) Synchronize here means that certain system files and directories are copied from the last-active BE to the BE being booted. (See synclist(4).) Live Upgrade software does not perform this synchronization after a BE's initial boot, unless you use the -s option, described below.
If luactivate detects conflicts between files that are subject to synchronization, it issues a warning and does not perform the synchronization for those files. Activation can complete successfully, in spite of such a conflict. A conflict can occur if you upgrade one BE or another to a new operating system version or if you modify system files (for example, /etc/passwd) on one of the BEs.
luactivate checks to see whether upgrade problems occurred. For example, packages required for the correct operation of the operating system might be missing. This package check is done for the global zone as well as all non-global zones inside of the BE. The command can issue a warning or, if a BE is incomplete, can refuse activation.
luactivate determines whether the bootstrap program requires updating and takes steps to update if necessary. If a bootstrap program changed from on operating release to another, an incorrect bootstrap program might render an upgraded BE unbootable. See installboot(1M).
luactivate modifies the root partition ID on a Solaris x86 disk to enable multiple BEs to reside on a single disk. In this configuration, if you do not run luactivate, booting of the BE will fail. See fmthard(1M) and dkio(7I).
The luactivate command requires root or equivalent privileges.
The luactivate command has the following options:
Error and status messages are sent to error_log, in addition to where they are sent in your current environment.
All command output is sent to outfile, in addition to where it is sent in your current environment.
Causes synchronization to occur (see DESCRIPTION) even if next boot of a specified BE is not the first boot of that BE. Use this option with great caution, because you might not be aware or in control of changes that might have occurred in the last-active BE.
If using -s, take special care when booting to an earlier release of Solaris than what is installed on the last-active BE. For example, consider that the last-active BE contains Solaris 9 and you want to activate a BE that contains Solaris 2.6. If you forced synchronization with the -s option, the BE containing Solaris 2.6 might be synchronized with files that, while compatible with Solaris 9, might not work under Solaris 2.6.
Enable XML output. Characteristics of XML are defined in DTD, in /usr/share/lib/xml/dtd/lu_cli.dtd.<num>, where <num> is the version number of the DTD file.
Name of the BE to be activated.
The following exit values are returned:
An error occurred.
list of BEs on the system
Live Upgrade DTD (see -X option)
See attributes(5) for descriptions of the following attributes:
lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludelete(1M), ludesc(1M), lufslist(1M), lumake(1M), lumount(1M), lurename(1M), lustatus(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5), zones(5)
After entering init 6, if an activated BE fails to boot, consult /var/svc/log/rc6.log on the current BE for possible obstacles.