|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- delete a boot environment
/usr/sbin/ludelete [-l error_log] [-o outfile] BE_name [-X]
The ludelete command is part of a suite of commands that make up the Live Upgrade feature of the Solaris operating environment. See live_upgrade(5) for a description of the Live Upgrade feature.
The ludelete command deletes all records associated with a boot environment (BE) on all defined complete BEs. A complete BE is one that is not participating in an lucreate(1M), luupgrade(1M), or lucompare(1M) operation. Use lustatus(1M) to determine a BE's status. You can delete neither the current BE, nor the BE that will become current upon the next reboot.
ludelete does not alter any files on the BE being deleted.
The ludelete command requires root privileges.
The ludelete command has the following options:
Error and status messages are sent to error_log, in addition to where they are sent in your current environment.
All command output is sent to outfile, in addition to where it is sent in your current environment.
Enable XML output. Characteristics of XML are defined in DTD, in /usr/share/lib/xml/dtd/lu_cli.dtd.<num>, where <num> is the version number of the DTD file.
Name of the BE to be deleted.
The following exit values are returned:
An error occurred.
list of BEs on the system
Live Upgrade DTD (see -X option)
See attributes(5) for descriptions of the following attributes:
lu(1M), luactivate(1M), lucancel(1M), lucompare(1M), lucreate(1M), lucurr(1M), ludesc(1M), lufslist(1M), lumake(1M), lumount(1M), lurename(1M), lustatus(1M), luupgrade(1M), lutab(4), attributes(5), live_upgrade(5)