|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- Platform-dependent beep driver for SMBus-based hardware
The grbeep driver generates beeps on platforms (including Sun Blade 100, 150, 1500, 2500) that use SMBbus-based registers and USB keyboards. When the KIOCCMD ioctl is issued to the USB keyboard module (see usbkbm(7M)) with command KBD_CMD_BELL/KBD_CMD_NOBELL, usbkbm(7M) passes the request to the grbeep driver to turn the beep on and off, respectively.
64–bit ELF kernel driver
See attributes(5) for descriptions of the following attributes:
Writing Device Drivers