|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- High Sierra & ISO 9660 CD-ROM file system
HSFS is a file system type that allows users access to files on High Sierra or ISO 9660 format CD-ROM disks from within the SunOS operating system. Once mounted, a HSFS file system provides standard SunOS read-only file system operations and semantics. That is, users can read files and list files in a directory on a High Sierra or ISO 9660 CD-ROM, and applications can use standard UNIX system calls on these files and directories.
This file system also contains support for the Rock Ridge Extensions. If the extensions are contained on the CD-ROM, then the file system will provide all of the file system semantics and file types of UFS, except for writability and hard links.
If your /etc/vfstab file contains a line similar to
/dev/dsk/c0t6d0s0 -/hsfs hsfs -no ro
and /hsfs exists, you can mount an HSFS file system with either of the following commands:
mount -F hsfs -o ro device-special directory-name
Normally, if Rock Ridge extensions exist on the CD-ROM, the file system will automatically use those extensions. If you do not want to use the Rock Ridge extensions, use the ``nrr'' (No Rock Ridge) mount option. The mount command would then be:
mount -F hsfs -o ro,nrr device-special directory-name
Files on a High Sierra or ISO 9660 CD-ROM disk have names of the form filename.ext;version, where filename and the optional ext consist of a sequence of uppercase alphanumeric characters (including ``_''), while the version consists of a sequence of digits, representing the version number of the file. HSFS converts all the uppercase characters in a file name to lowercase, and truncates the ``;'' and version information. If more than one version of a file is present on the CD-ROM, only the file with the highest version number is accessible.
If the CD-ROM contains Rock Ridge extensions, the file names and directory names may contain any character supported under UFS. The names may also be upper and/or lower case and will be case sensitive. File name lengths can be as long as those of UFS.
Files accessed through HSFS have mode 555 (owner, group and world readable and executable), uid 0 and gid 3. If a directory on the CD-ROM has read permission, HSFS grants execute permission to the directory, allowing it to be searched.
With Rock Ridge extensions, files and directories can have any permissions that are supported on a UFS file system; however, despite any write permissions, the file system is read-only, with EROFS returned to any write operations.
High Sierra and ISO 9660 CD-ROMs support only regular files and directories, thus HSFS supports only these file types. A Rock Ridge CD-ROM can support regular files, directories, and symbolic links, as well as device nodes, such as block, character, and FIFO.
Example 1 Sample Display of File System Files
If there is a file BIG.BAR on a High Sierra or ISO 9660 format CD-ROM it will show up as big.bar when listed on a HSFS file system.
If there are three files
on a High Sierra or ISO 9660 format CD-ROM, only the file BAR.BAZ;3 will be accessible. It will be listed as bar.baz.
N. V. Phillips and Sony Corporation, System Description Compact Disc Digital Audio, ("Red Book").
N. V. Phillips and Sony Corporation, System Description of Compact Disc Read Only Memory, ("Yellow Book").
IR "Volume and File Structure of CD-ROM for Information Interchange", ISO 9660:1988(E).
The specific reason appears on the following line. You might be attempting to mount a CD-ROM containing a different file system, such as UFS.
The hsfs file system does not support the format of some file or directory on the CD-ROM, for example a record structured file.
There are not enough HSFS internal data structure elements to handle all the files currently open. This problem may be overcome by adding a line of the form set hsfs:nhsnode=number to the /etc/system system configuration file and rebooting. See system(4).
Do not physically eject a CD-ROM while the device is still mounted as a HSFS file system.
Under MS-DOS (for which CD-ROMs are frequently targeted), files with no extension may be represented either as
that is, with or without a trailing period. These names are not equivalent under UNIX systems. For example, the names
are not names for the same file under the UNIX system. This may cause confusion if you are consulting documentation for CD-ROMs originally intended for MS-DOS systems.
No translation of any sort is done on the contents of High Sierra or ISO 9660 format CD-ROMs; only directory and file names are subject to interpretation by HSFS.