|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- Solaris InfiniBand Transport Layer
InfiniBand (IB) is an I/O technology based on switched fabrics. The Solaris InfiniBand Transport Layer (IBTL) is a Solaris kernel misc module and adheres to the IB Architecture Version 1.1 specification and provides a transport layer abstraction to IB client drivers.
IBTL implements the programming interfaces for the Solaris InfiniBand Transport Framework (IBTF), consisting of the IB Channel Interface (CI) and the IB Transport Interface (TI).
The CI consists of Host Channel Adapters (HCAs) and HCA drivers. A host is attached to the IB fabric through the CI layer. The Solaris InfiniBand CI is Sun's API rendering of the InfiniBand Architecture (IBTA) "verbs" specification.
The Solaris InfiniBand TI is the kernel service driver interface into the Solaris InfiniBand Transport Framework. It provides transport and communications setup programming interfaces for Unreliable Datagram (UD) and Reliable Connected (RC) transport types only.
32-bit x86 ELF kernel misc module
64-bit x86 ELF kernel misc module
64-bit SPARC ELF kernel module
See attributes(5) for a description of the following attribute:
InfiniBand Architecture Specification, Volume 1: Release 1.1