|Skip Navigation Links|
|Exit Print View|
|man pages section 7: Device and Network Interfaces Oracle Solaris 10 8/11 Information Library|
- DTrace Linux system call tracing provider
The lx_systrace driver implements the DTrace lxsyscall dynamic tracing provider. The lxsyscall provider performs dynamic instrumentation to offer probes that fire whenever a thread enters or returns from a Linux system call entry point.
The lx_systrace driver is not a public interface and you access the instrumentation offered by this provider through DTrace. Refer to the Solaris Dynamic Tracing Guide for a description of the public documented interfaces available for the DTrace facility and the probes offered by the lxsyscall provider.
See attributes(5) for a description of the following attributes:
Solaris Dynamic Tracing Guide