|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- mount hsfs file systems
mount -F hsfs [generic_options] [-o FSType-specific_options] [-O ] special | mount_point
mount -F hsfs [generic_options] [-o FSType-specific_options] [-O] special mount_point
mount attaches a High Sierra file system (hsfs) to the file system hierarchy at the mount_point, which is the pathname of a directory. If mount_point has any contents prior to the mount operation, these are hidden until the file system is unmounted.
If mount is invoked with special or mount_point as the only arguments, mount will search /etc/vfstab to fill in the missing arguments, including the FSType-specific_options; see mount(1M) for more details.
If the file system being mounted contains Rock Ridge extensions, by default they will be used, enabling support of features not normally available under High Sierra file systems such as symbolic links, and special files.
See mount(1M) for the list of supported options.
Specify hsfs file system specific options. If invalid options are specified, a warning message is printed and the invalid options are ignored. The following options are available:
If global is specified and supported on the file system, and the system in question is part of a cluster, the file system will be globally visible on all nodes of the cluster. If noglobal is specified, the mount will not be globally visible. The default behavior is noglobal.
Mount the file system read-only. This option is required.
no Rock Ridge: if Rock Ridge extensions are present in the file system, ignore them; interpret it as a regular High Sierra file system.
File names on High Sierra file systems consist of a proper name and an extension separated by a '.' (dot) character. By default, the separating dot is always considered part of the file's name for all file access operations, even if there is no extension present. Specifying notraildot makes it optional to specify the trailing dot to access a file whose name lacks an extension.
Exceptions: This option is effective only on file systems for which Rock Ridge extensions are not active, either because they are not present on the CD-ROM, or they are explicitly ignored via the nrr option. If Rock Ridge extensions are active, hsfs quietly ignores this option.
File names on High Sierra cdroms with no Rock Ridge extensions present should be uppercase characters only. By default, hsfs maps file names read from a non-Rock Ridge disk to all lowercase characters. nomaplcase turns off this mapping. The exceptions for notraildot discused above apply to nomaplcase.
Overlay mount. Allow the file system to be mounted over an existing mount point, making the underlying file system inaccessible. If a mount is attempted on a pre-existing mount point without setting this flag, the mount will fail, producing the error device busy.
table of mounted file systems
list of default parameters for each file system
See attributes(5) for descriptions of the following attributes:
If the directory on which a file system is to be mounted is a symbolic link, the file system is mounted on the directory to which the symbolic link refers, rather than on top of the symbolic link itself.