|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- NFS statistics
nfsstat [-cnrsza] [-v version] [interval [count]]
nfsstat -m [pathname]...
nfsstat displays statistical information about the NFS and RPC (Remote Procedure Call), interfaces to the kernel. It can also be used to reinitialize this information. If no options are given the default is as follows:
The default displays everything, but reinitializes nothing.
Display NFS_ACL information.
Display client information. Only the client side NFS, RPC, and NFS_ACL information is printed. Can be combined with the -n, -r, and -a options to print client side NFS, RPC, and NFS_ACL information only.
Display statistics for each NFS mounted file system. If pathname is not specified, displays statistics for all NFS mounted file systems. If pathname is specified, displays statistics for the NFS mounted file systems indicated by pathname.
This includes the server name and address, mount flags, current read and write sizes, the retransmission count, the attribute cache timeout values, failover information, and the timers used for dynamic retransmission. The dynamic retransmission timers are displayed only where dynamic retransmission is in use. By default, NFS mounts over the TCP protocols and NFS Version 3 mounts over either TCP or UDP do not use dynamic retransmission.
If you specify the -m option, this is the only option that nfsstat uses. If you specify other options with -m, you receive an error message alerting that the -m flag cannot be combined with other options.
Display NFS information. NFS information for both the client and server side are printed. Can be combined with the -c and -s options to print client or server NFS information only.
Display RPC information.
Display server information.
Specify which NFS version for which to print statistics. When followed by the optional version argument, (2|3|4), specifies statistics for that version. By default, prints statistics for all versions.
Zero (reinitialize) statistics. This option is for use by the super user only, and can be combined with any of the above options to zero particular sets of statistics after printing them.
The following operands are supported:
Display only count reports
Report once each interval seconds.
Specify the pathname of a file in an NFS mounted file system for which statistics are to be displayed.
The server RPC display includes the following fields:
The total number of RPC calls received.
The total number of calls rejected by the RPC layer (the sum of badlen and xdrcall as defined below).
The number of times an RPC call was not available when it was thought to be received.
The number of RPC calls with a length shorter than a minimum-sized RPC call.
The number of RPC calls whose header could not be XDR decoded.
The number of RPC calls that looked up in the duplicate request cache.
The number of RPC calls that were found to be duplicates.
The server NFS display shows the number of NFS calls received (calls) and rejected (badcalls), and the counts and percentages for the various calls that were made.
The server NFS_ACL display shows the counts and percentages for the various calls that were made.
The client RPC display includes the following fields:
The total number of RPC calls made.
The total number of calls rejected by the RPC layer.
The number of times a reply from a server was received which did not correspond to any outstanding call.
The number of times a call timed out while waiting for a reply from the server.
The number of times authentication information had to be refreshed.
The number of times the call failed due to a bad verifier in the response.
The number of times the calculated time-out value was greater than or equal to the minimum specified time-out value for a call.
The number of times the call failed due to a failure to make a connection to the server.
The number of times the call failed due to a failure to allocate memory.
The number of times the call was interrupted by a signal before completing.
The number of times a call had to be retransmitted due to a timeout while waiting for a reply from the server. Applicable only to RPC over connection-less transports.
The number of times a client was unable to send an RPC request over a connectionless transport when it tried to do so.
The client NFS display shows the number of calls sent and rejected, as well as the number of times a CLIENT handle was received (clgets), the number of times the CLIENT handle cache had no unused entries (cltoomany), as well as a count of the various calls and their respective percentages.
The client NFS_ACL display shows the counts and percentages for the various calls that were made.
The -m option includes information about mount flags set by mount options, mount flags internal to the system, and other mount information. See mount_nfs(1M).
The following mount flags are set by mount options:
sec has one of the following values:
UNIX-style authentication (UID, GID).
Short hand UNIX–style authentication.
des–style authentication (encrypted timestamps).
kerberos v5–style authentication.
kerberos v5–style authentication with integrity.
kerberos v5–style authentication with privacy.
Interrupts allowed on hard mount.
No interrupts allowed on hard mount.
Client is not caching attributes.
Read buffer size in bytes.
Write buffer size in bytes.
Initial NFS timeout, in tenths of a second.
No close-to-open consistency.
Local locking being used (no lock manager).
System V group id inheritance.
RPC time sync.
The following mount flags are internal to the system:
"Not responding" message printed.
Server is down.
Dynamic transfer size adjustment.
Server supports links.
Server supports symbolic links.
Use readdir instead of readdirplus.
Server supports NFS_ACL.
The following flags relate to additional mount information:
The -m option also provides attribute cache timeout values. The following fields in -m ouput provide timeout values for attribute cache:
Minimum seconds to hold cached file attributes.
Maximum seconds to hold cached file attributes.
Minimum seconds to hold cached directory attributes.
Maximum seconds to hold cached directory attributes.
The following fields in -m output provide failover information:
How many times servers have failed to respond.
How many times a new server has been selected.
How many times files have been re-evaluated to the new server.
Which server is currently providing NFS service. See the System Administration Guide: IP Services for additional details.
The fields in -m output shown below provide information on dynamic retransmissions. These items are displayed only where dynamic retransmission is in use.
The value for the smoothed round-trip time, in milliseconds.
Estimated deviation, in milliseconds.
Current backed-off retransmission value, in milliseconds.
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes: