|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- communicate with a network entity using SNMP SET requests
snmpset [common options] oid type value [oid type value]...
The snmpset utility is an SNMP application that uses the SNMP SET request to set information on a network entity. A type and a value must accompany each object identifier. Each variable name must be entered in the format specified in snmp_variables(4).
The type is a single character, one of:
i INTEGER u UNSIGNED c COUNTER32 s STRING x HEX STRING d DECIMAL STRING n NULLOBJ o OBJID t TIMETICKS a IPADDRESS b BITS
If you have the proper MIB file loaded, you can, in most cases, replace the type with an equal sign (=). For an object of type OCTET STRING this assumes a string such as the "s"-type notation. For other types, snmpset interprets the data in the way you would expect.
For example, the command:
snmpset -c private -v 1 test-hub system.sysContact.0 s firstname.lastname@example.org ip.ipforwarding.0 = 2
sets the variables sysContact.0 and ipForwarding.0, as follows:
system.sysContact.0 = STRING: "email@example.com" ip.ipForwarding.0 = INTEGER: not-forwarding(2)
If the network entity has an error processing the request packet, an error packet is returned and a message displayed, indicating the way in which the request was malformed.
snmpset takes the common options described in the snmpcmd(1M) manual page.
See attributes(5) for descriptions of the following attributes:
A usage syntax error. A usage message is displayed. Also used for timeout errors.
An error occurred while executing the command. An error message is displayed.