|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- communicate with a network entity using SNMP GET requests
/usr/sfw/bin/snmpget [common options] [-Cf] oid [oid]...
The snmpget utility is an SNMP application that uses the SNMP GET request to query for information on a network entity. You can specify one or more object identifiers (OIDs) as arguments on the command line. Each variable name must be specified in the format specified in snmp_variables(4) .
For example, the command:
# snmpget -c public zeus system.sysDescr.0
retrieves the variable system.sysDescr.0:
system.sysDescr.0 = "SunOS zeus.net.cmu.edu 4.1.3_U1 1 sun4m"
If the network entity has an error processing the request packet, an error packet is returned and a message displayed. The message indicates the way in which the request was malformed. If there were other variables in the request that were correctly formed, the request will be resent without the bad variable.
The following option is supported:
If -Cf is not specified, some applications (including snmpgetnext(1M) and snmpget) attempt to fix errors returned by the agent that you were talking to and resend the request. The -Cf option suppresses this fix-and-resend feature.
Fix-and-resend is useful if you specified a nonexistent OID in your request and you are using SNMPv1, which requires "all or nothing" types of requests. In the following example note that system.sysUpTime is an incomplete OID, because it requires the .0 index appended to it:
# snmpget -v1 -Cf -c public localhost system.sysUpTime \ system.sysContact.0 Error in packet Reason: (noSuchName) There is no such variable name in this MIB. This name doesn't exist: system.sysUpTime # snmpget -v1 -c public localhost system.sysUpTime system.sysContact.0 Error in packet Reason: (noSuchName) There is no such variable name in this MIB. This name doesn't exist: system.sysUpTime system.sysContact.0 = STRING: root@localhost
In addition to this option, snmpwalk takes the common options described in the snmpcmd(1M) manual page.
A usage syntax error. A usage message is displayed. Also used for timeout errors.
An error occurred while executing the command. An error message is displayed.
See attributes(5) for descriptions of the following attributes: