|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- Service Location Protocol Daemon
/usr/lib/inet/slpd [-f configuration-file]
The slpd daemon provides common server functionality for the Service Location Protocol (“SLP”) versions 1 and 2, as defined by IETF in RFC 2165 and RFC 2608. SLP provides a scalable framework for the discovery and selection of network services.
slpd provides the following framework services:
This service automatically caches service advertisements from service agents to provide them to user agents, and makes directory agent advertisements of its services. This service is optional. slpd does not provide directory agent service by default. Directory agents are not databases, and they do not need to be maintained.
All service agents on the local host register and deregister with this server. This service responds to all requests for services, and forwards registrations to directory agents. By default, slpd is a service agent server.
This service listens for directory agent advertisements and maintains a table of active directory agents. When a user agent wishes to discover a directory agent, it can simply query slpd, obviating the need to perform discovery by means of multicast. By default, slpd performs this service.
This service can act as a proxy service agent for services that cannot register themselves. slpd reads the proxy registration file for information on services it is to proxy. By default, no services are registered by proxy.
All configuration options are available from the configuration file. slpd reads its configuration file upon startup.
Stop and start the slpd daemon using svcadm(1M). Use the command svcadm enable network/slp to start the slpd daemon. Use the command svcadm disable network/slp to stop it.
The file /etc/inet/slp.conf must exist before the slp service can start the daemon. Only the example file /etc/inet/slp.conf.example is present by default. To enable SLP, copy /etc/inet/slp.conf.example to /etc/inet/slp.conf.
The following options are supported:
Specify an alternate configuration file
Example 1 Stopping the slpd daemon
The following command stops the slpd daemon:
example# svcadm disable network/slp
Example 2 Restarting the slpd daemon
The following command restarts the slpd daemon:
example# svcadm restart network/slp
The default configuration file
The proxy registration file
See attributes(5) for descriptions of the following attributes:
Guttman, E., Perkins, C., Veizades, J., and Day, M., RFC 2608, Service Location Protocol, Version 2, The Internet Society, June 1999.
The slpd service is managed by the service management facility, smf(5), under the service identifier: