|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- show network status using SNMP
/usr/sfw/bin/snmpnetstat [common options] [-a] [-n] agent
/usr/sfw/sma_snmp/bin/snmpnetstat [common options] [-iorns] agent
/usr/sfw/sma_snmp/bin/snmpnetstat [common options] [-in] [-I interface] agent [interval]
/usr/sfw/sma_snmp/bin/snmpnetstat [common options] [-an] [-s] [-P protocol] agent
The snmpnetstat command symbolically displays the values of various network-related information retrieved from a remote system using the SNMP protocol. There are a number of output formats, depending on the options for the information presented. Referring to the SYNOPSIS, above:
The first form of the command displays a list of active sockets.
The second form presents the values of other network-related information according to the option selected.
The third form, with an interval specified, continuously displays the information regarding packet traffic on the configured network interfaces.
The fourth form displays statistics about the named protocol.
The operand agent identifies a target SNMP agent that is instrumented to monitor the given objects. At its simplest, the agent specification consists of a host name or an IPv4 address. In this situation, the command attempts communication with the agent using UDP/IPv4 to port 161 of the target host. See snmpcmd(1M) for a full list of the possible formats for agent.
The version 1 and version 2c community specifies the community name for the transaction with the remote system.
The following options are supported:
See snmpcmd(1M) for a list of possible values for common options, as well as their descriptions.
With the default display, show the state of all sockets. Normally, sockets used by server processes are not shown.
Show the state of all of the network interfaces. The interface display provides a table of cumulative statistics regarding packets transferred, errors, and collisions. The network addresses of the interface and the maximum transmission unit (MTU) are also displayed.
Show an abbreviated interface status, giving octets in place of packets. This is useful when observing virtual interfaces (such as Frame Relay circuits) on a router.
Show information only about this interface; used with an interval as described below.
Show network addresses as numbers. (Normally, snmpnetstat interprets addresses and attempts to display them symbolically). This option can be used with any of the display formats.
Show statistics about protocol, which is either a well-known name for a protocol or an alias for it. Some protocol names and aliases are listed in the file /etc/protocols or in a naming service. A null response typically means that there are no interesting numbers to report. The program will complain if protocol is unknown or if there is no statistics routine for it.
Show per-protocol statistics. When used with the -r option, show routing statistics instead.
Show the routing tables. When -s is also present, show per-protocol routing statistics instead of the routing tables.
When snmpnetstat is invoked with an interval argument, it displays a running count of statistics related to network interfaces. interval is the number of seconds between reporting of statistics.
snmpnetstat supports the following types of display:
The default display, for active sockets, shows the local and remote addresses, protocol, and the internal state of the protocol. Address formats are of the form host.port or network.port if a socket's address specifies a network but no specific host address. When known, the host and network addresses are displayed symbolically according to /etc/hosts and /etc/networks, respectively. If a symbolic name for an address is unknown, or if the -n option is specified, the address is printed numerically, according to the address family. For more information regarding the Internet "dot format," refer to inet(3SOCKET). Unspecified, or wildcard, addresses and ports appear as "\(**".
The interface display provides a table of cumulative statistics regarding packets transferred, errors, and collisions. The network addresses of the interface and the maximum transmission unit (MTU) are also displayed.
The routing table display indicates the available routes and their status. Each route consists of a destination host or network and a gateway to use in forwarding packets. The flags field shows the state of the route (U if the route is up), whether the route is to a gateway (G), whether the route was created dynamically by a redirect (D), and whether the route has been modified by a redirect (M). Direct routes are created for each interface attached to the local host. The gateway field for such entries shows the address of the outgoing interface. The interface entry indicates the network interface used for the route.
When snmpnetstat is invoked with an interval argument, it displays a running count of statistics related to network interfaces. This display consists of a column for the primary interface and a column summarizing information for all interfaces. The primary interface can be replaced with another interface with the -I option. The first line of each screen of information contains a summary since the system was last rebooted. Subsequent lines of output show values accumulated over the preceding interval.
When a protocol is specified with the -P option, the information displayed is similar to that in the default display for active sockets, except the display is limited to the given protocol.
Note that figures snmpnetstat reports in the Ipkts column (part of the interface display) might differ from figures in the Ipkts column in netstat(1M). snmpnetstat displays a total of unicast, multicast, and broadcast packets. netstat omits broadcast packets from its total.
Example 1 Displaying Active Sockets
The following is an example of snmpnetstat's default display, which is to display active sockets.
% snmpnetstat -v 2c -c public -a testhost Active Internet (tcp) Connections (including servers) Proto Local Address Foreign Address (state) tcp *.echo *.* LISTEN tcp *.discard *.* LISTEN tcp *.daytime *.* LISTEN tcp *.chargen *.* LISTEN tcp *.ftp *.* LISTEN tcp *.telnet *.* LISTEN tcp *.smtp *.* LISTEN Active Internet (udp) Connections Proto Local Address udp *.echo udp *.discard udp *.daytime udp *.chargen udp *.time % snmpnetstat -v 2c -c public -i testhost Name Mtu Network Address Ipkts Ierrs Opkts Oerrs Queue eri0 1500 10.6.9/24 testhost 170548881 245601 687976 0 0 lo0 8232 127 localhost 7530982 0 7530982 0 0
Example 2 Displaying Statistics for a Specific Protocol
The following example shows how snmpnetstat displays statistics for a specific protocol.
% snmpnetstat -v 2c -c public -P tcp testhost Active Internet (tcp) Connections Proto Local Address Foreign Address (state) tcp *.echo *.* LISTEN tcp *.discard *.* LISTEN tcp *.daytime *.* LISTEN tcp *.chargen *.* LISTEN tcp *.ftp *.* LISTEN tcp *.telnet *.* LISTEN tcp *.smtp *.* LISTEN
A usage syntax error. A usage message is displayed.
See attributes(5) for descriptions of the following attributes: