|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- configure default linearity of 24-bit TrueColor Visual for OpenWindows
/usr/sbin/tcxconfig [linear | nonlinear]
The tcxconfig script changes the default linearity of a 24-bit TrueColor Visual for OpenWindows on a system with an S24 frame buffer. When the S24 graphics driver for OpenWindows is installed, the default 24-bit TrueColor Visual is nonlinear. You can run tcxconfig with an argument that specifies the setting you want.
OpenWindows should not be running when you execute the tcxconfig script with an option. Start OpenWindows after tcxconfig has set the linearity you desire.
If you specify no option, tcxconfig displays the current default setting.
You must become superuser before you can execute tcxconfig with one of the following options.
Set linear visual to be the default 24-bit TrueColor Visual. This means colors will be gamma-corrected.
Set nonlinear visual to be the default 24-bit TrueColor Visual.
The following exit values are returned:
an error has occurred.
See attributes(5) for descriptions of the following attributes: