|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 10 8/11 Information Library|
- accept or reject print requests
reject [-r reason] destination...
accept allows the queueing of print requests for the named destinations.
reject prevents queueing of print requests for the named destinations.
Use lpstat -a to check if destinations are accepting or rejecting print requests.
Generally, accept and reject are run on the print server to control local print queues. Under some configurations, accept and reject are run on client systems when IPP is being used to communicate between client and server.
The following options are supported for reject:
Assigns a reason for rejection of print requests for destination.
reason is reported by lpstat -a. By default, reason is unknown reason for existing destinations, and new printer for destinations added to the system but not yet accepting requests. Enclose reason in quotes if it contains blanks.
The following operands are supported:
The name of the destination accepting or rejecting print requests. Destination specifies the name of a printer or class of printers (see lpadmin(1M)). Specify destination using atomic name or URI-style (scheme://endpoint) names. See printers.conf(4) for information regarding the naming conventions for destinations.
The following exit values are returned:
An error occurred.
System printer configuration database
User-configurable printer database
LDAP version of /etc/printers.conf
NIS version of /etc/printers.conf
NIS+ version of /etc/printers.conf
See attributes(5) for descriptions of the following attributes:
accept and reject affect only queueing on the print server's spooling system. Requests made from a client system remain queued in the client system's queueing mechanism until they are cancelled or accepted by the print server's spooling system.
accept is CSI-enabled except for the destination name.
When IPP is in use, the user is prompted for a passphrase if the remote print service is configured to require authentication.