JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Properties and Data Structures     Oracle Solaris 11.1 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Data Structures for Drivers

aio_req(9S)

audio_engine_ops(9S)

blksize(9P)

buf(9S)

cb_ops(9S)

copyreq(9S)

copyresp(9S)

datab(9S)

dblk(9S)

ddi_device_acc_attr(9S)

ddi_dma_attr(9S)

ddi_dma_cookie(9S)

ddi_dmae_req(9S)

ddi_dma_lim(9S)

ddi_dma_lim_sparc(9S)

ddi_dma_lim_x86(9S)

ddi_dma_req(9S)

ddi_fm_error(9S)

ddi-forceattach(9P)

ddi_idevice_cookie(9S)

ddi-no-autodetach(9P)

ddi-no-modunload(9P)

device-blksize(9P)

device-nblocks(9P)

device-pblksize(9P)

devmap_callback_ctl(9S)

dev_ops(9S)

fmodsw(9S)

free_rtn(9S)

gld_mac_info(9S)

gld_stats(9S)

hook_nic_event(9S)

hook_pkt_event(9S)

hook_t(9S)

inquiry-device-type(9P)

inquiry-product-id(9P)

inquiry-revision-id(9P)

inquiry-serial-no(9P)

inquiry-vendor-id(9P)

iocblk(9S)

iovec(9S)

kstat(9S)

kstat_intr(9S)

kstat_io(9S)

kstat_named(9S)

linkblk(9S)

lso_basic_tcp_ipv4(9S)

mac_callbacks(9S)

mac_capab_lso(9S)

mac_capab_rings(9S)

mac_group_info(9S)

mac_register(9S)

mac_ring_info(9S)

mblk(9S)

modldrv(9S)

modlinkage(9S)

modlmisc(9S)

modlstrmod(9S)

module_info(9S)

msgb(9S)

Nblock(9P)

net_inject_t(9S)

net_instance_t(9S)

no-involuntary-power-cycles(9P)

pblksize(9P)

pm(9P)

pm-components(9P)

qband(9S)

qinit(9S)

queclass(9S)

queue(9S)

removable-media(9P)

scsi_address(9S)

scsi_arq_status(9S)

scsi_asc_key_strings(9S)

scsi_device(9S)

scsi_extended_sense(9S)

scsi_hba_tran(9S)

scsi_inquiry(9S)

scsi_pkt(9S)

scsi_status(9S)

size(9P)

sof_ops(9S)

streamtab(9S)

stroptions(9S)

tuple(9S)

uio(9S)

usb_bulk_request(9S)

usb_callback_flags(9S)

usb_cfg_descr(9S)

usb_client_dev_data(9S)

usb_completion_reason(9S)

usb_ctrl_request(9S)

usb_dev_descr(9S)

usb_dev_qlf_descr(9S)

usb_ep_descr(9S)

usb_if_descr(9S)

usb_intr_request(9S)

usb_isoc_request(9S)

usb_other_speed_cfg_descr(9S)

usb_request_attributes(9S)

usb_string_descr(9S)

mac_capab_rings

- rings capability data structure

Synopsis

#include <sys/mac_provider.h>

Interface Level

Solaris architecture specific (Solaris DDI)

Description

The mac_capab_rings structure is used by a network device driver to describe its rings capability. The structure is used as the argument to the mc_getcapab(9E) driver entry point when querying the MAC_CAPAB_RINGS capability.

Structure Members

mac_ring_type_t         mr_type;
mac_group_type_t        mr_group_type;
uint32_t                mr_flags;
mac_rings_version_t     mr_version;
uint_t                  mr_rnum;
uint_t                  mr_gnum;
mac_get_ring_t          mr_rget;
mac_get_group_t         mr_gget;
mac_group_add_ring_t    mr_gaddring;
mac_group_rem_ring_t    mr_gremring;

The following fields of the mac_capab_rings structure are set to indicate the device's rings capability:

mr_type

Set by MAC layer to indicate which driver resources is being queried. Possible ring types are MAC_RING_TYPE_RX or MAC_RING_TYPE_TX.

mr_group_type

Set by the driver to indicate whether the device is capable of static or dynamic ring grouping. Possible grouping types for the driver are MAC_GROUP_TYPE_STATIC or MAC_GROUP_TYPE_DYNAMIC. If the driver can dynamically grow and shrink ring groups, then it should advertise the MAC_GROUP_TYPE_DYNAMIC group type and implement mr_gaddring() and mr_gremring() entry points.

mr_flags

Set by the driver to indicate various conditions. Currently, MAC_RINGS_VLAN_TRANSPARENT is the possible value to indicate the hardware is capable of transparent VLANs.

mr_version

Set by the driver to indicate the version of the rings capability that the driver implements. The current revision level is MAC_RINGS_VERSION_1.

mr_rnum

Set by the driver to indicate the total number of RX or TX rings the driver implements.

mr_gnum

Set by the driver to indicate the total number of RX or TX ring groups the hardware implements.

mr_rget

A driver entry point to get specific ring information for each RX and TX ring the hardware implements.

mr_gget

A driver entry point to get the specific information for each RX and TX ring group the driver implements.

mr_gaddring

A driver entry point to add a ring to a driver ring group. This entry point is implemented for drivers who support dynamic ring grouping.

mr_gremring

A driver entry point to remove a specific ring from a driver ring group.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/header
Interface Stability
Committed

See Also

attributes(5), mac_capab_rings(9E), mac_group_info(9E), mc_getcapab(9E), mac_register(9S)