JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Properties and Data Structures     Oracle Solaris 11.1 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Data Structures for Drivers

aio_req(9S)

audio_engine_ops(9S)

blksize(9P)

buf(9S)

cb_ops(9S)

copyreq(9S)

copyresp(9S)

datab(9S)

dblk(9S)

ddi_device_acc_attr(9S)

ddi_dma_attr(9S)

ddi_dma_cookie(9S)

ddi_dmae_req(9S)

ddi_dma_lim(9S)

ddi_dma_lim_sparc(9S)

ddi_dma_lim_x86(9S)

ddi_dma_req(9S)

ddi_fm_error(9S)

ddi-forceattach(9P)

ddi_idevice_cookie(9S)

ddi-no-autodetach(9P)

ddi-no-modunload(9P)

device-blksize(9P)

device-nblocks(9P)

device-pblksize(9P)

devmap_callback_ctl(9S)

dev_ops(9S)

fmodsw(9S)

free_rtn(9S)

gld_mac_info(9S)

gld_stats(9S)

hook_nic_event(9S)

hook_pkt_event(9S)

hook_t(9S)

inquiry-device-type(9P)

inquiry-product-id(9P)

inquiry-revision-id(9P)

inquiry-serial-no(9P)

inquiry-vendor-id(9P)

iocblk(9S)

iovec(9S)

kstat(9S)

kstat_intr(9S)

kstat_io(9S)

kstat_named(9S)

linkblk(9S)

lso_basic_tcp_ipv4(9S)

mac_callbacks(9S)

mac_capab_lso(9S)

mac_capab_rings(9S)

mac_group_info(9S)

mac_register(9S)

mac_ring_info(9S)

mblk(9S)

modldrv(9S)

modlinkage(9S)

modlmisc(9S)

modlstrmod(9S)

module_info(9S)

msgb(9S)

Nblock(9P)

net_inject_t(9S)

net_instance_t(9S)

no-involuntary-power-cycles(9P)

pblksize(9P)

pm(9P)

pm-components(9P)

qband(9S)

qinit(9S)

queclass(9S)

queue(9S)

removable-media(9P)

scsi_address(9S)

scsi_arq_status(9S)

scsi_asc_key_strings(9S)

scsi_device(9S)

scsi_extended_sense(9S)

scsi_hba_tran(9S)

scsi_inquiry(9S)

scsi_pkt(9S)

scsi_status(9S)

size(9P)

sof_ops(9S)

streamtab(9S)

stroptions(9S)

tuple(9S)

uio(9S)

usb_bulk_request(9S)

usb_callback_flags(9S)

usb_cfg_descr(9S)

usb_client_dev_data(9S)

usb_completion_reason(9S)

usb_ctrl_request(9S)

usb_dev_descr(9S)

usb_dev_qlf_descr(9S)

usb_ep_descr(9S)

usb_if_descr(9S)

usb_intr_request(9S)

usb_isoc_request(9S)

usb_other_speed_cfg_descr(9S)

usb_request_attributes(9S)

usb_string_descr(9S)

mac_register

- MAC device driver registration data structure

Synopsis

#include <sys/mac_provider.h>
#include <sys/mac_ether.h>

Interface Level

Solaris architecture specific (Solaris DDI)

Description

The mac_register data structure is passed by device drivers to the MAC layer when registering using mac_register(9F).

Structure Members

uint_t          m_version;              /* set by framework */
const char      *m_type_ident;
void            *m_driver;
dev_info_t      *m_dip;
uint_t          m_instance;
uint8_t         *m_src_addr;
uint8_t         *m_dst_addr;
mac_callbacks_t *m_callbacks;
uint_t          m_min_sdu;
uint_t          m_max_sdu;
void            *m_pdata;
size_t          m_pdata_size;
mac_priv_prop_t *m_priv_props;
uint32_t          m_margin;

The following fields of mac_register_t must be set by the device driver before invoking the mac_register()entry point:

m_version

Set by mac_alloc(9F), device drivers should not modify this field.

m_type_ident

Must be set to one of the following depending on the type of device being registered.

MAC_PLUGIN_IDENT_ETHER

Ethernet driver

m_driver

Driver handle, opaque to the framework, usually points to a per-driver instance data structure. Passed back as argument to driver's entry points invoked by the framework.

m_dip

Pointer to the driver instance dev_info structure, see attach(9E).

m_instance

Used by the driver to specify the instance number to be associated with the MAC being registered. This value should always specified by 0.

m_src_addr

Pointer to the primary MAC address value of the MAC instance.

m_dst_addr

Pointer to the destination MAC address value of a fixed destination MAC address. This field is optional and should be set to NULL for regular device drivers.

m_callbacks

Pointer to an instance of the mac_callbacks(9S) structure.

m_min_sdu

Minimum Service Data Unit size, the minimum packet size, not including the MAC header, that the device can transmit. This can be zero if the device driver can handle any required padding.

m_max_sdu

Maximum Service Data Unit size, the maximum packet size, not including the MAC header, that can be transmitted by the device. For Ethernet, this number is commonly referred to as the MTU (maximum transmission unit.)

m_priv_props

Array of driver-private property names, terminated by a null pointer.

m_margin

Drivers set this value to the amount of data in bytes that the device can transmit beyond m_max_sdu. For example, if an Ethernet device can handle packets whose payload section is no greater than 1522 bytes and m_max_sdu is set to 1500 (as is typical for Ethernet), then m_margin is set to 22.

See mac_register(9F) for more information about the use of these fields.

The driver is responsible for allocating the memory pointed to by the fields m_priv_props, m_src_addr, and m_dst_addr. The driver can free this memory after the call to mac_register() returns.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/header
Interface Stability
Committed

See Also

attributes(5), attach(9E), mac_register(9F), mac_callbacks(9S)