JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Properties and Data Structures     Oracle Solaris 11.1 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Data Structures for Drivers

aio_req(9S)

audio_engine_ops(9S)

blksize(9P)

buf(9S)

cb_ops(9S)

copyreq(9S)

copyresp(9S)

datab(9S)

dblk(9S)

ddi_device_acc_attr(9S)

ddi_dma_attr(9S)

ddi_dma_cookie(9S)

ddi_dmae_req(9S)

ddi_dma_lim(9S)

ddi_dma_lim_sparc(9S)

ddi_dma_lim_x86(9S)

ddi_dma_req(9S)

ddi_fm_error(9S)

ddi-forceattach(9P)

ddi_idevice_cookie(9S)

ddi-no-autodetach(9P)

ddi-no-modunload(9P)

device-blksize(9P)

device-nblocks(9P)

device-pblksize(9P)

devmap_callback_ctl(9S)

dev_ops(9S)

fmodsw(9S)

free_rtn(9S)

gld_mac_info(9S)

gld_stats(9S)

hook_nic_event(9S)

hook_pkt_event(9S)

hook_t(9S)

inquiry-device-type(9P)

inquiry-product-id(9P)

inquiry-revision-id(9P)

inquiry-serial-no(9P)

inquiry-vendor-id(9P)

iocblk(9S)

iovec(9S)

kstat(9S)

kstat_intr(9S)

kstat_io(9S)

kstat_named(9S)

linkblk(9S)

lso_basic_tcp_ipv4(9S)

mac_callbacks(9S)

mac_capab_lso(9S)

mac_capab_rings(9S)

mac_group_info(9S)

mac_register(9S)

mac_ring_info(9S)

mblk(9S)

modldrv(9S)

modlinkage(9S)

modlmisc(9S)

modlstrmod(9S)

module_info(9S)

msgb(9S)

Nblock(9P)

net_inject_t(9S)

net_instance_t(9S)

no-involuntary-power-cycles(9P)

pblksize(9P)

pm(9P)

pm-components(9P)

qband(9S)

qinit(9S)

queclass(9S)

queue(9S)

removable-media(9P)

scsi_address(9S)

scsi_arq_status(9S)

scsi_asc_key_strings(9S)

scsi_device(9S)

scsi_extended_sense(9S)

scsi_hba_tran(9S)

scsi_inquiry(9S)

scsi_pkt(9S)

scsi_status(9S)

size(9P)

sof_ops(9S)

streamtab(9S)

stroptions(9S)

tuple(9S)

uio(9S)

usb_bulk_request(9S)

usb_callback_flags(9S)

usb_cfg_descr(9S)

usb_client_dev_data(9S)

usb_completion_reason(9S)

usb_ctrl_request(9S)

usb_dev_descr(9S)

usb_dev_qlf_descr(9S)

usb_ep_descr(9S)

usb_if_descr(9S)

usb_intr_request(9S)

usb_isoc_request(9S)

usb_other_speed_cfg_descr(9S)

usb_request_attributes(9S)

usb_string_descr(9S)

usb_bulk_request

- USB bulk request structure

Synopsis

#include  <sys/usb/usba.h>

Interface Level

Solaris DDI specific (Solaris DDI)

Description

A bulk request (that is, a request sent through a bulk pipe) is used to transfer large amounts of data in reliable but non-time-critical fashion. Please refer to Section 5.8 of the USB 2.0 specification for information on bulk transfers. (The USB 2.0 specification is available at www.usb.org.)

The fields in the usb_bulk_req_t are used to format a bulk request. Please see below for acceptable combinations of flags and attributes.

The usb_bulk_req_t fields are:

uint_t          bulk_len;       /* number of bytes to xfer      */
                                /* Please see */
                                /* usb_pipe_get_max_bulk_xfer_size(9F) */
                                /* for maximum size */
mblk_t          *bulk_data;     /* the data for the data phase  */
                                /* IN or OUT: allocated by client */
uint_t          bulk_timeout;   /* xfer timeout value in secs   */
                                /* If set to zero, defaults to 5 sec */
usb_opaque_t    bulk_client_private; /* Client specific information */
usb_req_attrs_t bulk_attributes; /* xfer-attributes     */

/* Normal callback function, called upon completion. */
void            (*bulk_cb)(
                    usb_pipe_handle_t ph, struct usb_bulk_req *req);

/* Exception callback function, for error handling. */
void            (*bulk_exc_cb)(
                    usb_pipe_handle_t ph, struct usb_bulk_req *req);

/* set by USBA/HCD framework on completion */
usb_cr_t        bulk_completion_reason; /* overall success status */
                                   /* See usb_completion_reason(9S) */
usb_cb_flags_t  bulk_cb_flags; /* recovery done by callback hndlr */
                                   /* See usb_callback_flags(9S) */

Request attributes define special handling for transfers. The following attributes are valid for bulk requests:

USB_ATTRS_SHORT_XFER_OK

USB framework accepts transfers where less data is received than expected.

USB_ATTRS_AUTOCLEARING

USB framework resets pipe and clears functional stalls automatically on exception.

USB_ATTRS_PIPE_RESET

USB framework resets pipe automatically on exception.

Please see usb_request_attributes(9S) for more information.

Bulk transfers/requests are subject to the following constraints and caveats:

1) The following table indicates combinations of usb_pipe_bulk_xfer() flags argument and fields of the usb_bulk_req_t request argument (X = don't care).

Flags     Type  Attributes       Data   Timeout Semantics
---------------------------------------------------------------
 X         X     X                ==NULL X      illegal

 X         X     ONE_XFER         X      X      illegal

 no sleep  IN    !SHORT_XFER_OK   !=NULL 0      See  note (A)

 no sleep  IN    !SHORT_XFER_OK   !=NULL > 0    See  note (B)

 sleep     IN    !SHORT_XFER_OK   !=NULL 0      See  note (C)

 sleep     IN    !SHORT_XFER_OK   !=NULL > 0    See  note (D)

 no sleep  IN    SHORT_XFER_OK    !=NULL 0      See  note (E)

 no sleep  IN    SHORT_XFER_OK    !=NULL > 0    See  note (F)

 sleep     IN    SHORT_XFER_OK    !=NULL 0      See  note (G)

 sleep     IN    SHORT_XFER_OK    !=NULL > 0    See  note (H)

 X         OUT   SHORT_XFER_OK   X       X      illegal
        
 no sleep  OUT   X               !=NULL  0      See  note (I)

 no sleep  OUT   X               !=NULL  > 0    See  note (J)

 sleep     OUT   X               !=NULL  0      See  note (K)

 sleep     OUT   X               !=NULL  > 0    See  note (L)

Table notes:

A). Fill buffer, no timeout, callback when bulk_len is transferred.
B). Fill buffer, with timeout; callback when bulk_len is transferred.
C). Fill buffer, no timeout, unblock when bulk_len is transferred; no callback.
D). Fill buffer, with timeout; unblock when bulk_len is transferred or a timeout occurs; no callback.
E) Fill buffer, no timeout, callback when bulk_len is transferred or first short packet is received.
F). Fill buffer, with timeout; callback when bulk_len is transferred or first short packet is received.
G). Fill buffer, no timeout, unblock when bulk_len is transferred or first short packet is received; no callback.
H). Fill buffer, with timeout; unblock when bulk_len is transferred, first short packet is received, or a timeout occurs; no callback.
I). Empty buffer, no timeout; callback when bulk_len is transferred.
J) Empty buffer, with timeout; callback when bulk_len is transferred or a timeout occurs.
K). Empty buffer, no timeout; unblock when bulk_len is transferred; no callback.
L). Empty buffer, with timeout; unblock when bulk_len is transferred or a timeout occurs; no callback.

2) bulk_len must be > 0. bulk_data must not be NULL.

3) Bulk_residue is set for both READ and WRITE. If it is set to 0, it means that all of the data was transferred successfully. In case of WRITE it contains data not written and in case of READ it contains the data NOT read so far. A residue can only occur because of timeout or bus/device error. (Note that a short transfer for a request where the USB_ATTRS_SHORT_XFER_OK attribute is not set is considered a device error.) An exception callback is made and completion_reason will be non-zero.

4) Splitting large Bulk xfers: Due to internal constraints, the USBA framework can only do a limited size bulk data xfer per request. A client driver may first determine this limitation by calling the USBA interface (usb_pipe_get_max_bulk_xfer_size(9F)) and then restrict itself to doing transfers in multiples of this fixed size. This forces a client driver to do data xfers in a loop for a large request, splitting it into multiple chunks of fixed size.

The bulk_completion_reason indicates the status of the transfer. See usb_completion_reason(9S) for usb_cr_t definitions.

The bulk_cb_flags are set prior to calling the exception callback handler to summarize recovery actions taken and errors encountered during recovery. See usb_callback_flags(9S) for usb_cb_flags_t definitions.

--- Callback handling ---

All usb request types share the same callback handling. See usb_callback_flags(9S) for details.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
PCI-based systems
Interface Stability
Committed
Availability
system/io/usb

See Also

usb_alloc_request(9F), usb_pipe_bulk_xfer(9F), usb_pipe_ctrl_xfer(9F), usb_pipe_get_max_bulk_transfer_size(9F), usb_pipe_intr_xfer(9F), usb_pipe_isoc_xfer(9F), usb_callback_flags(9S), usb_completion_reason(9S), usb_ctrl_request(9S), usb_intr_request(9S), usb_isoc_request(9S), usb_request_attributes(9S)