JavaScript is required to for searching.
Skip Navigation Links
Exit Print View
man pages section 9: DDI and DKI Properties and Data Structures     Oracle Solaris 11.1 Information Library
search filter icon
search icon

Document Information

Preface

Introduction

Data Structures for Drivers

aio_req(9S)

audio_engine_ops(9S)

blksize(9P)

buf(9S)

cb_ops(9S)

copyreq(9S)

copyresp(9S)

datab(9S)

dblk(9S)

ddi_device_acc_attr(9S)

ddi_dma_attr(9S)

ddi_dma_cookie(9S)

ddi_dmae_req(9S)

ddi_dma_lim(9S)

ddi_dma_lim_sparc(9S)

ddi_dma_lim_x86(9S)

ddi_dma_req(9S)

ddi_fm_error(9S)

ddi-forceattach(9P)

ddi_idevice_cookie(9S)

ddi-no-autodetach(9P)

ddi-no-modunload(9P)

device-blksize(9P)

device-nblocks(9P)

device-pblksize(9P)

devmap_callback_ctl(9S)

dev_ops(9S)

fmodsw(9S)

free_rtn(9S)

gld_mac_info(9S)

gld_stats(9S)

hook_nic_event(9S)

hook_pkt_event(9S)

hook_t(9S)

inquiry-device-type(9P)

inquiry-product-id(9P)

inquiry-revision-id(9P)

inquiry-serial-no(9P)

inquiry-vendor-id(9P)

iocblk(9S)

iovec(9S)

kstat(9S)

kstat_intr(9S)

kstat_io(9S)

kstat_named(9S)

linkblk(9S)

lso_basic_tcp_ipv4(9S)

mac_callbacks(9S)

mac_capab_lso(9S)

mac_capab_rings(9S)

mac_group_info(9S)

mac_register(9S)

mac_ring_info(9S)

mblk(9S)

modldrv(9S)

modlinkage(9S)

modlmisc(9S)

modlstrmod(9S)

module_info(9S)

msgb(9S)

Nblock(9P)

net_inject_t(9S)

net_instance_t(9S)

no-involuntary-power-cycles(9P)

pblksize(9P)

pm(9P)

pm-components(9P)

qband(9S)

qinit(9S)

queclass(9S)

queue(9S)

removable-media(9P)

scsi_address(9S)

scsi_arq_status(9S)

scsi_asc_key_strings(9S)

scsi_device(9S)

scsi_extended_sense(9S)

scsi_hba_tran(9S)

scsi_inquiry(9S)

scsi_pkt(9S)

scsi_status(9S)

size(9P)

sof_ops(9S)

streamtab(9S)

stroptions(9S)

tuple(9S)

uio(9S)

usb_bulk_request(9S)

usb_callback_flags(9S)

usb_cfg_descr(9S)

usb_client_dev_data(9S)

usb_completion_reason(9S)

usb_ctrl_request(9S)

usb_dev_descr(9S)

usb_dev_qlf_descr(9S)

usb_ep_descr(9S)

usb_if_descr(9S)

usb_intr_request(9S)

usb_isoc_request(9S)

usb_other_speed_cfg_descr(9S)

usb_request_attributes(9S)

usb_string_descr(9S)

mac_group_info

- group Information data structure

Synopsis

#include <sys/mac_provider.h>

Interface Level

Solaris architecture specific (Solaris DDI)

Description

The mac_group_info structure is used by a network device driver to describe its ring groups and the groups capabilities. The structure is used as the argument to the mr_gget(9E) driver entry point when querying the group and its capabilities.

Structure Members

mac_group_driver_t              mgi_driver;
mac_group_start_t               mgi_start;
mac_group_stop_t                mgi_stop;
uint_t                          mgi_count;
mac_group_flags_t               mgi_flags;
mac_group_addmac_t              mgi_addmac;
mac_group_remmac_t              mgi_remmac;
mac_group_addvlan_t             mgi_addvlan;
mac_group_remvlan_t             mgi_remvlan;
mac_group_setmtu_t              mgi_setmtu;
mac_group_getsriov_info_t       mgi_getsriov_info;
mgi_driver

Filled by the driver as handle to the driver's group structure.

mgi_start

The driver entry point for starting a driver's ring group.

mgi_stop

The driver entry point for stopping a driver ring group.

mgi_count

The number of rings that are members of this ring group.

mgi_flags

Set by the driver to indicate various ring group capabilities including whether the group is the default ring group for the interface, whether the group is a pool of non-active rings, whether the group implements tagging/stripping for all VLANs, or implements transparent VLANs.

mgi_addmac

The driver entry point to program a MAC address into the driver's hardware for this ring group. This entry is only for RX ring groups. For SRIOV-capable devices, the MAC_GROUP_MACADDR_PRIMARY flag will be used to identify which of the MAC addressed for the group is the primary MAC address of the VF.

mgi_remmac

The driver entry point to remove a previously programmed MAC address.

mgi_addvlan

The driver entry point to add a VLAN filter to the ring group. The MAC_VLAN_FILTER_TAG_ENABLE flag will be set if the group is to provide tagging/stripping offload.

mgi_remvlan

The driver entry point to remove a VLAN filter.

mgi_setmtu

The driver entry point for the MAC layer to set the MTU for the ring group.

mgi_getsriov_info

The driver entry point to get the SRIOV information associated with this group.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/header
Interface Stability
Committed

See Also

attributes(5), mac_capab_rings(9E), mac_group_info(9E), mr_gget(9E), mac_register(9S)