|Skip Navigation Links|
|Exit Print View|
|man pages section 9: DDI and DKI Properties and Data Structures Oracle Solaris 11.1 Information Library|
- packet event structure passed through to hooks
Solaris DDI specific (Solaris DDI).
The net_instance_t data structure defines a collection of instances to be called when relevant events happen within IP. The value returned by the nin_create() function is stored internally and passed back to both the nin_destroy() and nin_shutdown() functions as the second argument. The netid_t passed through to each function can be used to uniquely identify each instance of IP.
char *nin_name; void *(*nin_create)(const netid_t); void (*nin_destroy)(const netid_t, void *); void (*nin_shutdown)(const netid_t, void *);
Name of the owner of the instance.
Function to be called when a new instance of IP is created.
Function to be called when an instance of IP is being destroyed.
Function to be called when an instance of IP is being shutdown. nin_shutdown() is called before nin_destroy() is called.
See attributes(5) for descriptions of the following attributes: